P14 / Windows 10 Disk Access Freeze Issues

Discussion in 'Windows Guest OS Discussion' started by AdamD5, Sep 19, 2018.

  1. AdamD5

    AdamD5 Bit Poster

    Messages:
    1
    I've checked the forums and have seen several P14 responsiveness issue threads, but none seem to be exactly the same issue that I have been experiencing, so...

    Since upgrading to v14 my Windows 10 (10.0.17134) VM disk access regularly, and unpredictably "freezes" at 100% active, but with 0KB/s read/write causing applications to become unresponsive.
    Suspending & Resuming the VM appears to "flush" the issue and the read/write on the affected disk immediately resumes. The issue may then alternate between C: & E: drives in sequence, requiring multiple suspend/resume operations until application completes its file operation and becomes responsive to user input again.

    I have submitted technical data, ID: 276226503

    Screen Shot 2018-09-19 at 12.30.33.png
     
  2. RogerH6

    RogerH6 Kilo Poster

    Messages:
    153
  3. DonA2

    DonA2 Bit Poster

    Messages:
    43
    Yes, I reported that problem on the other thread, it does seem very similar to this. Still happening too, I went back to v. 14 to suffer it out hoping it will help get it fixed (but no requests for additional info). Unless the Parallels folks know what the problem(s) is/are and are working to get a fix out, it is disconcerting that there has not been much of any communication on these performance issues - even an acknowledgment that there are issue(s) and they are working on fixes would be a relief. I fear this is how it's going to work moving forward now...
     
  4. RogerH6

    RogerH6 Kilo Poster

    Messages:
    153
    I have found that if I disable the actual hibernate (set standbydelay to 0), so it does not go to the standby state, 99.9% of the problems seem to disappear. Boots, shuts down, disks keep working, applications work and respond to the keyboard/mouse OK. So while a bit of a waste of power, this seems to be the answer at present.
     
  5. DonA2

    DonA2 Bit Poster

    Messages:
    43
    Interesting, how do you do this, are you speaking about in Parallels or Windows 10? I am not sure I Have hibernate turned on in Windows 10..
     
  6. RogerH6

    RogerH6 Kilo Poster

    Messages:
    153
    Macintosh.

    From command prompt:
    sudo pmset standbydelay 0<enter>

    I have all hibernation disabled in Windows, but was controlling sleep using the Mac application.

    With this set, it has run yesterday afternoon, and now all day doing a lot of things without a glitch.
     
    DonA2 likes this.
  7. DonA2

    DonA2 Bit Poster

    Messages:
    43
    This seems to do the trick for me too so far! I have been running since yesterday afternoon without a single problem. I think it requires a restart? I did one anyway...

    This should give the @parallels folks a great clue as to what the problem is, I would think!

    Thanks @RogerH6 for finding this!
     
  8. RogerH6

    RogerH6 Kilo Poster

    Messages:
    153
    Thanks for the confirmation. It does appear that Parallels 14, for some unknown reason is failing in a suite of ways when the system hibernates. :(
    At least this means we having working systems again, and possibly may tell Parallels what the problem really is.....
     
  9. DonA2

    DonA2 Bit Poster

    Messages:
    43
    Ever since this afternoon, Windows is very slow again. I actually tried reinstalling this command in terminal and restarting, but I am getting that horrible delay on keystrokes. This is terrible. Why have we not heard ANYTHING from Parallels on this, even acknowledging the problem would be nice? I am getting to the end of my rope, it may be time to start looking at VMWare. My needs are simple in my Windows VMs, but this runs like total ****.
     
  10. LukeH4

    LukeH4 Bit Poster

    Messages:
    9
    I have also been having performance problems with P14 + Win10 guest. (Mojave 10.14 host)

    Symptoms are: VMs freeze for 15-30 seconds - completely unresponsive, eventually whatever is hanging gets unstuck and everything resumes.

    Also, Using Parallels shared folders (Home folder) when saving files from the Windows VM to a folder on the Mac, there is a very long freeze/pause at the 100% mark of the progress bar. The Windows file copy will just sit there and hang for 30 sec and finally close. Once in a while, the progress bar never closes and I have to kill Explorer.exe. Latest Guest Additions are installed... Win10 fully up to date and patched.

    Not sure what's going on-- v13 never had this issue. Not sure where the bug is- Parallels, Apple (Mojave) or Windows (1809) .... or a combination.... ¯\_(ツ)_/¯
     
  11. Sathiya@Parallels

    Sathiya@Parallels Staff Member

    Messages:
    733
    Hi LukeH4. If you have any antivirus/firewall protection enabled on the Mac, please disable and check for the issue.
     
  12. LukeH4

    LukeH4 Bit Poster

    Messages:
    9
    @Sathiya@Parallels :
    No, I have no antivirus software running on the Mac, and firewall is disabled.
     
  13. DonA2

    DonA2 Bit Poster

    Messages:
    43
    Has there been any update on this? I still suffer from the problem, I am now deciding whether to terminate my subscription and go to another solution. The freezes can be painful at times, a modern laptop running Windows 10 should not be running this poorly. Come on Parallels, fix this!!!!!
     
  14. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,143
    Hi @LukeH4, inside the Windows press the Start button > Cogwheel Settings icon > System > Power and sleep > Additional power settings > Choose what power buttons do > Change settings that are currently unavailable > Turn on fast startup (recommended) > Uncheck > Save changes. If the issue persists, please check out this article to increase the startup speed.
     
  15. DonA2

    DonA2 Bit Poster

    Messages:
    43
    Thanks, but this is not a startup problem - it occurs regularly and constantly throughout the day.
     
  16. DanielH22

    DanielH22 Bit Poster

    Messages:
    3
    Is there a solution to the problem you have described?
     
  17. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    4,140
    Do you have the same issue? Which Parallels Desktop version and macOS are you using?
     
  18. DanielH22

    DanielH22 Bit Poster

    Messages:
    3
  19. DanielH22

    DanielH22 Bit Poster

    Messages:
    3

Share This Page