Parallels 8 - Win 7 USB 3.0 support shaky?

Discussion in 'Windows Guest OS Discussion' started by Yourguide, Nov 10, 2012.

  1. Yourguide

    Yourguide Bit Poster

    Messages:
    7
    I have been trying to get the USB 3.0 support working with a USB 3.0 external HDD.
    So far it is very unreliable.... after installing the required drivers in my Win 7 VM... I can plug my external USB drive in, direct it to Win 7.... I hear the USB plugged in sound immediately... but it takes about a minute or more for it to assign a drive letter and allow me to use it.
    Then when copying files off or onto the drive it will hang like its not working at all..... then the progress bar will jump to about 3/4... then hang again... usually I have had to cancel out from waiting and waiting.

    If I uncheck the "USB 3" support in Parallels... then everything works solid. I get about 60Mb/s Read and 45Mb/s write to my external drive.
    I haven't been able to perform the read/write tests with USB 3 support since it just hangs.

    Anyone else able to get the USB 3 support working? I have a 15" Retina Macbook Pro.
    Thanks!
     
  2. Alexander Haltman

    Alexander Haltman Parallels Developers

    Messages:
    116
    Please, to help us fix this problem do the next:
    - disable shared webcam, shared bluetooth and shared printers in vm configuration
    - add the next system flags to vm configuration:
    devices.usb.mouse=0; devices.usb.keyboard=0; devices.usb.loglevel=2;
    - enable usb 3.0 support
    - start vm, connect usb hdd to vm and reproduce problem
    - create and send problem report
    - post problem report id here
    - post xhc driver version (which installed in guest) here
     
  3. Yourguide

    Yourguide Bit Poster

    Messages:
    7
    Report ID 19666058
    This time it never did bring up the drive letter.

    Device Manager says "This device cannot start. (Code 10)"

    Report ID 19666505
    After Installing all Windows 7 updates... rebooted and tried the drive again.
    Got a drive letter this time.
    Copied file from external USB drive to internal drive.... had it hang during copying near end of progress bar.... then finished all at once.
    Was able to run speed test this time... and got Read 64MB/s and Write 50 MB/s

    The USB 3 Host Controller Information says Driver Version: 2.1.28.0 Firmware Version: 3025
     
    Last edited: Nov 12, 2012
  4. BayardC

    BayardC Bit Poster

    Messages:
    21
    There are several other reports in this set of forums relating to problems with Parallels 8 and Windows 7
    and USB. Specifically, I (and several other folks) have been unable to 'start' the drivers for the FTDI
    serial/USB adapter cables (yes, Error Code 10), nor can we use our external USB sound cards (in my case,
    as well as some others, the Signalink USB, which is used by a lot of ham radio operators to generate
    digital signals to send on the air - the drivers for which are installed by the Windows Plug-n-Play mechanism,
    and, yes, once again, a "failure to start the driver"). Another post is complaining that s/he can't seem to
    "see" her/his USB flash drives.

    My suspicion is that Parallels did not do a thorough regression test of Parallels 8 and Windows 7 before
    tossing it over the transom. I know that at least one victim, er, customer has escalated it through the
    normal support channels. I don't have an extended support contract, so it would be a waste of my time.

    I'm getting ready to go back into Time Machine and see if I can find a working .pvm directory to try, but
    I'll need to save off my application-specific data first, which will be a major nuisance. If an older .pvm
    (with whatever the last working version of Parallels 7 is/was) can be made to work, I'll be relatively happy.

    I was a software QC engineer for a major UNIX vendor for several years, testing multi-CPU/multi-system
    high availability configurations, and we jumped through hoops (and made the development engineers share
    the pain) of "rolling upgrades" wherein some of the systems in the cluster were at the old revision level and
    some were at the new - we were very careful to make sure that the customer would always have one or
    more systems that stayed up during the entire upgrade process and that any or all of the involved systems
    could be rolled back to the original version if need be, recognizing that there might be some application-specific
    headaches that were outside of our purview. But for a system to stop recognizing devices on a USB bus
    was totally unacceptable and considered a "show-stopper" bug.
     
  5. MicahBM

    MicahBM

    Messages:
    2
    Hello Alexander Haltman (and anyone else who is experiencing USB 3.0 problems with Parallels 8),

    I just upgraded to Build 8.0.18354, as I saw that it offers USB 3.0 support. I have a Seagate FreeAgent GoFlex 750GB USB 3.0 hard drive that I use with my MacBook Air that supports USB 3.0 as well as other PCs that have USB 3.0 capability. On both my Mac and the other PCs, it works flawlessly. However, in Parallels 8, after I plug it in, it took roughly 50 seconds for all drive letters to be assigned to it. Furthermore, when I actually try to copy data to or from it or run a speedtest using AJA System Test, Windows Explorer freezes up and the drive is unusable. I downloaded the latest USB 3.0 driver in my guest operating system (Windows 7 Enterprise) as instructed when I enabled USB 3.0 in the VM configuration. Essentially, I am seeing almost the exact same behavior as Yourguide, possibly worse. I followed Alexander's instructions and submitted a problem report. The problem report ID is 20502612. The driver version for the Renesas Electronics USB 3.0 Host Controller has driver version 2.1.28.0. It was the driver that Parallels directs you to download and install in the guest after enabling USB 3.0 support in the VM configuration page.

    I hope this information is helpful and I look forward to Parallels getting to the bottom of what is going on.
    Thank you.
     
  6. KonstantinO

    KonstantinO Parallels Developers

    Messages:
    38
    Hello, thank you for feedback.

    Can you check your USB 3.0 disk with Windows 8 VM ?
     
  7. MicahBM

    MicahBM

    Messages:
    2
    I just created a fresh Windows 8 Enterprise VM and tested my Seagate FreeAgent GoFlex 750GB USB 3.0 hard drive with it. I plugged it in and the drive was immediately recognized and seems to be performing well.

    I also have a SanDisk Extreme USB 3.0 32GB flash drive that I tested with my Windows 7 VM and see the exact same behavior as my hard drive.

    On a Windows 8 VM, I see different behavior. Whenever the Windows 8 VM has been cleanly booted and I plug the flash drive in for the first time, nothing happens. No usable drive letter is assigned and the flash drive does not show up in the "Safely Remove Hardware and Eject Media". If I remove the flash drive and then re-insert it into the same USB port, it works flawlessly. I can continue to remove it and re-insert it with no problems. If I insert it into the other USB 3.0 port on my 2012 MacBook Air, it gives me the same behavior the first time of not being recognized at all. Once I unplug it and re-insert it into that same point, it works fine after that. When I power off the VM and then restart it, I get the same exact behavior and it is reproducible every time.

    It seems like the Windows 7 issues are widespread across different high speed USB 3.0 storage devices. The Windows 8 issue with my USB 3.0 flash is the only one I have come across thus far, but I haven't tested any other USB 3.0 devices.
     
  8. Br.uno

    Br.uno Bit Poster

    Messages:
    9
    there is definitely a problem with parallels 8 and windows 7 using usb3.

    my vm with win 7 does not even recognize the usb3 external hard drive.
    on the same imac the vm win 8 has no problems at all.

    please fix..... thx.
     
  9. KonstantinO

    KonstantinO Parallels Developers

    Messages:
    38
    Hello.

    Can you create, send to us and post numder here a problem report with unrecognized hard drive attached to VM ?
     
  10. Br.uno

    Br.uno Bit Poster

    Messages:
    9
    strange...

    now it works.... however, i have the feeling that i don't get quite the same performance as with the vm running win 8...
     
    Last edited: Dec 29, 2012
  11. xlikman

    xlikman

    Messages:
    1
    I'm facing the same problems too. Works fine if disable USB 3.0 support. When Enabled, it takes along time to assign a drive letter, sometimes even say "disk not formatted", scared the hell out of me. I'm running on MAC Mini late 2012, i7-2.3Ghz. Mountain Lion, Win7 Ultimate VM.
    Looking forward for the solution, I'm so in need of the speed boost.
     
  12. Br.uno

    Br.uno Bit Poster

    Messages:
    9
    @KonstantinO
    the problem report number is: 22644586

    i still have problem under windows7-64bit on my imac. my usb3-harddrives are mostly not recognised.
    in the vm of windows 8 it runs smooth.

    and (sometimes) if it gets recognised, the performance is really poor. about the speed of usb2.

    today i deinstalled and re-installed the usb3-driver you recommend. did not help.

    please help, thanks.
     
    Last edited: Feb 26, 2013

Share This Page