Parallels Desktop 10 kernel panics 10.11 on Retina MBP

Discussion in 'Installation and Configuration' started by Bill Standen, Jul 9, 2015.

  1. Bill Standen

    Bill Standen Bit Poster

    This is more just a report than anything, realise it's a beta OS and unsupported.

    Discovered that with some reliability Parallels Desktop 10 will cause a kernel panic when starting up on 10.11b2 and b3 on Retina Macbook Pros. Seems fine on my iMacs but I've been able to replicate this on multiple 15" Retina MBPs running both clean and upgraded 10.11 installs with both pre-existing and fresh installs of Parallels 10.
  2. marat_t

    marat_t Kilo Poster

    Hello Bill, can you collect panic report and memory dump?
  3. Bill Standen

    Bill Standen Bit Poster

    I'll see what I can do as far as getting a full dump. I usually use a VM for remote capture which in this instance is a little awkward.

    I should also clarify this kernel panic occurs right on the start up of Parallels, not the boot of a VM. I'm usually looking at the loading throbber bar, very rarely it'll just get to drawing the Control Centre VM list window.

    Panic report below:

    Anonymous UUID: 5F09B645-92E1-CEFF-687D-1FBE5864DBA5

    Thu Jul 9 20:10:09 2015

    *** Panic Report ***
    panic(cpu 2 caller 0xffffff80085f6f99): "corrupt so_rcv: sb_mb 0 sb_cc 1\n"@/Library/Caches/
    Backtrace (CPU 2), Frame : Return Address
    0xffffff91f5f03cd0 : 0xffffff80080e74d7
    0xffffff91f5f03d50 : 0xffffff80085f6f99
    0xffffff91f5f03e60 : 0xffffff80085cb2ca
    0xffffff91f5f03f00 : 0xffffff80085cb033
    0xffffff91f5f03f60 : 0xffffff800862c9a1
    0xffffff91f5f03fb0 : 0xffffff80081f5d56

    BSD process name corresponding to current thread: prl_naptd
    Boot args: rootless=0

    Mac OS version:

    Kernel version:
    Darwin Kernel Version 15.0.0: Sun Jun 28 00:25:56 PDT 2015; root:xnu-3247.1.36~7/RELEASE_X86_64
    Kernel UUID: E6DB13C9-258E-310A-A791-6F9E324C3726
    Kernel slide: 0x0000000007e00000
    Kernel text base: 0xffffff8008000000
    __HIB text base: 0xffffff8007f00000
    System model name: MacBookPro11,3 (Mac-2BD1B31983FE1663)

    System uptime in nanoseconds: 3062497836238
    last loaded kext at 3062344103067: com.parallels.kext.vnic 10.2.1 29006 (addr 0xffffff7f8b178000, size 32768)
    last unloaded kext at 544323683711: 3 (addr 0xffffff7f8a671000, size 40960)
    loaded kexts:
    com.parallels.kext.vnic 10.2.1 29006
    com.parallels.kext.netbridge 10.2.1 29006
    com.parallels.kext.hypervisor 10.2.1 29006
    com.parallels.kext.usbconnect 10.2.1 29006
    org.virtualbox.kext.VBoxNetAdp 4.3.26
    org.virtualbox.kext.VBoxNetFlt 4.3.26
    org.virtualbox.kext.VBoxUSB 4.3.26
    org.virtualbox.kext.VBoxDrv 4.3.26
    com.citrix.driver.net6im 1.1.9
    com.deterministicnetworks.driver.dne 1.0.18
    com.deterministicnetworks.driver.dniregistry 1.0.7 4.4.0d77 1.9.5d0 1.70 4.4.0d77 110.20.19 2.5.0d0 1.0.0 1 3.0 3.7.7 272.40 1 1.0.0d13 1.0.1 3.6.1 7.0.0 10.0.6 1 1 10.0.8 4.4.0d77 208 1.2.13 5.36.0 3.1 3.11.26 4.0.0 10.0.8 3.0.5 245.4 3.6.0 245.4 1.0.0d1 1.0.0 37 2.8.0 3.1.5 1000.8.6a2 161.0.0 2.0 4.0 1.8 2.1 4.0 1.7 163 3 8 900.4.1 11 1.0 272.40 525 1 10.0.6 10.0.6 107 4.4.0d77 4.4.0d77 272.40 272.40 203.7 1.2.0 1.0.13d1 1.1.0 2.4.1 3.11.26 1.0.0 1.0.0 3.1.9 6.0.0d7 3.11.26 203.2.0 2.4.1 3.7.7 1.0.0 3.7.7 1.0.1 250.4 900.4.1 1.0.1 509 900.4.1 2.8.0 4.1.2 4.1.2 2.0.2 4.0.1 5.0.6 1100.19 1.0.1b8 3.2 1.0.4 1.0.1 1.0.1 2.0 2.0 2.0.0 1.1 300.0 1.0.0d1 2 1.0.5 1.0 414 2.1 31 28.30 1.0.1 1.0 4.0 2.9 1.4 1 1 1.0
  4. marat_t

    marat_t Kilo Poster

    could you please collect a problem report right after rebooting as described here . After the report is sent you will see its unique 8-digit number in the pop-up window on your screen. Specify this ID number here.
  5. Bill Standen

    Bill Standen Bit Poster

    Won't be able to do the first method, it'll have panicked again by then. I'll see what ican pull from the terminal when I'm next in front of a computer.
  6. marat_t

    marat_t Kilo Poster

    it's still better to collect problem report. you can do the following after reboot.
    - open Terminal and execute
    prlsrvctl problem-report --send --stand-alone​
    this will send the report and will show its ID number in the Terminal window.
    Last edited: Jul 11, 2015
  7. Bill Standen

    Bill Standen Bit Poster

    Hi Marat, apologies for the delay but only just got to sit down with the MBPs again today.

    Under both 10.11b3 and b4 "prlsrvctl problem-report --send --stand-alone" also results in a kernel panic. In fact, even running just "prlctl list -a" also causes an immediate panic.

    The machines in question are all Late 2013 Retina MBPs with the 2.6GHz i7, 16GB RAM, 512GB SSDs and GT750M GPUs. All exhibit the same behaviour whether with a clean install or an upgrade from 10.10 and they've been otherwise rock solid on b3 since it was released.

    I'd be fascinated to get access to the Parallels 11 beta to try it on the same machines as it's currently a show stopper for upgrading a client to El Cap.
  8. Bill Standen

    Bill Standen Bit Poster

    Issue persists on 10.11 Beta 5 with both the main Parallels application and the prlctl command line tool.
  9. ThirdI

    ThirdI Bit Poster

    I am having the same problem, but with a late-2013 Mac Pro, 32 GB Memory, first running OS X Yosemite and, most recently, the beta OS X El Capitan. I sent a problem report via terminal using id: 73290204 I have not had any luck with a resolution--it has persisted since the original Parallels install. I am using Parallels 10.
  10. Chen1

    Chen1 Bit Poster

    I am running into a kernel panic as well. However, my panic signature is different.
    Host is running El Capitan. Guest OS is Windows 10 Pro, hardware is iMac 5K. I am running Parallel Desktop 11.
    It's quite disappointing after paid an upgrade and it turns out not working.

    Anonymous UUID: D66711E7-AFAD-617F-DB91-436E2133BCAD

    Sat Sep 19 00:17:21 2015

    *** Panic Report ***
    panic(cpu 0 caller 0xffffff8018e8e1fe): /Library/Caches/ Assertion failed: !mem->private && !mem->fictitious
    Backtrace (CPU 0), Frame : Return Address
    0xffffff920ce2b950 : 0xffffff8018e8e307
    0xffffff920ce2b9d0 : 0xffffff8018e8e1fe
    0xffffff920ce2b9f0 : 0xffffff8018f4ed4c
    0xffffff920ce2ba20 : 0xffffff8018f0912f
    0xffffff920ce2bb20 : 0xffffff8018f233b8
    0xffffff920ce2bc00 : 0xffffff7f9ee79d16
    0xffffff920ce2bc30 : 0xffffff7f9ee82a38
    0xffffff920ce2bd80 : 0xffffff7f9ee7c72c
    0xffffff920ce2be50 : 0xffffff7f9ee7ab62
    0xffffff920ce2bed0 : 0xffffff80194be10f
    0xffffff920ce2bf10 : 0xffffff8018f89c90
    0xffffff920ce2bfb0 : 0xffffff8018fbf186
    Kernel Extensions in backtrace:
  11. Chen1

    Chen1 Bit Poster

    Also tried with my wife's MacBookPro Retina from 2012. Same panic when windows 10 is rebooting.
  12. Alvaro1

    Alvaro1 Bit Poster

    One more with the same Kernel Panic caused by Parallels network daemon prl_naptd. This is not related with the new Parallels version because also I tested with Parallels 8 and 10 (maybe when you install an older version some componentes for the newer are still present). It's very annoyed because it's completely random and even after reboot if you try to "reopen" all application the kernel panic will happen again. The only way is to boot, wait around 10 seconds and then you can open Parallels without problem. I also tried with SIP enable/disable and exactly the same issue.

    I have a webex tonight, I guess to try to find the issue, but my advice at this moment to everyone is NOT upgrade to El Capitan if you are using Parallels in a MacBook.
  13. Alvaro1

    Alvaro1 Bit Poster

    Anyone with any idea? I could see a workaround disabling all interfaces in the Macbook, but of course, that means a very little functionality of the VM.
  14. Alvaro1

    Alvaro1 Bit Poster

    Just in case someone has the same kernel panics, it getting much better (not 100% but almost) if you disable IPv6 from ALL interfaces (not only WIFI/Ethernet but Bluetooth,Firewire, etc.). The command to do it from a terminal: networksetup -setv6off Wi-Fi (change Wifi with the name of every interface, the ones with white space in the name, put in with quotes " ")
  15. Alvaro1

    Alvaro1 Bit Poster

    Just a last update, unfortunately this workaround fails in several working in this way is almost impossible. For the time being I had to move to Fusion, an now working without any issue. Very sad the bad support with an issue with a new OS that it's clearly not fully supported, but you can receive every day a message asking you to migrate the latest Parallels version to have a full support for El Capitan.
    TravisP1 likes this.

Share This Page