Parallels Desktop 14 filters display when using Resolution: Scaled

Discussion in 'Installation and Configuration' started by tom_seddon, Oct 15, 2018.

  1. tom_seddon

    tom_seddon Bit Poster

    Messages:
    11
    I use Resolution: Scaled when using Windows 10 in a Parallels VM. I have a retina Macbook Pro and two normal-DPI monitors, and I don't like the way Windows handles displays with mismatching DPIs.

    On whichever Parallels I was using before, 11 I think, this option gave me 3 screens with the same apparent DPI, with a clear, if blocky, scaled-up image on the retina display. Apparently Parallels scaled things up without using any filtering. Here's roughly what it looked like: (I had to cheat and make this image by hand, since I don't have PD11 installed any more, but it's an accurate representation of how it looked)
    [​IMG]

    Here's what it looks like now, on Parallels Desktop 14. The DPI is fine, but there's some filtering being applied during the scaling process, so it looks a bit blurry. I'm sure some people prefer this, but I don't, as I actually find it quite uncomfortable to look at. Without the sharp corners, I can't seem to focus on things properly, which is rather tiring.
    [​IMG]
    I can set up Parallels to have the retina display in high-DPI mode, and then that looks fine... but then I have to deal with the Windows mixed-DPI behaviour! I'd got quite used to having the best of both worlds with PD11, so can I get PD14 to behave the same way?

    Thanks,

    --Tom
     
  2. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,360
    Hi @tom_seddon , please help us with the screenshots explaining the issue, so that we can understand it better and assist you.
     
  3. tom_seddon

    tom_seddon Bit Poster

    Messages:
    11
    Thanks for the response, but I don't understand. Do you not see the images in the post?
    --Tom
     
  4. StanislavZ

    StanislavZ Parallels Developers

    Messages:
    98
    You need to shut down your VM and add
    video.scale_filter=0
    line to boot flags in VM configuration Hardware -> Boot order -> Advanced Settings page.
     
    tom_seddon likes this.
  5. tom_seddon

    tom_seddon Bit Poster

    Messages:
    11
    Excellent - that's done it. Thank you for the response!
    --Tom
     

Share This Page