I got exactly the same message after I installed the latest version on my Mac (Parallels Desktop Build 5.0.9310). This is the first time I installed Parallels on my MacBook Pro. After every start of Parallels that message appears. Reboot of MacOSX doesn't help. I was really confused that Parallels doesn't work the first time I started that application. I submitted the Error to Parallels and checked all the solutions in KB wich didn't helped at all. I didn't hear anything from Parallels so I decided to do some research on my own.
I realized that in Activity Monitor the prl_disp_service doesn't appear. Because every application wich starts at boot has a StartupItem or somewhat like "launchd daemon". I checked the launchd daemon script from parallels wich executes
/Library/Parallels/Parallels Service.app/Contents/Resources/ParallelsDispatcherService start
upon start of MacOSX. Then I debugged that script in Terminal.app with this command:
sudo bash -x /Library/Parallels/Parallels\ Service.app/Contents/Resources/ParallelsDispatcherService start
then something strange appeared at the end of the debug output:
+ RunService start
+ case $1 in
+ StartService
+ '[' $'-YES-\r' '!=' -YES- ']'
+ return
in the ParallelsDispatcherService it happens at this code:
# The start subroutine
StartService () {
# Check if service is enabled
[ "${PARALLELS:=-YES-}" != "-YES-" ] && return
wich means when the PARALLELS property in file /etc/hostconfig is not set to
it doesn't start the services. But when I checked that file /etc/hostconfig everything seems ok, but that comparision [ "${PARALLELS:=-YES-}" != "-YES-" ] fails because of that "\r" character at the end of -YES- (in red above)
I checked the /etc/hostconfig file and compared it to an older TimeMachine backup. Now everything comes clear. After the install of Parallels the line delimiters in /etc/hostconfig are corrupted (DOS-Style line delimiters: \r\n instead of the UNIX line delimiter: \n). In this case the comparision fails and the Parallels Services don't start (ex. the prl_disp_service).
By executing this command in Terminal.app
if this returns
/etc/hostconfig: ASCII text, with CRLF line terminators
you have the same problem as I have.
This can now be fixed with following command executed in Terminal.app:
sudo perl -pi -e 's/\r\n/\n/g' /etc/hostconfig
wich replaces all these DOS-style line delimiters into standard UNIX line delimiters. Now after a reboot or after executing this command in Terminal.app:
sudo launchctl start com.parallels.desktop.launchdaemon
Parallels works fine for me!