Parallels Desktop 8 and Yosemite Update

Discussion in 'General Questions' started by Andrew@Parallels, Aug 5, 2014.

  1. María_José_Tintoré_Espuny

    María_José_Tintoré_Espuny Bit Poster

    Messages:
    1
    Estoy con Marpies. Llevo dos meses usando Yosemite y PD 8 funciona perfectamente. No voy a pagar de nuevo y como estrategia comercial me parece lamentable. Simplemente desactivare las actualizaciones no sea que incluyan algún procedimiento tipo los de obsolescencia programada de algunas impresoras. Hace poco un amigo me pregunto por un programa para usar Windows en su Mac, y esta advertencia inmoral me impidió recomendarle Parallels. Además, las distintas actualizaciones del program ase anuncian con grandes mejoras que luego ni se observan. Si queréis que paguemos el programa todos los años espabilad y darnos algo que realmente lo valga, no nos toméis el pelo.
     
  2. Martin_Meadows

    Martin_Meadows Bit Poster

    Messages:
    1
    Like Ben, marpies and María José above, I have been able to launch Parallels 8 in Yosemite. Seems to work fine so far. I have the public release of Yosemite, installed today. What gives?
     
  3. Alberto_Nada

    Alberto_Nada Bit Poster

    Messages:
    2
    I 'm agree with you, Ben... there is an malicious intent on the part of Parallels to disable software that works in all technical respects. It's not acceptable to be forced to update Parallels software regularly bought..!!! It is an unfair and fraudolent attitude...
     
    Abood likes this.
  4. Abood

    Abood Bit Poster

    Messages:
    2
    I upgraded to Yosemite and Parallels 8 is still working fine. I am afraid they will intentionally kill it soon. The strategy to rip customers will not work out this time. I will definitely not buy the upgrade (bough the Paralles SW only mid 2013), already installed VirtualBox and have it ready (migrated using the VMWare Tool).
    Dear Parallels people: you have to win your customers to buy new versions, not force them by killing the elder one. I am an IT-Sales guy myself. Should you kill it, I will definitely not come back. Best Regards to your marketing and strategy colleagues.
     
  5. Exergy

    Exergy Bit Poster

    Messages:
    1
    +1 - This strikes me as incredibly shady business practice. Version 8 is working fine for me on Yosemite. That notice saying it will not work just makes your company look really sleazy. I am with the others in this thread, if you subsequently release an update to break it on Yosemite, I will never buy anything from you again.
     
    Abood and Alberto_Nada like this.
  6. marpies

    marpies Bit Poster

    Messages:
    2
    Agreed. Everything is working well with v8 and Yosemite, do not really have a reason to upgrade.
     
  7. Marco1

    Marco1 Bit Poster

    Messages:
    1
    Me too. I have Parallels 8 and Yosemite and my virtual machine with Win8 works fine. Very very bad work of marketing in my opinion, i was going to buy the version 10 in order to increasing performance and for other small reasons, until i received the message that my version of P8 will not work with Yosemite. And now after viewing that the old version works good, that showing how the Parallels team has kidding me (us), i think to pass to the competitors.
    If the parallels 8, after an update, stop to working with Yosemite means only that you are criminals.
     
    Alberto_Nada likes this.
  8. Maksim_Churyumov

    Maksim_Churyumov Bit Poster

    Messages:
    2
    You have to be kidding me guys. What the hell should I pay for your product once again just because you decided do not support it any more. You suggest me to buy PD10? No thanks. Who knows, maybe you will decided do not support it in 2015. I'm really disappointed with your politics. It's kind of fraud. Bring me my money back for PD8 and I'll buy PD10 with pleasure.
     
    Abood likes this.
  9. Andy_Cunningham

    Andy_Cunningham Bit Poster

    Messages:
    1
    Forcing a paid upgrade to a barely 2 year old piece of software to support a new OS is not acceptable. I'll spend the money on VMware Fusion - wish I'd bought it in the first place ....
     
    Abood likes this.
  10. Tim1

    Tim1 Bit Poster

    Messages:
    1
    It really feels like you are planning to kill off 8 with an update, that's just sad. If you want your customers to pay each year, just switch to a subscription plan, at least that way you are being honest to people.
     
  11. Alberto_Nada

    Alberto_Nada Bit Poster

    Messages:
    2
    Why you continue to send email messages that are not true and menacing? ....Where is the moderator...??
    NOTIFICA DEL SERVIZIO URGENTE N. 3:
    "Se intende eseguire l'aggiornamento a Mac OS X Yosemite (10.10), tenga presente che Parallels Desktop 8 per Mac NON supporta OS X Yosemite (10.10). Non sarà in grado di avviare la macchina virtuale di Windows o utilizzare direttamente i suoi file tramite Parallels Desktop 8."

    PD8 works fine with Yosemith... I'm really disappointed with your politics. If the parallels 8 stop to working now (with Yosemite) means only that you are really incorrect and in bad faith...
     
  12. Alastair_Hardwick

    Alastair_Hardwick Bit Poster

    Messages:
    1
    Installed Yosemite last night, ran Parallels 8, ignored the message that it will "NOT" work in Yosemite and fired up my Windows 7 VM with no apparent issues. Categorically stating that "PD8 will NOT work with Yosemite" is an outright lie. I bought your software because I think it's a solid product. You lost my return custom by your marketing team stating something that is completely untrue in order to leverage another £40 from my wallet. MBP2011.
     
  13. Abood

    Abood Bit Poster

    Messages:
    2
    Parallels moderator is hiding , ... what a shame ! Today I received another mail stating that it will not be compatible.
     
  14. Westside guy

    Westside guy Bit Poster

    Messages:
    2
    Parallels 8 is currently working fine for me under Yosemite. I understand this may change, depending on what Apple does with Yosemite - and that sort of breakage won't be fixed by Parallels. I think that stance is completely reasonable.

    However I'll also be sure not to install any Parallels 8 "updates" that might show up from this point on. ;)

    (Posted using Internet Explorer, running on Windows 7, running under Parallels 8, running on Yosemite)
     
    Last edited: Oct 21, 2014
  15. Hua_Zhong

    Hua_Zhong Bit Poster

    Messages:
    3
    I am just signing in here to have my first post: I was happy with Parallels product and too got the messages that PD8 wouldn't be compatible with Yosemite. I was seriously considering upgrading to PD10. Now I've upgraded to Yosemite and PD8 works fine for me. So I will NEVER pay for Parallels 10 again, until the company apologizes and changes its practices.

    What a shame.
     
  16. Phantastes

    Phantastes Bit Poster

    Messages:
    1
    I also got the notices that 8 would not work with Yosemite. I went out and bought Quicken 2015 for Mac as Quicken was the last windows app i needed to run. Just for giggles, i left Parallels installed and did the Yosemite update and lo and behold. My Parallels 8 is currently working perfectly. So thanks to Parallels, I purchased a piece of junk software (Quicken for Mac). Maybe they should have said the all features would not work, not that your Parallels would not open.
     
  17. Joffre_Fernandez

    Joffre_Fernandez Bit Poster

    Messages:
    1
    After reading the comments made on upgrading to Yosemite and paralleles 8 I decided to take a chance and upgrade today and it worked flawlessly. I can't tell anyone that they will have the same results as I did
    • [​IMG]
      Paul T3 October 2013 14:29
      Thanks anonymous. Here we're discussing non-sanforized jean, on which there will be some leg twist, even with perfect cutting and sewing.


      i have read all the comments made in this forum concerning the upgrade to yosemite and parallels 8. I decided to take a chance and upgrade today and to my surprise most of the comments made that said it will work were absolutely correct. It worked flawlessly for me with no problem whatsoever. I can't gaurantee the same results for anyone else but i can't see any reason why you would have a different outcome. The upgrade to yosemite was a great move also.
     
  18. jesterpaul

    jesterpaul Bit Poster

    Messages:
    6
    I am another Parallels user running version 8 on Yosemite.


    I have lost all respect for this company that tries to force you to upgrade for money every year or two. Ever heard of a lifetime license? In New Zealand your claims about the requirement to upgrade to use PD with Yosemite are illegal if not factual. They are not factual: merely a blatant marketing lie.

    Come out from under your rock Parallels mod.
     
  19. Andrew1

    Andrew1 Bit Poster

    Messages:
    2
    This is a ridiculous scam that Parallels runs! I'm now committed to exposing it on social media and on my website. UN-FREAKING-BELIEVABLE! Here's my experience:

    Running Parallels Desktop 8 on my iMac and MBPr. During the Yosemite beta period, I got these not-so-friendly pop-ups informing me that PD 8 was not compatible with Yosemite BETA. I had no intention of installing Yosemite Beta, so I closed them and ignored them.

    Then Yosemite launched, I updated both machines. Parallels Desktop 8 continues to function on my MBP, but NOT on my iMac (where I get a series of three Parallels errors upon attempting to start the VMs...1) May run slow due to firmware not allowing virtualization, 2) Only 1 CPU will be used because of same and 3) Failure loading Parallels drivers.

    But my MBP is running the same Apple SW, same VMs same PD version, so it's 100% clear that Parallels is engaging in planned obsolescence to force its customer to continue to pay. Thankfully, we have options, like VirtualBox or VMWare Fusion, both of which you do have to pay for, but they don't kill your product after a year or two. Unbelievable crap, parallels. You just lost a customer, and one that's committed to making sure others don't make the same mistake I did when buying your product for the first time!

    Benchmarks tests show you people only come out a hair ahead of VMWare Fusion, so I'll take the unnoticeable performance hit and save myself untold amounts of my hard-earned money.
     
  20. Nikky_Nixx

    Nikky_Nixx

    Messages:
    2
    I want to run multiple version of Windows on my MacBook at once.
    How far back does support for Windows go and how many versions can run in parallel?
    For example, say I wanted to run all of these together..

    Win93
    Win95
    Win96
    Win98
    WinNT
    WinXP
    Win7
    WinVista
    Win8
    OSX

    Would this be possible?
     

Share This Page