Parallels keeps changing my selected Keyboard Layout! (Input Source)

Discussion in 'Installation and Configuration' started by danieltharris, Sep 28, 2012.

  1. danieltharris

    danieltharris

    Messages:
    87
    No matter what I set my keyboard language to (Believe this is called Input Source in Mac OS), Parallels keeps changing it back to British as soon as I click into any of my VM's...

    Any ideas why it would do this? No other apps are doing it at all. Parallels should just use whatever configuration I have set it to on my Mac, not switch it for me when I don't want it to...

    There must be a setting to prevent this somewhere?
     
  2. OldTimski

    OldTimski

    Messages:
    4
    I have exactly the same problem since upgrading to Parallels 8. Is there a known remedy for this yet?
     
  3. danieltharris

    danieltharris

    Messages:
    87
    If you can then get an Issue ID and post it here, as I know the Parallels staff will ask for that before doing anything about it.

    I will try and get a Problem ID for it tonight but don't have my Mac with me at the moment.

    Hopefully somebody knows how to make this work. It's annoying Parallels changes it where are no other applications for Mac have done that to me so far.
     
  4. OldTimski

    OldTimski

    Messages:
    4
    I've just received support ID 1486515 in relation to this. Lets hope there's an easy fix. It's driving me mad!
     
  5. OldTimski

    OldTimski

    Messages:
    4
    Problem Resolved

    This problem is resolved by disabling the new keyboard synchronisation feature in parallels 8. Please see the reply from Parallels technical support below. Thanks parallels for resolving this so quickly for me:

    "In Parallels Desktop 8 a new feature has been added - automatic synchronization of Mac and Windows keyboard layouts.
    This feature works for added 'Parallels' layouts in Windows virtual machines.
    Please refer the User's guide page 83:
    http://www.parallels.com/fileadmin/...port/pd8fm/Parallels_Desktop_User_s_Guide.pdf

    You can disable it the following way:
    - Shut down Windows virtual machine.
    - From Parallels Desktop menu go to Window -> Virtual Machines List -> right-click on your virtual machine -> select 'Show in Finder' -> right-click on the .pvm -> select 'Show package contents'-> open config.pvs using TextEdit -> locate the "KeyboardLayoutSync" tag -> change 'Enabled' value to '0' (zero) -> close config.pvs
    - After that you can start your virtual machine once again and keyboard layouts in Windows and Mac will not be automatically synchronized."
     
    Daniel_Lancelot likes this.
  6. danieltharris

    danieltharris

    Messages:
    87
    Thanks for posting your solution OldTimski

    If you want to use the "British - Microsoft" Mac layout in both your Mac and your Windows VM do you need to set the layout in Windows?

    I tried setting it in Windows to use what it considers the standard "United Kingdom" layout but couldn't get it to use it for some reason.

    I'll try making the change as suggested and hopefully all will become clear. I don't mind setting it separately in both.
     
  7. OldTimski

    OldTimski

    Messages:
    4
    You do have to set the layout in both unfortunately. The Mac and Windows keyboard settings seem to operate entirely independently. The keyboard synchronisation feature in Parallels automatically switches from the the Windows United Kingdom setting to United Kingdom (Apple) - Parallels which causes the problem. Disabling synchronisation allows the Windows and Mac settings to persist which solves the majority of my problem. I tend to use the Windows VM always with the same keyboard and I've added the Mac keyboard setting to the menu bar for quick adjustment.
     
  8. danieltharris

    danieltharris

    Messages:
    87
    Thanks to posting the steps. I am now able to set the two independently.

    The only problem I have is that in Windows 8 I have no option for the Standard UK layout of a Microsoft Keyboard.

    I have it...But only for touch. My workaround was to add the Irish keyboard layout, which appears to be the same as the UK one...Is there a way to add the missing one in? I only have United Kingdom (Apple), and United Kingdom Touch.

    There doesn't exist an option for United Kingdom for a normal keyboard. This is in Windows 8, and I assume Parallels tools removed it to try and be helpful (Which it is for some people who don't use a UK Std Keyboard and always use their Mac keyboard).

    I also added the language bar in Mac OS X and it's fine to switch that way as once plugged in I use the same keyboard all day.

    I just press Win + Space to switch it in Windows when I need to, but at the minute set to Irish layout alongside UK (Apple)
     
  9. John Kiska

    John Kiska Bit Poster

    Messages:
    5
    This same issue exists if you use Spell Catcher. When I switched to PD8 my input source would change to the "Flag" or US keyboard, but it did not change back to Spell Catcher when switching back from PD8. I resolved the issue by disabling the new keyboard synchronisation feature in parallels 8 as described above.

    Thanks for the tip OldTimski.
     
  10. LCarvalho

    LCarvalho

    Messages:
    1
    I'm still using Parallels 7 and having the same problem. Could not find KeyboardLayoutSync tag in config.pvs
     
  11. AleAve

    AleAve

    Messages:
    5
    OldTimski, many thanks for your help! This was driving me absolutely insane, to the point of wanting to ditch Parallels Desktop, or in fact throwing my MacBook Air out of the window. ;)

    This buggy functionality is a nice example of the pretty frequent occurrence of someone creating more harm than good with their well-meant effort to help. Bad choice on the part of Parallels Desktop developers, to activate this feature by default. Worse still, hiding the setting in a deeply buried plain-text configuration file. If anything, it should be a setting that one could activate or deactivate using Parallel Desktop's standard user interface.

    Thank heavens, though, that the issue is gone now.
     
  12. Jean-PierreF

    Jean-PierreF

    Messages:
    1
    Thank you so much, it was rather annoying
     
  13. SouthOfTheBorder

    SouthOfTheBorder

    Messages:
    1
    This totally worked

    Thank you! This did the job.


     
  14. Daniel_Lancelot

    Daniel_Lancelot

    Messages:
    1
    Thanks for posting... I reported this issue to Parallels support when this """Feature""" was first introduced (I think Parallels 7?) - but at the time although they did eventually mange to nail down the cause of the issue, they closed the issue without providing a solution "Works as designed..." apparently...

    Now to unlearn my muscle memory, and use what is actually printed on the keyboard!!!
     
  15. JuanO1

    JuanO1 Bit Poster

    Messages:
    1
    You do have to set the layout in both unfortunately. The Mac and Windows keyboard settings seem to operate entirely independently. The keyboard synchronisation feature in Parallels automatically switches from the the Windows United Kingdom setting to United Kingdom (Apple) - Parallels which causes the problem. Disabling synchronisation allows the Windows and Mac settings to persist which solves the majority of my problem depurar javascript. I tend to use the Windows VM always with the same keyboard and I've added the Mac keyboard setting to the menu bar for quick adjustment.
     
  16. MarkC9

    MarkC9

    Messages:
    2
    This problem still exists in Parallels 14. I think there is a fundamental error in the keyboard synchronization code which is why it has to be disabled. I'm going to try now. I hope it works.

    In my case I have a Japanese keyboard layout so on Windows I have "ENG" (UK English with Japanese keyboard layout), "ENG JA (US English with Japanese keyboard)", and Japanese IME installed. However after going to the Mac and back to Windows the keyboard is *always* set to ENG US (i.e English with a US keyboard layout) regardless of what was set on the Mac side and regardless that I don't have that keyboard layout installed. Even if it was only set to ENG US when the Mac is set to US, that would be wrong. The settings on the Mac are about what language you are typing not the keyboard layout.

    Pretty obviously the physical keyboard layout does not change when switching between Windows & Mac. In my situation keyboard synchronization should be limited to making sure the IME is in the same mode as the Mac - hiragana, katakana, etc.
     
  17. MarkC9

    MarkC9

    Messages:
    2
    Yup. Disabling synchronization did the trick.

    The feature is clearly buggy.
     

Share This Page