Parallels on macOS Big Sur not starting. Forced to upgrade?

Discussion in 'Windows Guest OS Discussion' started by DanielA22, Nov 24, 2020.

  1. DanielA22

    DanielA22 Bit Poster

    Messages:
    5
    Hi All!
    I have recently updated to Big Sur however my copy of parallels does not seem to be able to open. I get the message
    Parallels Desktop cannot be started because some of the required components are missing from the operating system of your Mac.

    I desperately need my windows vm to do my work while I have to work from home and cant access any of the programs I need as it stands.

    Any help would be much appreciated!
    Thanks in advance!
     
  2. RogerH6

    RogerH6 Kilo Poster

    Messages:
    215
    It should work. Have you upgraded Parallels to the latest release?. It needs to be pretty modern to work correctly with Big Sur, and in fact the latest update to 16.1.1, fixes a couple of issues I was having.
    Uninstall Parallels. Go to the application folder, select the 'Parallels desktop', right click and move to trash.
    Then install the latest release (http://www.parallels.com/directdownload/pd16).
    This should clean up whatever is wrong with the install.
     
  3. RogerH6

    RogerH6 Kilo Poster

    Messages:
    215
    Also, make sure your VM is set to use the Apple hypervisor, not the Parallels one. Big Sur seems to stop the Parallels one from actually working.....
     
  4. DanielA22

    DanielA22 Bit Poster

    Messages:
    5
    Hi, thank you for your reply. Yeah I am on parallels 13, but upgrading to 16 would mean I would need to purchase a new license right?
     
  5. RogerH6

    RogerH6 Kilo Poster

    Messages:
    215
    I'm afraid I think that is the case. Big Sur changes so many things inside the OS, that I think the chances of getting anything older that PD16 actually to work are basically nil....
     
  6. RogerH6

    RogerH6 Kilo Poster

    Messages:
    215
  7. DanielA22

    DanielA22 Bit Poster

    Messages:
    5
    ahh I see, I unfortunately figured as much. I definitely wouldn't have upgraded to big sur had i known before hand :(. It's a shame Parallels seem happy to spam my email asking me to buy more stuff but didn't think to mention at any point my version wouldn't work at all after the upgrade.

    Thanks for this, I will give it a try but i'm getting a bit desperate now and may just have to bite the bullet :(


    I suppose my advice to anyone out there who has an older version of parallels and needs it to work without being forced to purchase a new copy is... well, dont update to big sur. Or look at finding different software to host your vm.
     
  8. RyanL10

    RyanL10

    Messages:
    1
    I am also in the same situations. Upgraded to Big Sur and found that my PD13 fails to start with the same missing component error. I wish they released some sort of hot fix for PD13. Has anyone tried reinstalling PD13 on Big Sur?
     
  9. RogerH6

    RogerH6 Kilo Poster

    Messages:
    215
    I'm afraid I think you will have to upgrade.
     

Share This Page