Parallels prl_disp_service.exe wakes computer

Discussion in 'Windows Guest OS Discussion' started by Terrax, Aug 6, 2013.

  1. Terrax

    Terrax

    Messages:
    7
    I am running a virtual 32 bit Windows 7 on a 64 bit Windows 7 host. Nightly at 11:10pm, prl_disp_service.exe wakes the system. This is a service; if I disable the service, or even set it to manual, Parallels cannot start, so that's not a solution.

    How can I prevent parallels from destroying my computer's sleep?

    Thanks.
     
  2. Terrax

    Terrax

    Messages:
    7
    This is definitely the problem:
    C:\Windows\system32>powercfg -waketimers
    Timer set by [PROCESS] \Device\HarddiskVolume1\Program Files (x86)\Parallels\Parallels Workstation\Application\prl_disp_service.exe expires at 5:53:29 AM on 8/9/2013.

    But why is it creating a wake timer?
     
  3. Terrax

    Terrax

    Messages:
    7
    Anybody? Bueller? Nobody?

    Well, okay, I've got a work-around.

    It cancels other wake-up timers also, but in Windows Control Panel, Power Options, Edit Plan Settings, Change Advanced Power Settings, expand "Sleep", expand "Allow wake timers" and set that to "Disable".
     

Share This Page