Parallels Toolbox menubar bug on macOS Catalina

Discussion in 'Parallels Toolbox for Mac' started by MichaelC17, Nov 2, 2019.

  1. MichaelC17

    MichaelC17 Bit Poster

    Messages:
    4
    The Parallels Toolbox app is seriously misbehaving on my MacBook Pro, running Catalina 15.1 Final. Had a conversation with an Adobe rep on Facebook yesterday, which I'm copying below. They recommended a reinstall of PT, which I did and which solved the problem for awhile, but it's back to misbehaving today.
    I seriously suspect an incompatibility with another app that posts icons on the menubar and dynamically changes them, iStat Menus. Anyone else in similar straits who's seen this?

    TIA,

    Mike
    ----------------------------------------------
     
  2. sergk

    sergk Parallels Developers

    Messages:
    395
    Hello,

    yes, "Hide Menu Icons" tool may have problems with applications that actively work with menu bar icons. Unfortunately behavior of such applications could be unpredictable which causes misbehavior of Hide Menu Icons. We continue work on improving the tool to cover as much such cases as possible.

    Anyway, thank you for your feedback!
     
  3. MichaelC17

    MichaelC17 Bit Poster

    Messages:
    4
    OK, updated to Catalina 15.2 beta 3 and even reinstalled the latest Parallels Toolbox Version 3.7.0 (2768), but I'm still unable to use Clipboard History:
    1. The Toolbox icon on the menubar won't respond until I run the app at least once after booting (and yes, it has already run once during the boot process).
    2. The Hide Menu Icons icon is erratic until I exercise it a couple times, and
    3. The Clipboard History icon never produces a history drop-down. Just sits there, highlighted blue:
    Can you please fix this? I really miss having Clipboard History.
    Thanks,
    Mike
    Screen Shot 2019-11-22 at 3.46.08 PM.png
     
  4. sergk

    sergk Parallels Developers

    Messages:
    395
    Hello,

    Thank you for your feedback,

    > The Toolbox icon on the menubar won't respond until I run the app at least once after booting (and yes, it has already run once during the boot process).
    We've found that this issue appears if on of the tool (from inside Parallels Toolbox) is launched Agent. There are some of such tools like Date Countdown, Alarm. Please try this:
    1. Check that all your tools are turned off.
    2. Make sure that Toolbox will be launched on startup (open Toolbox Preferences and check "Start Parallels Toolbox when Mac starts" option)
    3. Restart macOS.
    4. Check behavior of Toolbox icon.
    If problem still there then send us Technical Report: https://kb.parallels.com/en/124107

    > The Hide Menu Icons icon is erratic until I exercise it a couple times
    Yes, there are still problem applications (like istatmenus in your case), we continue working on such issues

    > The Clipboard History icon never produces a history drop-down. Just sits there, highlighted blue:
    Try this:
    1. Open Activity Monitor application and close "Clipboard History". Make sure that tool icon disappeared from menu bar.
    2. Launch tool from Parallels Toolbox again.
    Does it help? Does problem return after restarting the mac?
     
  5. MichaelC17

    MichaelC17 Bit Poster

    Messages:
    4
    Sergk,

    Thanks for the suggestions. Here are my observations:
    1. Did a fresh restart.
    2. As the icons start filling in on the menu bar, three icons from Parallels Toolbox appear: the Toolbox, Clipboard History, Hide Menu Items (as expected, per my settings).
    3. The first two appear at the left side of the row of icons; Hide Menu Items at the second from the right, as expected.
    4. But the Hide Menu Items icon is gray, not black.
    5. As the menu bar icons complete filling in, iStat Menus runs and adds its icons between the PT and CH icons.
    6. After the system completes starting up and settles down, the Toolbox icon is active. When clicked on, it highlights and a drop-down panel showing all tools appears, as expected.
    7. But when the CH icon is clicked, it only highlights. No drop-down panel appears. Clicking outside the icon deselects it.
    8. Clicking on the larger CH icon inside the Tools drop-down pane does exactly the same as clicking on the menubar CH icon. The latter just highlights.
    9. When the HM icon is clicked, nothing happens. It doesn't even highlight or respond in any way.
    10. The iStat Menu's menubar icon(s) behave as expected.
    11. Force Quitting the Clipboard History process in Activity Monitor causes its menubar icon to disappear.
    12. Invoking CH by clicking on the tool icon in the Toolbox drop-down pane apparently restarts the CH process.
    13. After (perhaps) the second try, CH now works(!) as expected. Its menubar icon is active. Clicking on the CH icon invokes the drop-down panel of clipboard history entries.
    14. Similarly, for Hide Menus. Killing its associated process and re-invoking HM from the main Toolbox d-d panel causes its menubar icon to reappear (black this time, not gray) and it behaves as expected.
    Hope this helps. I'm still suspicious of some interaction between your PT and iStat Menus (even though the developers of the later discounted any possible interference). I suppose the definitive test would be to uninstall their app and try this sequence again. (Bit of a bother, but would be willing to try that if it would be useful to you.)
    In any case, thanks for helping me find a workaround so I have access to your tools again :)

    Mike
     
  6. sergk

    sergk Parallels Developers

    Messages:
    395
    Mike, thanks a lot for your small investigation!
    Sure it will help to fix these issues.
     

Share This Page