Parallels Tools fails Kali Linux

Discussion in 'Other Guest OS Types Discussion' started by Jacob13, Feb 24, 2021.

  1. Jacob13

    Jacob13 Bit Poster

    Messages:
    2
    System Information:
    OS: Mac OS 11.2
    Device: MacBook Pro 2019
    Parallels:
    Parallels Desktop 16
    Version: 16.1.3
    Kali:
    "uname -a" gives
    Kali Linux 5.10.0-kali3-amd64 #1 SMP Debian 5.10.13-1kali1 (2021-02-08) x86_64 GNU/Linux

    I tried posting this on the Kali forums but even after waiting weeks it never actually passed the comity. :(
    I originally thought this was a problem with Kali, however I'm not 100% sure anymore:

    Description of problem:
    I mounted the Parallels Tools cdrom, copied it to my desktop, ran chmod 700 on the install file and ran it with sudo.
    It goes though a couple messages then says "Please wait while installing is in progress." This last about 3 to 5 seconds then gives this error:
    "An Error occurred when installing Parallels Tools. Please go to /var/log/parallels-tools-install.log for more information."
    The contents of said log is attached.
    The important lines appear to be these:
    Code:
    Err:2 http://http.kali.org/kali kali-rolling/main amd64 Contents (deb)
      File has unexpected size (39503686 != 39499265). Mirror sync in progress? [IP: 169.229.226.30 80]
    Ign:3 http://http.kali.org/kali kali-rolling/contrib amd64 Contents (deb)
    Ign:4 http://http.kali.org/kali kali-rolling/non-free amd64 Contents (deb)
    Reading package lists...
    E: Failed to fetch http://http.kali.org/kali/dists/kali-rolling/main/Contents-amd64  File has unexpected size (39503686 != 39499265). Mirror sync in progress? [IP: 169.229.226.30 80]
    E: Some index files failed to download. They have been ignored, or old ones used instead.
    Return code from apt-get update is 100
    
    I also had this problem error I tried to run "apt update", which was solved by changing '/etc/apt/sources.list' to refer to kali-last-snapshot instead of kali-rolling, however this still did not fix the Parallels Tools Install.

    While this looks a lot like a problem with Kali I was unable to reproduce this problem in Virtual Box.

    Things I have tried:
    apt update, apt upgrade and apt dist-upgrade.
    Reinstalling Kali.
    Trying this at least 7 times over the last few weeks, and in the process have in total mounted and copied the cdrom 4 times in case of an update.
    Rebooting mac and Kali.
    Quitting and relaunching Parallels.
    Disabling firewall on mac.

    I need to be able to use Bluetooth in Kali and if this doesn't get resolved soon I may have to resort to using Virtual Box and buying a usb Bluetooth dongle (because VB can't use the internal one).
     

    Attached Files:

  2. StefanoR2

    StefanoR2 Bit Poster

    Messages:
    1
    same configuration, same error.

    Any solution?

    thanks
     
  3. who

    who Bit Poster

    Messages:
    1
    I ran into the same problem, and it seems that Parallels Tools does not yet patch to the Linux 5.10 kernel.
    Hope to with it as soon as possible.
     
  4. Jacob13

    Jacob13 Bit Poster

    Messages:
    2
    With this being the only reply, I take it that for this to work I need to use an older kernel for now, if I am going to use Parallels.
    Could someone point me to a resource on how to downgrade a kernel? Or do I need to install an older Kali?
     
  5. JannikS

    JannikS

    Messages:
    2
    This worked for me (for many different versions of kali, currently using 2021.1):

    mount cdrom0
    copy parallels tools to ~/
    cd ~/
    chown -R user:user parallels-tools # important step, failed for me without
    cd parallels-tools && ./install

    Hope that helps! :)
     
  6. JannikS

    JannikS

    Messages:
    2
    add: user should be any user but root. However, run the install file as root. Did it just today, works fine on the most current Kali amd64 (2021.1 at the time of writing)
     

Share This Page