Parallels won't stay in its space!

Discussion in 'Installation and Configuration' started by pufferdude, May 26, 2011.

  1. pufferdude

    pufferdude Bit Poster

    Messages:
    21
    I'm not exactly sure when this changed, as I run Parallels in space2 and I'm IN that VM 95% of the time on my Mac, but somewhere along the line (I'm on 6.0.11994) Parallels stopped loading into space2 properly. When I launch Parallels, the Mac briefly switches to space2 (like it should), but as soon as Parallels starts to load, it quickly switches back to space1 and the Parallels window ends up in space1. I always run Parallels full screen in its space, but also tried in windowed mode and it does the same thing.

    I'm not sure if Parallels started doing this after a Parallels update, or if some OSX update is breaking it. Any ideas? Anyone else seeing this behavior? It's really annoying not being able to target Parallels to a specific space anymore.
     
  2. RSW

    RSW

    Messages:
    2
    I have the same problem. I want to run Parallels in Space 2. It works when I start Parallels but when the machine resumes from sleep Parallels consistently is running in Space 1. I am running 6.0.12092 on a MacBook with external monitor.
     
  3. pufferdude

    pufferdude Bit Poster

    Messages:
    21
    I managed to get it working by telling Parallels to open in space 1, and then back to space 2 again (basically toggling the space on and off)... after that it "stuck" and finally launches in space2 all the time.
     
  4. Navitas

    Navitas Bit Poster

    Messages:
    8
    Me too

    I am also having this issue - I normally have Parallels running in Spaces 2 - however after upgrading to P6 in order to upgrade to Lion (we are still running Snow Leopard until these issues are sorted) I now get P6 opening up in random spaces. To make matter worse, I have two screens and so on some occasions I get left screen of Windows 7 and right screen of Mac when in Spaces 1, switch to spaces 2 and I get left screen of Mac and right screen of Windows 7 so it seems to get it all totally wrong

    When are we going to get a fix for this ?????
     
  5. RSW

    RSW

    Messages:
    2
    Does anyone know if this spaces bug gets fixed in Parallels 7?
     
  6. caltuna

    caltuna

    Messages:
    9
    I have Lion and just installed the latest build (7.0.15052) and the problem persists. Parallels opens in Desktop (spaces) 4 but when the black "click here to start" VM (WinXP) screen comes up it switches to Desktop (space) 1.

    PITA.
     
  7. YanaYana

    YanaYana

    Messages:
    1,666
    I have already posted in other thread - this behaviour has been fixed recently, but the fix is still on it's way. Just keep your system updated - fix should arrive together with one of nearest updates.
     
  8. J.C

    J.C

    Messages:
    4
    Actually NOT yet though I have installed the latest version. The issue is still there. Is the fix a joke?
     
  9. ZacharyE

    ZacharyE

    Messages:
    3
    I struggled with this issue for a while. One thing that seemed to work for me is to turn off the Mac OSX Fullscreen option from the virtual machine configuration (you can still view Parallels in fullscreen). I ended up not bothering with spaces in my setup but I think that will work until another fix is released.
     
  10. J.C

    J.C

    Messages:
    4
    I've tried all I can including what you said. But the weirdness stays. I assigned Parallels to space 3 so I can quickly find it by cmd+3. But after updating to Parallels Desktop 7, when I start Paralles Desktop, my Mac desktop will be shifted to space 3 first, then space 2, then back to space 3 again...looks great, isn't it? Actually, NO. Because my Windows is put to the space 1!!!

    Stay there, please. But it looks drunk...
     
  11. SPelly

    SPelly Bit Poster

    Messages:
    27
    I too am having problems getting my VMs to stay in their assigned space.

    I'm running Build 7.0.15054 (Revision 722853; December 16, 2011).

    When I start the parallels application, it always opens in its assigned space #4. When I launch a VM, focus always changes to space #2 and the VM window is always rendered on space #1. The VM window is behind the other open windows so have to change to space #1 and then dig for the buried VM window.

    Has anyone discovered a work around?
     
  12. YanaYana

    YanaYana

    Messages:
    1,666
    Guys, one more time.
    This is how it works: after some misbehaviour is fixed it is not included straight away to the next update. It may take a while and be delivered with some update in future (not the next one) - the time depends on a lot of circumstances - maybe some interdependent fixes which are still in progress.
     
  13. PC Mac Dr

    PC Mac Dr

    Messages:
    7
    Build 7.0.15055

    Still NOT staying in its proper windows

    I have it configured to Desktop 16

    When I first launch PD7 in start in 16, once again when I press one of the VM, it GOES back to Desktop 1

    Come ON, this REALLY needs to be FIXED, WE have been making request for a FIX for quite some time.

    If Parallels Team can't figure it out, then GET help or take notes from VMFusion


    thanx
     
  14. vanclute

    vanclute

    Messages:
    2
    Holy crap... seriously, this is STILL an issue? I just upgraded to Parallels 7 a couple weeks ago and am getting used to my new 27" iMac running Lion 10.7.4. Problem is - Parallels and Spaces simply do not play well together at all! I thought it was working fine, until I rebooted. Now no matter what I do, Parallels (and any apps in Coherence mode) simply will not stick to the space I tell it to stick to.

    Is this every going to actually be fixed? I'm actively doing everything I can to move to Mac versions of my few remaining Windows apps now, and if I can do away with Parallels all together, I will. And mostly because of this issue.

    Any word from anyone inside the company on a fix for this?
     
  15. J.C

    J.C

    Messages:
    4
    We DID NOT see any move, the BUG still there. What happened in your company?
     
  16. YanaYana

    YanaYana

    Messages:
    1,666
    We are terribly sorry, but i'm afraid the issue is back. Our team is working hard to get rid of the roots as seems like it is not that simple to fix it. Please be patient, i understand all your frustration.

    I will let you know straight away when the fix is ready.
     

Share This Page