PD13.x: Windows application icons no longer appear on dock -- FIXED (again)

Discussion in 'Windows Guest OS Discussion' started by DoniK, Sep 20, 2017.

  1. DoniK

    DoniK Bit Poster

    Messages:
    98
    Updated PD12 to PD13.0.1. VM in windowed mode. macOS 10.12.6.
    Windows application icons no longer appear in the macOS dock. I've tried restarting PD, restarting the dock, reinstalling Parallels Tools, and retoggling VM settings, to no avail. Same problem if I click "Show Windows application folder in Dock": it doesn't show (I normally have that disabled anyway). "Show Windows notification area in Mac menu bar" doesn't seem to do anything either.
    My VM's Application settings:

    Screen Shot 2017-09-20 at 9.02.08 AM.png

    Thanks
     
  2. DoniK

    DoniK Bit Poster

    Messages:
    98
    Hm, after reinstalling Parallels Tools and restarting PD13 and the dock a third time, it now seems to be finally working again. Whew!
     
  3. Alfena@Parallels

    Alfena@Parallels Kilo Poster

    Messages:
    445
    Hello @DoniK , Thank you for sharing, glad to know it is resolved. Thanks, Alfena
     
  4. DoniK

    DoniK Bit Poster

    Messages:
    98
    And now I have the problem again. Not sure when it came back, but I can't get Windows app icons to appear on the Mac dock, no matter how many times I reinstall Parallels Tools, restart PD, restart the dock. VM settings are as described in the first post.

    (macOS 10.12.6, PD 13.1.1, Win10 VM windowed mode)
     
  5. DoniK

    DoniK Bit Poster

    Messages:
    98
    FIX: Delete the "Applications (Parallels)" folder, restart PD, and allow PD to recreate it.

    I noticed my "Applications (Parallels)" folder did not have a subfolder for my VM. So I deleted the entire "Applications (Parallels)" folder and restarted PD. When the VM booted back up, the "Applications (Parallels)" folder was automatically recreated WITH the correct subfolder for my VM. And now all the applications settings are working correctly: Win app icons show in the dock, win app folder shows in the dock, etc.
     
  6. DoniK

    DoniK Bit Poster

    Messages:
    98
    Three years and two full PD version later, this is still an issue. This time, a few of my Win apps suddenly stopped appearing in the dock, while the rest did. After deleting the "Applications (Parallels)" folder, uninstall/reinstalling Parallels Tools + restarting PD half a dozen times, it finally recreated the folder and the dock icons are back again (which also allows any Win app-related macOS notification to work again, like for Outlook). I think the problem may have started when I upgraded to 15.1.4, FWIW. In case this helps anyone.
     
  7. DoniK

    DoniK Bit Poster

    Messages:
    98
    Getting pretty fed up with this. Some Win apps suddenly stopped appearing on the dock again, Microsoft apps and Chrome. Deleted the Applications (Parallels) folder, but this time I can't get it to be recreated, even after uninstalling/reinstalling both PD and Parallels Tools multiple times. :mad:
     
  8. DoniK

    DoniK Bit Poster

    Messages:
    98
    Ok, this time I even opened a support ticket, but their idea of trying Coherence mode didn't help (good idea, though). What did finally fix it: I also deleted the ~/Library/Parallels folder (which contains the Applications Menus folder, used to share Windows app folder on the dock). Then uninstalled and reinstalled Parallels Tools. Finally, on next VM start, it recreated both the "Applications (Parallels)" and the ~/Library/Parallels folders. So I guess it needed to see both of those Windows app sharing icon folders deleted before recreating them. Anyhow, I still consider this all a longstanding bug. But hope this helps someone else.
     

Share This Page