PD8: Chrome 21 shows odd graphical glitches with DirectX enabled

Discussion in 'Installation and Configuration' started by JoacimB, Sep 11, 2012.

  1. JoacimB

    JoacimB

    Messages:
    17
    With DirectX9 and DirectX10 everything is very smooth in Windows 8.

    Accelerated CSS3 animation is also very smooth, when they work..
    After upgrading to PD8 from PD7 (complete reinstall of Windows 8 Pro). I started experiencing weird behaviour in Chrome 21. I tested both the release, beta and canary builds but to no avail.

    Most often the screen doesn't seem to update itself. Sometimes it goes black and sometimes it doesn't finish rendering.

    I THINK it only appears when you have accelerated CSS transitions/animations but I'm not 100% sure.

    It worked fine in PD7 & Windows 7 Ultimate.


    To solve it, I'm forced to disabled DirectX under Parallels / Configure / Hardware / Video / 3D Acceleration

    But this "fix" makes everything choppy and slow...

    I'm only having this problem with Chrome. IE10 and FireFox 15 is working fine.

    I've tested both with and without "Enable full resolution" and increasing the video memory from 256MB to 512MB.
    Doesn't make a difference.


    MBP Retina with ML 10.8.1
    Parallels 8.0.18101
    Windows 8 Pro
     

    Attached Files:

    Last edited: Sep 11, 2012
  2. serv

    serv Parallels Developers

    Messages:
    777
    Can you give us example URLs that are not rendering properly in Chrome?
     
  3. JoacimB

    JoacimB

    Messages:
    17
    It showed up in the admin section of the Wordpress blog tools, for one.

    It should appear everywhere that CSS3 is GPU accelerated. I was about to build a test case but it seems that your last build fixed the problem. I haven't been able to replicate it anymore so it's all good.


    Thanks!


    /J
     

Share This Page