Preparing to configure your virtual machine parallels won't finish

Discussion in 'Installation and Configuration' started by AndersD, Sep 19, 2018.

  1. AndersD

    AndersD Bit Poster

    Messages:
    1
    As the subject says, the Preparing to configure-dialog hangs for some time and then closes without any further action. I try to open a win10.pvm with Parallels 14 Pro edition om a new MacBook Pro and I don't no where to start look for solutions.
     
  2. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,349
    Hi @AndersD , please try Actions > Reset and check if that helps.
     
  3. IvanK5

    IvanK5 Bit Poster

    Messages:
    4
    Hello, I had same problem after copying my laptop with Win7 with Paralles 14 on iMac with Mojave. After Reset as you mentioned, I'm getting following error:
    Trying to boot from SATA drive 1...
    No boot device is available, press Enter to continue.

    What else I should try to start virtual machine correctly?
     
  4. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,142
    Hi @IvanK5, Please follow this article to locate the virtual machine file on the Mac (it is a file with the extension '.pvm'). Once you see it, take a note of its size and reply with the same. Probably, it might have not completed the migration successfully.
     
  5. IvanK5

    IvanK5 Bit Poster

    Messages:
    4
    Hello, however no success after new migration, problem is still persists. I tried migration over network an also trough external drive, bot finished successfully but I§m not able start virtual due to mentioned error.
     
  6. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,142
    Hi @IvanK5, can you please send us a Technical Data collected right after the error and a splash screen (Help menu > Send Technical Data...)? This will help us significantly, please reply me back with the report ID number.
     
  7. ChristianK15

    ChristianK15 Bit Poster

    Messages:
    1
    Hello,
    I have the same problem. I tried to migrate my Windows 7 from another PC to Parallels 14 Pro on my Mac. After migrating the data from via an external hard drive the Parallels configuration screen stucks on "Preparing to configure your virtual machine". I tried it several times.

    Please help.
     
  8. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    748
    Hello ChristianK15, The migration must be re-done. Certain prerequisites must be observed before even attempting the migration. Please follow http://kb.parallels.com/119172 to set the stage properly for the migration and then http://kb.parallels.com/123929 to perform the same, using an external hard drive with strictly 'exFAT' file system and sufficient disk space.
     
  9. ChisolmW

    ChisolmW Bit Poster

    Messages:
    2
    Im having same problem. Just downloaded trial version. Migrated Win7 to Parallels 14, using external hard drive. All that went successfully. Every time starting, it gets stuck "Preparing to configure your virtual machine...". Yes, clicking reset seems to help. Still your product seems buggy. Also I cant get shared folders to work, no matter what I do. Mac doesnt see the Windows folders, and Windows doesn't see the Mac folders. And yes I've been through the settings for sharing.
     
  10. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    2,678
    Hey, and what about the Parallels Tools? Did you install it? Please check the Parallels Control Center process in Task Manager and let us know runs it on not.
     
  11. ChisolmW

    ChisolmW Bit Poster

    Messages:
    2
    Yes I installed the Parallels Toolbox on the Mac. Are you saying Parallels tools also has to be installed within Windows, in the Windows VM? If so, I didn't see anything about that in your documentation. Please clarify.
     
  12. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    748
    Hello ChisolmW, Let us ensure that Parallels Tools are properly installed. Please follow https://bit.ly/2N1mrkW to install Parallels Tools. If you see reinstall or update Parallels Tools then kindly reinstall it.
     
  13. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    2,678
    Yes, you need to install Parallels tools in your VM. It maybe Windows, Linux, MacOS VM, but you need to install it on the guest (your VM)
    All Parallels tools utilities supported by your guest OS are installed in your virtual machine as a single package when you install Parallels Tools.
     
  14. MikkoS2

    MikkoS2 Bit Poster

    Messages:
    3
    I have this very same problem. Migrating Windows 7 from a physical PC seems to complete successfully, but when trying to open the Windows VM, it's stuck at message showing "Preparing to configure your virtual machine..." That step never completes.
    If the reset the VM and re-start it, then I get the "There is no operating system installed in this virtual machine" error.
    My report ID is 299707435.
    Please advise how to fix the issue.
     
  15. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    2,678
    Hi @MikkoS2 did you turn off Firewall before migration? or maybe your Windows PC has drivers (e.g. printer driver, graphic card) which conflicts with Parallels virtual hardware. Please check this https://kb.parallels.com/113269 for more info.
     
  16. MikkoS2

    MikkoS2 Bit Poster

    Messages:
    3
    Thanks Maria.
    The Windows Firewall was Off during migration.
    How do I check if there are conflicting drivers? What diagnostics or checks do I need to run to find such driver?

    Also, were you able to analyze the data that I submitted with my report ID?
     
  17. GinnyM

    GinnyM Bit Poster

    Messages:
    2
    I am having this exact same problem. Parallels Tools also will not install. Firewall is off.
     
  18. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    2,678
  19. MikkoS2

    MikkoS2 Bit Poster

    Messages:
    3
    I got my VM finally working.
    The steps were as follows:
    - When the VM is stuck at "Preparing to configure your virtual machine..." click on the Parallels icon in the system bar, select "Actions", click on 'Shut Down" (to close the Windows VM that's not starting). You might have to try this multiple times if the "Actions" is grayed out. The goal is close the Windows VM so that you can edit its configuration.
    - After you got the miss-behaving VM shut down, go into the Windows VM "Configuration" menu, scroll all the way down to "Boot Order", expand "Advanced Settings" and add the following boot flag "vm.bios.efi=1".

    That did the trick for me.
    (I migrated the Windows from a Intel NUC, that uses UEFI BIOS)

    [​IMG]
     

Share This Page