Problem with MDM service configuration utility

Discussion in 'Parallels Mac Management for Microsoft SCCM' started by ITL2, Jul 13, 2020.

  1. ITL2

    ITL2 Bit Poster

    Messages:
    3
    Hello
    I scanned the forum and double-checked from PMM administrators manual but still having problem setting it up. I can get .csr succesfully, all data entered correctly (tried with automatic option and manual signing option on parallels), signed it in Apple Push Certificates Portal, but upon in the exit of wizard it gives me and error that Issued To field does not match FQDN name. Imported to MMC and indeed Issued To field is just random scribble of letters and numbers. Has anyone experienced this or got any hints of what to try?
     
  2. Evgeny Smirnov

    Evgeny Smirnov Parallels Developers

    Messages:
    52
    Hello,
    This error probably relates to the SSL certificate, not APNS. Please, check that your SSL certificate's subject contains the FQDN of the MDM server.
     
    ITL2 likes this.
  3. ITL2

    ITL2 Bit Poster

    Messages:
    3
    Hello again
    It seems creating new SSL certificate fixed that issue, I guess it could have been a typo. Many thanks!
    Although I have stumbled to a new problem, prerequisite check is successful, it doesn't give me any error about cert, ports but in the last step of the setup when pressing finish, it gives me an error: failed to apply parallels mdm service configuration settings.
    Is there any log for it to read about specifics of what failed?
     
  4. Evgeny Smirnov

    Evgeny Smirnov Parallels Developers

    Messages:
    52
    You can find the log here C:\Windows\Logs\pmm_mdm_service_config.log. Anyway, I suggest contacting the support team to get help with it.
     
  5. ITL2

    ITL2 Bit Poster

    Messages:
    3
    Weirdly enough email support was only for active subscription so I'll paste log entry here too incase someone has any bright ideas:
    07-16 11:37:51.004 I /pmm_mdm_service_config:******:******/ Updating the service logon account...
    07-16 11:37:51.004 D /CmProxyCfgUtils:******:******/ Setting service failure actions for pmm_mdm_service
    07-16 11:37:51.005 W /CmProxyCfgUtils:******:******/ Cannot add service account '.\serviceaccount' to local administrators group: 0x56b (A member could not be added to or removed from the local group because the member does not exist.)
    07-16 11:37:51.005 F /CmProxyCfgUtils:******:******/ Cannot change config for service 'pmm_mdm_service': The account name is invalid or does not exist, or the password is invalid for the account name specified.
    07-16 11:37:51.005 W /pmm_mdm_service_config:******:******/ Configuration commit failed: Cannot apply service account.

    This is really weird since that user is in local administrators group
     
  6. Evgeny Smirnov

    Evgeny Smirnov Parallels Developers

    Messages:
    52
    Could you try to use another account? There is probably some conflict in account names.
     
  7. PeterJ18

    PeterJ18 Bit Poster

    Messages:
    23
    It appears making new SSL authentication fixed that issue, I get it could have been a grammatical error. Much obliged!

    Despite the fact that I have lurched to another issue, essential check is effective, it doesn't give me any blunder about cert, ports yet in the last advance of the arrangement when squeezing finish, it gives me a mistake: neglected to apply matches mdm administration design settings.

    Is there any log for it to find out about points of interest of what fizzled?
     

Share This Page