Running two version of PHP

Discussion in 'Feature Suggestions' started by iantresman, Feb 8, 2012.

  1. iantresman

    iantresman Bit Poster

    Messages:
    19
    My server runs PHP 5.2. Some customers are asking for PHP 5.3, and even PHP 5.4.

    I can't update PHP globally, as it may not work for some people, so it would be useful to be able to run multiple versions of PHP, and have individual subscriptions or even domains, decide which version they want to use.
     
  2. Sergey L

    Sergey L

    Messages:
    0
    Are you running Plesk? Plesk for Linux?
     
  3. iantresman

    iantresman Bit Poster

    Messages:
    19
    Yes, Plesk 10.4 for Linux. But hosting company said I could replace the old PHP with the new version, but I'd like a way to install the new version at the same time, so I can test it before removing the old PHP on the server.
     
  4. Sergey L

    Sergey L

    Messages:
    0
    So far running two versions of PHP is possible on Plesk for Windows only.
    On Linux most distributions won't let two PHP versions installed, one will replace another.
    Which OS you are on now?
     
  5. iantresman

    iantresman Bit Poster

    Messages:
    19
    Sorry, I'm not sure. Can I find out from Tools? I've tried Server Information, but I'm not sure what I'm looking for. If it's not readily available, it would be a useful addition to Server Information, to show the installed version of Apache, OS, PHP, mySQL, and other core modules.
     
  6. Sergey L

    Sergey L

    Messages:
    0
    True, instead of OS the kernel version is shown currently. We'll need to correct it. Until that you probably have to get this information for a provider selling the server to you.

    Apache, PHP, MySQL versions can be seen in Tools & Settings > Server Components
     
  7. iantresman

    iantresman Bit Poster

    Messages:
    19
    CentOS release 5.5. I guess if it does not support two or more versions of PHP, I should encourage them to do so!
     
  8. Sergey L

    Sergey L

    Messages:
    0
    Hi, CentOS 5 yet can have multiple PHP version as they ship php53-* package (so they can also have php51-*, php52-*). But CentOS 6 is shipping only php-* package, thus if php-5.3 is installed, it will replace php-5.1 or php-5.2 installed previously.
     
  9. WilliamPaul

    WilliamPaul

    Messages:
    45
    I know this,but was not quite sure about the versions. Finally got here


    __________________
    Macbook Pro 17 2.8Ghz; Host OS: Snow Leopard 10.6.2, 32-bit;Guest OS: Windows 7 Ultimate x64... Proud [​IMG]
     

Share This Page