Screen flashes with Gnome-Shell, Parallels 7, Ubuntu 11.10

Discussion in 'Linux Guest OS Discussion' started by deanproxy, Jan 5, 2012.

  1. deanproxy

    deanproxy

    Messages:
    22
    I was excited to find out that Parallels supports OpenGL so that I could run Gnome-Shell in Linux on my VM. I downloaded the trial version of Parallels to test this out and make sure it works well enough to be productive in it. For a while, it was great and then all of the sudden the screen flashed and made it look like all of my applications had closed. After about a second, everything came back to normal. I figured it was just something I had done. However, a little while later, the same thing. Then about 30 minutes later, the same thing. However, this time it seemed to make gnome-shell crash and all of my virtual desktops were gone, the window borders were gone and I was left with a bunch of cluttered windows on my desktop. I couldn't do anything so I had to shutdown the VM and restart.

    I'm running this on a MacBook Pro, i7 processor with 8G of memory. I have assigned 4 cores and 3G of memory to the VM. I have assigned 32M of memory to the video (although I recently upped it to 256M hoping it would help some) and I have it set to make the VM have more performance than my Mac. I am also running it in full screen mode.

    Does anyone else have this problem? I would really like to purchase a copy of Parallels, but this would certainly stop me from doing so if this problem is typical and there are no work arounds as it would keep me from being productive.
     
  2. Specimen

    Specimen Product Expert

    Messages:
    3,244
    Did you install Parallels Tools?

    Also:
    Don't assign all your CPUs to the virtual machine, use the default settings for CPUs and Video RAM (256 minimum) and only if these aren't satifactory should you mess with them. But first, install Parallels Tools (see User Guide).
     
  3. deanproxy

    deanproxy

    Messages:
    22
    Yep, I have Parallel Tools installed.

    My processor has 8 cores, so I'm only using 4 of them. The default setting for the video card was 32M and I bumped it up to the max at 256M hoping this would fix the flashing, but it didn't.
     
  4. HeadGeek

    HeadGeek

    Messages:
    8
    I've had similar problems here over the last week or two, ever since I upgraded to Ubuntu 11.10 and Gnome-Shell (Unity isn't quite useful at present). The symptoms are decidedly odd:

    * The screen flashes all-white (or rarely all-black).
    * My Pidgin window, normally hidden, gets unhidden.
    * Claws-Mail, normally visible, gets hidden.

    This happens maybe one to four times a day, seemingly completely at random. Sometimes it goes on for twenty seconds or more before it calms down, with the hard drive reading continuously. I've noticed that System Load Indicator says that something on the Linux VM had accessed the network at the same time this started; I can't imagine how that could be related, but it happens every time, so I suspect it must be. If I switch to a different virtual desktop, the screen is repainted properly, but then goes all-white again immediately until it calms down.

    I'm running it on a MacBook Pro (mid-2009, dual-core and 8Gb of memory), with one core and 2.25G of memory for the VM. Haven't touched any video memory setting. The VM is running full screen on an external monitor.

    Except for this problem, I've had no real trouble with Parallels or Gnome-Shell, but this is highly annoying.

    Specimen, I *do* have Parallels Tools installed.
     
  5. deanproxy

    deanproxy

    Messages:
    22
    I just had the same issue that HeadGeek has. Usually for me it's just a flash and it shows me my desktop with no applications open and then another flash and it's back to normal. This time however, it did exactly what HeadGeek described.

    This is really bad... Anyone else have this issue? Any work around? I really want this to work so I can run gnome shell...

    Is anyone running gnome shell successfully without issues? If so, please let me know what your settings are and are you using 32bit or 64bit ubuntu?
     
    Last edited: Jan 6, 2012
  6. HeadGeek

    HeadGeek

    Messages:
    8
    When you said you had an eight-core machine, I assumed you were using a desktop, rather than a MacBook Pro as you said earlier. I've always assumed that the twenty-second thing is because the hard drive in this machine is very slow, but if you're seeing it too, then I doubt that's the case.

    Curiously enough, I just had an instance without the twenty-second delay, as you described above. The entire screen went black, except for the tiny System Load Indicator window that I've got in the top bar, but as soon as I hit alt-tab, everything came back normal (though a terminal window I had open had resized itself to 80x18 instead of the 80x22 that it was previously). (And while typing this paragraph, it did the same, though all white instead. Both times, there was a quick surge of network activity at the exact same time.)

    I'd been assuming that it's a Gnome-Shell bug, but my Google searches haven't found any report other than yours that match the symptoms. They might be out there, and I just can't find them in the noise about Adobe Flash and other old black-screen and white-screen problems that the shell has had.
     
  7. deanproxy

    deanproxy

    Messages:
    22
    Parallels sees my processor as 8 CPU's because it has 4 cores and then 4 hyperthreading which makes some systems appears to have 8 cpus I guess. I can try taking it down to 2 CPU's which would only use 2 cores, I guess... I'm not sure how the hyperthreading stuff works in the i7 processor, but everything on my system that looks at the processor seems to think it has 8 cores.

    I don't think it's a gnome-shell problem because I'm running it natively on my desktop at work and a buddy of mine is doing the same on his laptop and these issues don't happen.

    I've noticed that the flashing takes place whenever anything draws on the screen. Such as a dialog box or even an incoming message from Empathy. It doesn't happen all of the time. Just sometimes, but it's always when something is getting ready to draw on the screen. It's as if it runs out of memory or something and has to "refresh". I'm sure that's not the issue, but that's what it reminds me of...

    Also, I seriously doubt this will help any, but I'm trying the 64bit version of ubuntu on my MacBook Air. It too was having the same issues, so I am currently using the 64bit version of Ubuntu on it right now. So far so good, but I'm only 30 minutes into using it and haven't really had much going on other than typing this.
     
    Last edited: Jan 6, 2012
  8. deanproxy

    deanproxy

    Messages:
    22
    I'd like to recant my last statement about this working fine natively. I was just discussing this with my friend and I believe we misunderstood each other when we discussed this before. He said that he too has noticed the screen flashes where his entire screen will go blank and then refresh itself. He said it's almost as if Gnome-Shell crashes but handles reloading itself properly... That's what it's like for me.

    I will note, that after I did a system update today, those flashes have not happened in the past few hours. So maybe the updates I did today helped some. I'll repost if I have any further issues.
     
  9. dpickett

    dpickett Bit Poster

    Messages:
    64
    In my experience the screen flashing is a Gnome Shell thing: whenever it happens I see log messages about Gnome Shell having received a kill signal. Occasionally the Shell will get into a loop of crashing over and over. When this happens I press option-F2, which brings up a small text field, then type "r", which restarts Gnome Shell.

    FWIW, I find the latest Ubuntu runs really well with 2 processors, 2 GB of RAM and 256 MB of VRAM.
     
  10. HeadGeek

    HeadGeek

    Messages:
    8
    Yes, that seems to be the case here, now that I know what to look for. Nothing to do with Parallels at all.

    Thanks for the r-to-restart hint.
     
  11. dpickett

    dpickett Bit Poster

    Messages:
    64
    You can also type "rt" which reloads the current theme.
     
  12. deanproxy

    deanproxy

    Messages:
    22
    Ok, I'm almost certain now that it is not gnome-shell. I have installed it on my MacBook Air natively and have been running it without a hiccup for days now. No flashes at all. However, if I boot into the Mac partition and run it under Parallels, I get constant flashing and blacking out of the screen and cannot find a remedy for it. This is doing the same work... Web browser, Terminal, Thunderbird and Rhythmbox... without fail it will always flash and turn black in Parallels.
     
  13. deanproxy

    deanproxy

    Messages:
    22
    Actually, let me restate that... It is gnome-shell doing the crashing. However, this crash only exists inside of Parallels. It does not exist when I'm running Linux natively on the same laptop. So, there is something about the way it's interacting with the VM that makes it have these frequent crashes. I have not been able to figure it out. I have tried many different configurations including the defaults and I continue to get the crashes.
     
  14. dpickett

    dpickett Bit Poster

    Messages:
    64
    I know from reading the Ubuntu forums--where I learned how to restart the shell--that people running Linux on bare metal were also having problems with Gnome Shell, so it's not something which is limited to Parallels. There may be something about Parallels which makes the Shell more crash-prone.

    I have also found that some shell themes are much more crash-prone than others.
     
  15. deanproxy

    deanproxy

    Messages:
    22
    Yeah, its certainly something about Parallels that triggers it more often. I'm not using any shell themes and the native install and thr parallels install are identical... native install is flawless.
     
  16. HeadGeek

    HeadGeek

    Messages:
    8
    It may be a fluke, but I just ran it for the last twenty-four hours without a single crash. During that time, I did all my usual stuff on it, but I didn't try switching desktops or closing (hiding) the Pidgin "Buddy List" window (which was the first thing I always did before).

    I thought this may be related, as many of the problems I see happen when windows are being opened/closed (or shown/hidden). It's not proof, but it's a start.

    I'll keep running that way for a while and see what happens.
     
  17. deanproxy

    deanproxy

    Messages:
    22
    Yeah, I agree. It is definitely when windows are opened/closed or redrawn (moved around and such). I am also always using multiple virtual desktops (3-5).
     
  18. HeadGeek

    HeadGeek

    Messages:
    8
    It seems that it *was* just a fluke -- I've just had my third crash since I posted that. :-( On the plus side, the twenty-seconds-or-more delay I was seeing previously was apparently because my disk cache wasn't large enough to keep everything in memory. I've given the virtual machine an extra gigabyte of memory now, and that delay has vanished, so the problem is a lot less irritating than it was.
     
  19. deanproxy

    deanproxy

    Messages:
    22
    I gave up... My trial edition of Parallels is finished and it just wouldn't run satisfactory so I won't be purchasing it. I'd be showing a co-worker some code at work and then all of the sudden my screen would blank and we'd lose track of where we were in the code. It's a small annoyance that can become very large in certain situations... :)

    I'll try the next version to see if it's any better... I hope they can figure out what it is with Parallels that causes Gnome-Shell to freak out like that...
     
  20. HeadGeek

    HeadGeek

    Messages:
    8
    There's apparently a Gnome-Shell update slated for March. If that doesn't at least reduce the problem (and hopefully correct it in its entirety), I'll be very surprised.
     

Share This Page