Screen no longer filled in full screen mode

Discussion in 'Installation and Configuration of Parallels Desktop' started by MaciejZ, Jun 27, 2023.

  1. MaciejZ

    MaciejZ Bit poster

    Messages:
    5
    Hi!
    Filling screen on my MacBook Pro 16 M1 Pro has stopped working properly for full screen mode around parallels 18.3.X. Previously VM would fill the whole screen (but the notch), now when I enter the full screen black bars are displayed on the left and right sides of my screen. What's even worse this behaviour is pretty buggy and if I close the VM (but not parallels) sometimes the borders are still present on the Mac host desktop.

    I attach three screenshots: one with the fullscreen problem, second one where the borders disturb the main host, third one that indicates how the screen should normally look like.

    Things I have already done:
    1. Reinstalled Parallels
    2. Reinstalled Parallels tools
    3. Tried all the Full Screen > Advanced > Stretch/Keep/Auto/Off options (previously it has always been on auto)
    4. Tried changing resolution in Windows settings
     

    Attached Files:

  2. MaciejZ

    MaciejZ Bit poster

    Messages:
    5
    Best Answer
    @dylanc1 After some time Parallels managed to provide me with a solution to this problem. FYI this is what has helped me (hope it works for you too):

     
  3. Adeboye Adeotan

    Adeboye Adeotan Staff Member

    Messages:
    358

    Hello MaciejZ,

    To assist with troubleshooting this issue and for the sake of clarity, kindly specify using filenames which of the uploaded photos you referred to here "one with the fullscreen problem, second one where the borders disturb the main host, third one that indicates how the screen should normally look like".

    Additionally, kindly provide us with a technical report while the issue is reproduced. To do this, please
    click the Parallels icon > Help > Send technical data > check "Attach screenshots..." > press Send Report) and provide its 9-digit ID here.

    Thank you.
     
  4. MaciejZ

    MaciejZ Bit poster

    Messages:
    5
    Hi,
    IMG_7202 shows how screen looks normally, 7201 shows how parallels look like when in full screen. Notice the borders on the left and right sides on the screen - they are much wider in Parallels. 7203 shows how the problem looks like when it "spreads" from parallels to the whole system (here the problem should be most visible if you compare 7203 with 7202).

    I've sent the report; the ID is 429547050.

    Thank you, looking forward to resolve this issue.
     
  5. MaciejZ

    MaciejZ Bit poster

    Messages:
    5
    I've replied in the comment above, not sure you/anyone from the parallels stuff got notified. Really looking forward to solving this issue.
     
  6. MaciejZ

    MaciejZ Bit poster

    Messages:
    5
    I am writing on the post to publicly let anyone know how disappointing Parallels suport is in case of any serious issue.

    I've been in contact with the support in regard to this issue for over a month. They had me provide numerous examples of the problem thought the month including images, descriptions, videos, reports. They never acknowledged any of my previous explanations, instead kept me wasting my time on video recording the same issue over and over again. I was tasked with redoing things that I have stated I had done previously in my first post in this thread. I have reinstalled/restarted Parallels, VM, Windows, rested Full screen mode several times, usually first on my own initiative, then again on Parallels' request. Not to mention that my last message here was completely ignored.

    Working with Parallels support has felt like worst kind of bureaucracy. If your issue is serious, they will task you with performing obvious turn off & on tasks and sending endless repots without any technical attention.
     
  7. dylanc1

    dylanc1 Bit poster

    Messages:
    4
    I'm experiencing the same issue as this user. I'm running Windows 11 ARM on Parallels and using it in full-screen mode on an M2 MacBook Pro. Ever since the form factor resolution of the M2 MacBook Pro changed, I've been unable to utilize the entire screen of the MacBook monitor in full-screen mode on Windows, regardless of the resolution setting. This causes inconvenience as the screen size keeps changing when switching between Mac and Windows. Please update Parallels to add a resolution option that allows full-screen use of the entire screen on the MacBook when in full-screen mode.
     
  8. MaciejZ

    MaciejZ Bit poster

    Messages:
    5
    Best Answer
    @dylanc1 After some time Parallels managed to provide me with a solution to this problem. FYI this is what has helped me (hope it works for you too):

     
  9. dylanc1

    dylanc1 Bit poster

    Messages:
    4
    The issue was resolved after I followed the procedure you provided. Thank you so much for sharing this solution with me. This problem had been bothering me, and now I feel a great sense of relief.
     
  10. dylanc1

    dylanc1 Bit poster

    Messages:
    4
    After implementing the previously mentioned solution, the original problem was resolved. But now, I am facing another issue. I run Windows through Parallels and find it bothersome when the menu bar appears every time I move the mouse cursor to the top of the screen. To mitigate this, I accessed the VM's configuration menu, went to Hardware -> Mouse & Keyboard, clicked on Advanced Settings, and enabled the option to keep the mouse pointer at the window's edge. However, ever since fixing the fullscreen issue, I have encountered a new problem where the mouse cursor is drifting beyond the edge of the Windows screen. Is there any way to resolve this?
     
  11. dylanc1

    dylanc1 Bit poster

    Messages:
    4
    After applying the aforementioned solution, the initial problem was resolved. However, a new issue has arisen. I use Parallels to run Windows, and I find it annoying when the menu appears every time I move the mouse cursor to the top of the screen. To address this, I went to the configuration menu of the VM, selected Hardware -> Mouse & Keyboard, clicked on Advanced Settings, and enabled the option to keep the mouse pointer at the edge of the window. However, since solving the fullscreen issue, I'm now experiencing a problem where the mouse escapes the edge of the Windows screen. Is there a solution to this problem?
     

Share This Page