screen resolution issues in Parallels Client V19 for RDP standard in MAC

Discussion in 'Parallels Client for Mac' started by marlynU, Aug 8, 2022.

  1. marlynU

    marlynU Bit Poster

    Messages:
    6
    We use the standard rdp option of parallels client to access our windows computers but with the version 19 update the resolution in the connection is very small and we do not see the applications, bars and icons. This happens only with the update of the application on Mac computers error resolucion.png
     
  2. jpc

    jpc Kilo Poster

    Messages:
    397
    @marlynU It seems that you are connecting to a Windows 2008/R2 server. From what I understand, to improve compatibility with newer RDP (2012R2 and later) servers, the macOS client is now redirecting the actual resolution to the RDP server. Unfortunately Windows 2008/R2 does not support this. There should be an option in the client's (global) options to use "DPI Aware" connections. Disable it to restore the old behaviour.
     
  3. marlynU

    marlynU Bit Poster

    Messages:
    6
    Thanks for your answer. This also happens with Windows server 2012 R2. All the desktop and icons of the virtual machine are not displayed because they are in miniature
     
  4. jpc

    jpc Kilo Poster

    Messages:
    397
    It seems strange that your Windows Server 2012R2 gave you the same problem.

    Can you please do the following, in order:
    1. Launch a desktop session connected to Windows Server 2012R2, open a new notepad window and post a screenshot.
    2. Make sure to logoff any existing sessions for your user on Windows Server 2012R2 (can check via task manager). Then attempt to launch a desktop session again. In some cases, explorer resizes the icons incorrectly when switching from a session that has a 100% scale to one with a larger dpi scale (on most modern macOS systems, dpi scale normally starts at 200%)
    3. If the problem is not resolved with a new session, then you should be able to disable DPI awareness from the Parallels Client for macOS's Preferences, under the Advanced page. Always test these changes with a new session.

    Hope this helps.
     
  5. Frederic Puhan

    Frederic Puhan Bit Poster

    Messages:
    33
    I found I had the same issue connecting to my Linux server (using XRDP). The desktop renders fine, but the menus and windows were all shrunken. This could be handy, but I'd rather have the same dimensions as my Mac's screen. Disabling the DPI option seems to have worked. Thanks!
     
    jpc likes this.

Share This Page