Scrolling in Linux/Ubuntu is either too slow or too fast

Discussion in 'Linux Guest OS Discussion' started by BryanSmith, Jan 1, 2023.

  1. BryanSmith

    BryanSmith Bit Poster

    Messages:
    7
    I am using a Macbook Pro M1 2021, and only using the built-in trackpad, to run a Linux guest.
    I understand that Linux/Ubuntu has moved towards using libinput, and that this means that trackpad scroll speed is not customizable.
    Further, the virtual mouse provided by Parallels is not a trackpad, and doesn't have configurable parameters.
    It is possible to adjust scroll speed in Firefox. But not for other applications, such as VSCode, or Nautilus.
    In general, the scrolling experience is barely acceptable, to the point where I would happily switch to VMware if their solution was better, but it's not.
    Can you please implement trackpad support in Linux/Ubuntu? It works well/smoothly in my Windows guest, equivalent to the scrolling experience on the host.
    This would provide amazing value for the Mac-Parallels-Linux ecosystem, and keep me as a customer for many years.

    --
    I have tried:
    - libinput customization
    - smooth scrolling in the configuration file
    - "optimize for games". Note that I use side-swiping to change between host and guest (and this works well with Windows), so "optimize for games" is not even an option for me, because it grabs all gestures.
     
  2. Asish

    Asish Staff Member

    Messages:
    199
  3. SkylerT

    SkylerT Bit Poster

    Messages:
    4
    That is not a solution. I have Parallels installed on both my M1 Macbook Air (16gb/1tb) and my M1 Max Macbook Pro (32gb/1tb) and they both have the same issue as the OP regardless of the Linux distro. Windows scrolling is great but any Linux distro has horrible scrolling to the point where it is pretty much unusable without manually grabbing the scroll bar and using it. Scrolling with two fingers just jumps all over the place. I've seen a dozen or more forum posts that all end with the user giving up in frustration because the same recycled responses are given of reinstalling parallels tools or pointing users to the "Mouse/Trackpad optimizations in a virtual machine" article.

    What I would like to see is a bug ticket opened with the engineering team and actually get some eyes and engineering resources on fixing this problem. As it stands right now, I pretty much only use linux vms with no desktop environment and simply ssh into them from my host for this reason. Please fix this.
     
    Ali28 and BryanSmith like this.
  4. AwlsomeAlex

    AwlsomeAlex Bit Poster

    Messages:
    18
    This has been an issue with Parallels for as long as I can remember (and continues to be quite unacceptable). This is what I used to do to at least make it somewhat usable:

    via: https://forum.parallels.com/threads/ability-to-disable-smooth-scrolling.350866/
    To disable smooth scrolling manually, please shutdown the VM > locate in Finder > right-click and select "Show Package Contents" > open config.pvs in TextEdit > locate this key and change the value to 0:

    <SmoothScrolling dyn_lists="">
    <Enabled>10</Enabled>
    </SmoothScrolling>

    Then press Cmd+S to save the file > close it and start the VM.
    You can also mess around with Xorg configs a bit to manually change the scrolling speed. KDE provides a nice settings panel to do this from. The real fix would be to fix your code @parallels.
     
    MichaelF51 likes this.
  5. SkylerT

    SkylerT Bit Poster

    Messages:
    4
    Thanks for the reply. Yes, I already disabled smooth scrolling and that made it a little better but not really usable IMO. I will give it a go for messing with Xorg settings and see what that does next time I create a vm where I need a GUI.
     
  6. BryanSmith

    BryanSmith Bit Poster

    Messages:
    7
    @Asish@Parallels Can you ask the developer team whether they are working on supporting smooth scrolling in Linux, so that it works equivalent to the experience in MacOS and Windows? What's the roadmap?
     
  7. BryanSmith

    BryanSmith Bit Poster

    Messages:
    7
    @Asish@Parallels Or could Parallels offer a bounty to the open source community to fix this? It would make a Macbook much more suitable for development that requires an isolated environment.
     
  8. Ali28

    Ali28 Bit Poster

    Messages:
    2
    Same here, very annoying indeed. I am with Parallels for over 10 years by now and will stay for Windows machines - they are fantastic. But Linux is barely usable because of scrolling (and issues with multi screen setups).
    Do VMWare, VB and others provide better scrolling experience?
     
  9. BryanSmith

    BryanSmith Bit Poster

    Messages:
    7
    I always used a mouse until I started using Mac, and then smooth scrolling is more essential.
    It should be trivial to implement, especially considering the existing work on Windows.
    @Asish@Parallels Do you have any update from your engineering team on this? How do you track feature requests?
     
  10. BryanSmith

    BryanSmith Bit Poster

    Messages:
    7
    Hello,

    Did you contact the engineering team to find out what's preventing this from being implemented?
     
  11. sfgvieira

    sfgvieira Bit Poster

    Messages:
    1
    Any news on this? It really makes development in the VM unbearable :(
     
  12. AwlsomeAlex

    AwlsomeAlex Bit Poster

    Messages:
    18
    My suggestion above (#4) makes it a lot more usable (not macOS standards, but better than it is now...). Give it a go, hopefully it helps!
     
  13. BryanSmith

    BryanSmith Bit Poster

    Messages:
    7
    Yes, the news is that Parallels has done absolutely nothing despite numerous attempts at asking for a simple "no, we don't want to develop this feature".
    The various hacks that keep being proposed don't solve the problem and are just being rehashed repeatedly to cover up the fact that Parallels doesn't care about using Linux as a guest system.
     
  14. Pavel Merkulov

    Pavel Merkulov Staff Member

    Messages:
    80
    Hello,

    Thank you for your feedback.

    To try to resolve the issue, please perform the following steps:

    1. Shut down the Virtual Machine. Make sure that the virtual machine is shut down. If it is in a suspended state, please run it and then shut down (Actions > Shut Down).

    2. Locate your Ubuntu virtual machine (https://kb.parallels.com/10109)

    3. Open your Ubuntu Virtual Machine by right click on it and choose Show Package Content.

    4. Find and open config.pvs file by right click and choose Open With -> TextEdit

    5. Then you need to find this:
    <SmoothScrolling dyn_lists="">
    <Enabled>0</Enabled>
    </SmoothScrolling>

    and switch 0 to 1.

    6. Restart Parallels Desktop.

    7. Check if the issue persists.

    In case if the issue persists, please collect a technical report (click Parallels icon || > Help > Send technical data > check "Attach screenshots..." > press Send Report) and send the report's 9-digit ID in a reply.
     
  15. BryanSmith

    BryanSmith Bit Poster

    Messages:
    7
    You see? I suspect that this forum just has bots that generate the same response over and over without actually adressing the issue.
     
  16. MichaelF51

    MichaelF51 Bit Poster

    Messages:
    4
    Brand new user, and noticed the mouse issue in my Ubuntu 24.02 VM. Went into Config file and found out it is already set to 0. So they took your advice but I'm not sure it's an improvement.
     

Share This Page