Shift key not detected for nested VM

Discussion in 'Windows Guest OS Discussion' started by KennethL5, Nov 20, 2017.

  1. KennethL5

    KennethL5 Bit Poster

    Messages:
    2
    Hi,

    I have Parallels 12 for Mac Business Edition and recently upgraded to Parallels 13. When I use Remote Desktop Connection to login into a Windows Server 2016 and then open Hyperv Manager try to console into another Windows Server 2016, parallels won't pick up the shift key (making it hard to login) on the login screen. I checked Parallels Desktop Application Shortcuts and it's all default so nothing special there.

    Is this a known issue? I didn't see it posted anywhere. Is there a workaround for this?

    thanks!
     
  2. MartijnS1

    MartijnS1 Bit Poster

    Messages:
    1
    I have a similar problem when connecting to a Windows server through RDC. If I enter fullscreen mode, the shift key is not recognised. However, when I rescale the screen and click outside my remote desktop, then back into my remote machine, the shift key works...

    Very annoying!
     
  3. KennethL5

    KennethL5 Bit Poster

    Messages:
    2
    MartijnS1,

    I changed keyboard settings in hardware > mouse & keyboard to 'Optimize for games' and added in 'Open Shortcuts Preferences...' Virtual Machine > Windows 10 to include From: shift To: shift. That seemed to solve my issues.
     
  4. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,359
    Hi @KennthL5, glad that your issue is resolved . Please reach us anytime for further assistance.
     
  5. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,359
    RaphaelF1 likes this.
  6. FrankH9

    FrankH9 Bit Poster

    Messages:
    2
    I've tried this and it doesn't work. Still no shift
     
  7. DavidH32

    DavidH32 Bit Poster

    Messages:
    1
    Same here. My workaround is to a) either press both Shift keys b) make sure the RDC session is not in full screen mode or c) set the RDC Options for Local Resources -> Apply Windows Key Combinations to "on this computer" all of which I find annoying and counterintuitive.
     
  8. dife

    dife Bit Poster

    Messages:
    11
    In my experience, pressing shift, the first key does not shift, but the subsequent keys are shifted in full screen mode as well. But this is very annoying.
    Parallels's team should find solution for this problem asap.
    BTW, I have 13.3.0
     
  9. RaphaelF1

    RaphaelF1 Bit Poster

    Messages:
    15
    Hooray! Using the optimize for games option worked perfectly for me. Tks much. R.
     
  10. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,359
    Hi @RaphaelF1 , We are glad that your issue is resolved. Please reach us anytime for further assistance.
     
  11. ChristianS16

    ChristianS16 Bit Poster

    Messages:
    6
    Dear Support,

    I am experiencing the same problem when using the Windows Remote Desktop Connection from within a Windows 10 VM to a Windows 10 desktop and have tried all the solutions discussed in https://kb.parallels.com/de/123602. The only one that works is the "optimise for games" keyboard setting, the other two including the advanced boot flags fail.

    Unfortunately, the keyboard has an undesirable side effect: the mappings of option+left|right arrow -> CTRL+left|right arrow do not work any longer. This is reproducible and happens every time.

    Any idea how to resolve this?
     

Share This Page