Skyrim

Discussion in 'Windows Guest OS Discussion' started by bge0, Nov 18, 2011.

  1. bge0

    bge0

    Messages:
    14
    Hello Parallels Devs,
    Please take a look at Skyrim on PD7. It works really well except for 2 issues:
    1) Sudden quit to desktop with no error message after playing for 5->10 min
    2) Mouse doesn't respond accurately within the game.
    I feel like these issues aren't major issues and should be easily fixable. I'm sure a ton of people would love to play this game from their VM's rather than rebooting into windows.
    Thanks in advance!
     
  2. hancop

    hancop

    Messages:
    2
    Agree developers lets Skyrim working on parallels 7

    This is a really popular game and we need support for it in parallels 7.

    Thanks
     
  3. Manders

    Manders

    Messages:
    1
    Yes, I agree. Parallels often touts its improved graphics performance, etc, but I'm not sure it counts for much unless the game runs for more than 5 minutes.
     
  4. hancop

    hancop

    Messages:
    2
    I can not even get Skyrim to start in Parallels 7, I just get a blank black screen ):
     
  5. AdrianRoberts

    AdrianRoberts

    Messages:
    1
    I realise this isn't necessarily helpful, but it has been running OK for me. On a mid-2010 iMac with 4Gb memory it ran OK on Low settings, but struggled a bit. I have just added another 8Gb memory and allocated 4Gb to the VM and it seems to run pretty well on High (though only a quick check so far).

    I guess those of you having problems have ensured there's enough memory allocated to the VM, the full 1Gb of video memory is set, and that 3D acceleration is enabled?

    Cheers,

    Adrian
     
  6. bge0

    bge0

    Messages:
    14
    Make sure you have gfxCardStatus and set it to Dedicated Video before starting your VM.
     
    Last edited: Nov 26, 2011
  7. bge0

    bge0

    Messages:
    14
    The game runs perfectly on Ultra Settings for me. I just make sure to disable AntiAliasing during startup. I have a 2010 MBP i7 Quad Core. Allocated 6 cores (i7 has hyper threading), 6gb ram, 768Mb Video from a Radeon 6750M.

    Still having mouse issues though, even after the newest update. The mouse seems to not smoothly move around. I know its not the mouse because the game works fine in Bootcamp. I think the issue with the crashes has been fixed though. Anyone have any ideas regarding the mouse problem?
     
  8. Specimen

    Specimen Product Expert

    Messages:
    3,244
    If you only allocate 4 cores, does the mouse work better? (reasoning: the mouse movement is processed both in the guest and host, and USB in host).
     
  9. bge0

    bge0

    Messages:
    14
    Ok that was not the issue. Issue is the same as described in other threads regarding mouse issue. Fixed it by disabling Smart Mouse. However needed to turn up scroll speed by a ton to get good gameplay. Can't complain though. At least it works. Will actually put the time delayed crash to a test now!
     
  10. ColterW

    ColterW

    Messages:
    9
    It works but saving screws it up

    I got it to work but it saves really slow, and is unplayable when it auto saves. Is there a disc setting I am missing that will allow it to read and write better?
     
  11. ColterW

    ColterW

    Messages:
    9
    use an xbox controller it works fine
     
  12. bge0

    bge0

    Messages:
    14
    Not sure. Don't have that problem.....But I do have an OCZ Vertex3 SATA6GBPS SSD though. Also, I'm using win7 fyi.
     
  13. ColterW

    ColterW

    Messages:
    9
    I am using XP with an image file IDE Location 0:0 not sure if tweaking this would help?
     
  14. bge0

    bge0

    Messages:
    14
    That seems like a physical location. Is it a Bootcamp XP? Also IDE? Probably the reason why its slow. Try creating a VM and test it on there with an expanding disk or something like that.
     
  15. ColterW

    ColterW

    Messages:
    9
    It is not a boot camp drive look at the screen shot, I am so close to making this work.

    [​IMG]
     
  16. ColterW

    ColterW

    Messages:
    9
  17. bge0

    bge0

    Messages:
    14
    Yea, like I said, probably has to do with you having an IDE drive. Mine is SATA.
     
  18. ColterW

    ColterW

    Messages:
    9
    I tries just setting it to SATA but XP has to have a driver so I guess I will try that
     
  19. spullara

    spullara

    Messages:
    29
    Mine lasts between 5 min and an hour before quitting to desktop. I fixed the mouse issue by turning off the modifier settings and using Microsoft intellimouse software on the Mac side. So it is playable until it crashes. Higher settings result in more frequent crashes. Seems like this should be fixable since it does work.
     
  20. ColterW

    ColterW

    Messages:
    9
    I got it to work

    It will still crash every now and again but you have to use Win 7, 720 screen res, and with the 1 gig video acceleration, keep it on the mid to low setting and it will not crash all that often. I think it could be fixed with an update. I skips a little but is playable.
     

Share This Page