[Solved] "Parallels Ethernet Adapter" is missing; No internet

Discussion in 'Windows Guest OS Discussion' started by RahulJ1, Nov 12, 2015.

  1. RahulJ1

    RahulJ1 Bit Poster

    Messages:
    7
    After updating to the latest Windows 10 (10586), and reinstalling Parallel tools, I don't see any "Parallels Ethernet Adapter" in my Device Manager.

    [​IMG]

    Consequently, I do not have any internet access in my Windows 10 environment.

    Parallels Desktop: Version 11.0.2 (31348)

    Could someone suggest a fix?
     
  2. ManojK@Parallels

    ManojK@Parallels Parallels Support

    Messages:
    367
    Please uninstall the 2 Hyper-V Virtual Ethernet Adapters as they are creating a conflict with the default Intel Pro adapter of Parallels and try reinstalling Parallels Tools.
     
  3. RahulJ1

    RahulJ1 Bit Poster

    Messages:
    7
    That doesn't help.
     
  4. Dhruba@Parallels

    Dhruba@Parallels Kilo Poster

    Messages:
    779
  5. RahulJ1

    RahulJ1 Bit Poster

    Messages:
    7
    I tried to create a support request. I got the following email as reply:

    >The product Parallels Desktop for Mac Pro Edition support is not covered by the Support contract you have.
     
  6. Elric

    Elric Parallels Developers

    Messages:
    1,673
    The entry "Intel PRO E1000" is the network adapter, it does the same functionality as the Parallels Ethernet (and it is a default emulation for Windows 7+).

    The problem you met is likely because of you have Microsoft HyperV role installed. As far as I know it will work only with Shared Networking
     
  7. RahulJ1

    RahulJ1 Bit Poster

    Messages:
    7
    I am using shared networking. Everything was working before upgrading to 10586.
     
  8. Elric

    Elric Parallels Developers

    Messages:
    1,673
    Please make sure that you are using Shared Networking. Then click Start -> Run and execute cmd.exe. Type in the appeared window command "ipconfig /all" (make sure that all output fits to the window). Then, without closing the window, click Parallels Desktop menu "Help"->"Send technical data", send a problem report (it is not necessary to provide description) and post here the report ID.
     
  9. RahulJ1

    RahulJ1 Bit Poster

    Messages:
    7
    Report ID: 80848264
     
  10. Elric

    Elric Parallels Developers

    Messages:
    1,673
    Sorry, it looks like the issue doesn't relate to Parallels, it appears to me like something Windows related.
    I'm not sure how Parallels Support handles issues like this..

    If you were upgrading to Windows 10 from earlier Windows, then likely you met the famous problem with disappearing network connections if some VPN client is installed. So far the only solution for this is to downgrade back, remove all VPN clients and upgrade to Windows 10 only after this.

    You can try to remove the network devices (by pressing Del in Device Manager) and refresh the devices, may be Windows will find and configure a Network Connection for it. Or try to google for phrase "Network connection disappeared". This thread looks promising http://www.tenforums.com/network-sharing/29638-no-network-after-windows-10-build-10586-update.html
     
  11. RahulJ1

    RahulJ1 Bit Poster

    Messages:
    7
    Thanks, a simple "netcfg -d" seems to have solved the issue. Got to hand it to Windows for the amazing update experience. :mad:

    Thanks a lot for helping me out.
     
  12. ManojK@Parallels

    ManojK@Parallels Parallels Support

    Messages:
    367
    We are glad that the issue is resolved. Feel free to reach out anytime for further assistance.
     
  13. LIAM

    LIAM Bit Poster

    Messages:
    4
    Dear All;
    I urgently need your advise, I was using paralel desktop 10, but later upgrade to version 16 , but as you can see in the attached pictures, I can not connect to the internet, I spend couple of hours to understand what is problem and finally got that in my windows=> device manager, there is no adaptor and "ethernet controller driver " for the network, and I guess it because I made mistake and install free trial or " parallel toolbox " . anyway I want to know how can I install this "ethernet controller " driver in my windows.
    by the way my windows is 7 and my network source in parallel control center is : shared network.
    thanks and waiting for your recommendation.
     

    Attached Files:

  14. Elric

    Elric Parallels Developers

    Messages:
    1,673
    Hi
    Hi! you need to install Parallels Tools for VM. It is done via menu of Parallels Desktop Action -> Install Parallels Tools

    Also I recommend to go to the VM Configuration -> Hardware -> Network -> Advanced and choose there "Intel PRO 1000" - it is the recommended type for Windows 7 vm, others likely will not work (actually Realtek will, but e1000 is still recommended).
     
  15. LIAM

    LIAM Bit Poster

    Messages:
    4
    thanks for reply, in my Parallels Desktop Action -> there is Reinstall parallels Tools and once I click it, then nothing happen, just a caution menue apear ( as attached file )
    also in my VM config ==>> advance, all content are gray color and can't choose anything ( attached picture )
     

    Attached Files:

  16. Elric

    Elric Parallels Developers

    Messages:
    1,673
    Likely you already have tools installed

    Please shutdown the VM; this setting cannot be edited on running VM

    And.. not sure how this happened. the Net has emulated type "virtio" - this will not work in Windows 7
     

Share This Page