Solved: Ubuntu 14.04 - 16.04 Upgrade fails to load login screen

Discussion in 'Linux Guest OS Discussion' started by Niall Campbell, Jan 20, 2017.

  1. Niall Campbell

    Niall Campbell Bit Poster

    I've been following BrianH2's steps to upgrade to 16.04, that is:
    But after restarting (step 7) Ubuntu fails to load the login screen. Instead I'm presented with:

    /dev/sda1: clean, 322731/4128168 files, 3366736/16514816 blocks
    Created slice User Slice of newrelic.
    Created Session c1 of user newrelic.
    Starting User Manager for UID 999...
    Created slice User Slice of gdm.
    Starting User Manager for UID 119...
    Started Session c2 of user gdm.
    Started User Manager for UID 999
    Started User Manager for UID 119.
    Starting Console Manager...
    Started Console Manager.
    Started LSB: Apache2 web server.
    Stopping User Manager for UID 119...
    And no login screen.
    The solution that has worked for me is involves reconfiguring lightdm. I'm unsure as to why this works but thought it would be helpful.
    1. Press CTRL+ALT+F2 to open the terminal window. Note that there might be a lot of flickering between the previous screen and the terminal window in parallels. This flickering subsided for me after a few minutes (when the hard disk read/write light stopped).
    2. Login to Ubuntu in the terminal if you're presented with the login prompt.
    3. Run the lightdm package configuration command
      sudo dpkg-reconfigure lightdm
    4. Select lightdm from the list.
    5. Restart Ubuntu
      sudo reboot now
    The lightdm greeter loads and I'm able to continue with BrianH2's upgrade steps.
  2. MartinB26

    MartinB26 Bit Poster

    I have the same problem and pressing CTRL+ALT+F2 and I get this, so happy, thanks Parallels for the great experience:

    Attached Files:

Share This Page