Special PW build 2226 for Linux 2.6.24 kernels

Discussion in 'Installation and Configuration in Windows and Linux' started by spectre, Mar 27, 2008.

  1. John@Parallels

    John@Parallels

    Messages:
    6,343
    I raised this question yesterday and I suppose to get answer in 2 -3 days
     
  2. mgpws

    mgpws

    Messages:
    17
    I too am waiting for 2.6.25

    to install OpenSuse 11.0, when will Parallels be ready for that?
     
  3. John@Parallels

    John@Parallels

    Messages:
    6,343
  4. Morgano

    Morgano

    Messages:
    13
    Nice to see progress :)

    Parallels tools not ready - does that mean Parallels shared folders is not working?
    (OK i can probably set up to share on LAN)

    USB is working?
     
  5. John@Parallels

    John@Parallels

    Messages:
    6,343
    There is no additional features in this build, only problem fixing, more features will be available in Parallels Workstation 3, it is in progress, and it will be almost with the same features as Parallels Desktop
     
  6. Morgano

    Morgano

    Messages:
    13
    So far I am only interested in getting back to the features we had...
    Both shared folders and USB is working for me in the 2232 build, for Linux and MSWin2k as guest.
    Network is not OK for me (crash), but not very important for me.

    I thought shared folders is part of Parallels tools for the VM guest?
    If so are they not working anymore if i install 2234 as you say the Parallels Tools in VM is not ready?
     
  7. John@Parallels

    John@Parallels

    Messages:
    6,343
    I meant for guest Linux OSes, for Windows there are no problems
     
  8. faa_70

    faa_70

    Messages:
    8
    okay, well my new install didn't work...can anyone help me?...here is the error log, it's giving me the same error..cannot compile and/or link drivers

    cd drivers && make KSRC=/lib/modules/2.6.25.14-69.fc8/build clean && cd ../
    make[1]: Entering directory `/usr/lib/parallels/drivers'
    cd drv_main/ && make clean && cd ..
    make[2]: Entering directory `/usr/lib/parallels/drivers/drv_main'
    rm -rf *.o *.ko .*.cmd *.mod.c .tmp_versions
    cd common; rm -rf *.o .*.cmd .tmp_versions; cd ..
    cd mm; rm -rf *.o .*.cmd .tmp_versions; cd ..
    make[2]: Leaving directory `/usr/lib/parallels/drivers/drv_main'
    cd hypervisor/ && make clean && cd ..
    make[2]: Entering directory `/usr/lib/parallels/drivers/hypervisor'
    make[2]: Leaving directory `/usr/lib/parallels/drivers/hypervisor'
    cd drv_net/linux/ && make clean && cd ..
    make[2]: Entering directory `/usr/lib/parallels/drivers/drv_net/linux'
    rm -rf *.o *.ko .*.cmd *.mod.c .tmp_versions
    make[2]: Leaving directory `/usr/lib/parallels/drivers/drv_net/linux'
    cd drv_virtualnic/ && make clean && cd ..
    make[2]: Entering directory `/usr/lib/parallels/drivers/drv_virtualnic'
    rm -rf *.o *.ko .*.cmd *.mod.c .tmp_versions
    make[2]: Leaving directory `/usr/lib/parallels/drivers/drv_virtualnic'
    make[1]: Leaving directory `/usr/lib/parallels/drivers'
    cd drivers && make KSRC=/lib/modules/2.6.25.14-69.fc8/build all && cd ../
    make[1]: Entering directory `/usr/lib/parallels/drivers'
    cd drv_main/ && make clean && cd ..
    make[2]: Entering directory `/usr/lib/parallels/drivers/drv_main'
    rm -rf *.o *.ko .*.cmd *.mod.c .tmp_versions
    cd common; rm -rf *.o .*.cmd .tmp_versions; cd ..
    cd mm; rm -rf *.o .*.cmd .tmp_versions; cd ..
    make[2]: Leaving directory `/usr/lib/parallels/drivers/drv_main'
    cd hypervisor/ && make clean && cd ..
    make[2]: Entering directory `/usr/lib/parallels/drivers/hypervisor'
    make[2]: Leaving directory `/usr/lib/parallels/drivers/hypervisor'
    cd drv_net/linux/ && make clean && cd ..
    make[2]: Entering directory `/usr/lib/parallels/drivers/drv_net/linux'
    rm -rf *.o *.ko .*.cmd *.mod.c .tmp_versions
    make[2]: Leaving directory `/usr/lib/parallels/drivers/drv_net/linux'
    cd drv_virtualnic/ && make clean && cd ..
    make[2]: Entering directory `/usr/lib/parallels/drivers/drv_virtualnic'
    rm -rf *.o *.ko .*.cmd *.mod.c .tmp_versions
    make[2]: Leaving directory `/usr/lib/parallels/drivers/drv_virtualnic'
    cd drv_main/ && make KSRC=/lib/modules/2.6.25.14-69.fc8/build && cd ..
    make[2]: Entering directory `/usr/lib/parallels/drivers/drv_main'
    make -C /lib/modules/2.6.25.14-69.fc8/build SUBDIRS=/usr/lib/parallels/drivers/drv_main SRCROOT=/usr/lib/parallels/drivers/drv_main modules
    make[3]: Entering directory `/usr/src/kernels/2.6.25.14-69.fc8-i586'
    CC [M] /usr/lib/parallels/drivers/drv_main/vmmain.o
    In file included from /usr/lib/parallels/drivers/drv_main/vmmain.c:29:
    /usr/lib/parallels/drivers/drv_main/vmmain.h:193: error: field ‘pmmAccSem’ has incomplete type
    /usr/lib/parallels/drivers/drv_main/vmmain.h:206: error: field ‘wsSem’ has incomplete type
    make[4]: *** [/usr/lib/parallels/drivers/drv_main/vmmain.o] Error 1
    make[3]: *** [_module_/usr/lib/parallels/drivers/drv_main] Error 2
    make[3]: Leaving directory `/usr/src/kernels/2.6.25.14-69.fc8-i586'
    make[2]: *** [all] Error 2
    make[2]: Leaving directory `/usr/lib/parallels/drivers/drv_main'
    make[1]: *** [vmmain] Error 2
    make[1]: Leaving directory `/usr/lib/parallels/drivers'
    make: *** [build] Error 2
     
  9. John@Parallels

    John@Parallels

    Messages:
    6,343
    Kernel 2.6.25 is not supported for Parallels Tools,
    please wait for update on Parallel Workstation, PW3 will be free upgrade
     
  10. faa_70

    faa_70

    Messages:
    8
    Okay, but i wasn't trying to install Parallels Tools...i was just trying to install parallels which stopped working when i upgraded from FC6 to FC8...it hasn't worked since...

    When will PW3 be available? and will it break again when i run an update?
     
  11. John@Parallels

    John@Parallels

    Messages:
    6,343
    I am not exactly sure about the PW3 (in time), but we are working to bring Parallels Workstation also to be compiled on kernel 2.6.25
     
  12. emc2008

    emc2008

    Messages:
    4
    John, seems like you are the only one around here working for parallels. I've been checking daily for progress on 2.6.25 support. Is it close? Do you need some beta testers? Where is the best place to look for updates?
     
  13. 1nept

    1nept

    Messages:
    12
    patch to support linux kernel 2.6.26

    To run PW build 2234 under linux kernel 2.6.26 one needs:

    1) To have a kernel compiled with CONFIG_UNUSED_SYMBOLS=y option

    2) To apply this patch to PW build 2234 (posted above in this thread).

    Run something like:

    mkdir temp
    cd temp
    tar -xvzf /usr/lib/parallels/devel.tar.gz
    patch -p1 </path_to_patch/support_2.6.26.patch
    tar -czf devel.tar.gz *

    Copy created devel.tar.gz over original /usr/lib/parallels/devel.tar.gz and run parallels-config
     
  14. Robertjm

    Robertjm Bit Poster

    Messages:
    47
    Free upgrade???

    Not to doubt you BUT when v3.0 for OSX was released it was in no way shape or form a free upgrade. The deal was $49.99 for the upgrade, which you offered to all registered users regardless of platform.

    Robert

     
  15. John@Parallels

    John@Parallels

    Messages:
    6,343
    Actually there are 2 different products, Parallels Desktop and Parallels Workstation
     
  16. Robertjm

    Robertjm Bit Poster

    Messages:
    47
    patch doesn't seem to do anything.

    Thanks!! However, when I get to the step of running patch nothing seems to happen, and the HDD light isn't flashing at all. (And I'm running patch with the --verbose switch so I'd see text flying by on the screen if it were doing anything...right?

    Robert


     
  17. 1nept

    1nept

    Messages:
    12
    These symptoms are such as if you missed '<' in the command line, didn't you?
    You should run patch exactly this way:
    Code:
    patch -p1 </path_to_patch/support_2.6.26.patch
    Also, check if support_2.6.26.patch was downloaded correctly - its size should be 5920 bytes.
     
  18. dmattox

    dmattox

    Messages:
    1
    Parallels build 2234 with kernel 2.6.26

    Will Parallels build 2234 run under Fedora 9 and Linux kernel 2.6.26?

    Configuration
    Fedora 9
    kernel 2.6.26
    Parallels build 2234 with applied patch from this thread.

    I run parallels from the command line, I get the following error.

    >parallels
    Qt: Locales not supported on X server

    The configuration wizard starts up and I create a Windows - Windows XP virtual setup. I click the run button on the side and get a popup dialog box with the following error "unable to communicate with hypervision".

    Any ideas how to solve?

    thanks
    Darrel
     
  19. Morgano

    Morgano

    Messages:
    13
    Any new date for major update release yet?

    I would like to upgrade my system to kernel 2.6.27 from Manbo; Mandriva 2009.0
    (When) will Parallels Workstation work on that kernel?
    Currently i am using build 2234 on kernel 2.6.24-7
     
  20. emc2008

    emc2008

    Messages:
    4
    no, if you upgrade to any kernel newer than you are running, you will not be able to use Parallels. I've been reading on here that an update is right around the corner since June. Parallels should drop linux and windows and only sell to mac users if they are not going to devote any developers to the project.
     

Share This Page