Still over 100% CPU Usage . . . HELP

Discussion in 'Installation and Configuration' started by JohnH36, Feb 26, 2020.

  1. MirkoA1

    MirkoA1 Bit Poster

    Messages:
    1
    Hello,

    yes I use a second Monitor and I have Problems...
    Now I´m back to PD15 without no Problems
     
  2. NathanM7

    NathanM7

    Messages:
    1
    I was having the same problem. It would seem that the solution for me was to uncheck the "share Mac applications with windows" box in the applications section of the configuration. After doing that I have not heard the fans kick on, and windows cpu usage in activity monitor is around 10-30%.
     
  3. BrianC14

    BrianC14

    Messages:
    1
    Upon opening (Big Sur / PD 16, i7 4 Ghz), usage immediately jumps to 164% then drops. Opening PowerPoint file jumps to 190% then fluxes 100%<>190%. FYI, I run on a second monitor as well.
     
  4. RalphM4

    RalphM4 Bit Poster

    Messages:
    1
    For me, the "solution" to high CPU utilization and constantly running fans was to follow the advice here and change to these vm configuration settings:
    Processors used: 1
    Memory 4+ GB (4096 MB) <-- Linked thread recommends 4 GB but I have 32 GB available, so I tried with 12 GB ram setting and works fine for me. Also worked fine at 4 GB.
    Adaptive hypervisor: Off
    Graphics card: memory automatically.​
    My fans no longer constantly run (silent again even when running Visual Studio, SSMS, and other dev apps all at same time) and my windows machine is fully available within 1 minute after startup or restart, and everything works "normally." Prior to using this configuration, I used the recommended number of processors and other default/recommended settings and was frustrated that I had to wait 10+ minutes for the vm to be really usable (would take several minutes after clicking an app for it to load and become usable) and my 2019 16" MBP (2.4 GHz 8-Core Intel Core i9, 32 GB ram) fans would run full blast constantly and showed % CPU of 600%+ in Activity Monitor. I'm running Parallels Version 16.1.3 (49160).
     
  5. ryderpat

    ryderpat Bit Poster

    Messages:
    2
    dont set on 4cpu. only 1 cpu will be faster.
    this is the problem
     
  6. BigGJS

    BigGJS Bit Poster

    Messages:
    21
    'dont set on 4cpu. only 1 cpu will be faster.
    this is the problem'
    Doesn't that depend on your setup? I have 64GB and 16 CPUs available, I give Parallels 16GB and 8 CPUs for my Win10 and also limit the processor to moderate ... and the fans still kick in
     
  7. Jdx636

    Jdx636 Bit Poster

    Messages:
    1
    Hi,
    I've reduced to one cpu but the performance lags. Has there been any solution from parallels engineering team as of yet?
    Thank you.
     
  8. AlbertoM6

    AlbertoM6 Bit Poster

    Messages:
    11
    Reducing it to 1 CPU only makes sense if you have Xeon processor. If you have i7/i9 won't be a problem.
     
  9. BigGJS

    BigGJS Bit Poster

    Messages:
    21
    What do you mean by, won't be a problem? I have and i9 and 16 CPUs and 64GB. I've reduced Parallels Windows 10 to 4 CPUs and 8GB, no perceptible difference in performance from 8CPUs and 16GB but the fan is still on as I type this. Nothing else other than background tasks and Firefox are running on the Mac.
     
  10. AlbertoM6

    AlbertoM6 Bit Poster

    Messages:
    11
    I mean that reducing to 1 CPU is not going to solve the issue described in this thread unless you have a Xeon CPU, it was bug time a go and it was fixed, I reckon. I feel your pain regarding your fans kicking off like crazy, my solution for that matter has been disabling Turbo Boost in Big Sur and now in Monterey enabling Low Power mode. Helps a lot and in my case with 4 CPUs assigned to the VM when I utilise Mac's dGPU I can live with it. It was very challenging before being in Teams meetings (I am force to use a VM for my work).
     
  11. BigGJS

    BigGJS Bit Poster

    Messages:
    21
    Yes, I use a VM too for work so its annoying to listen to the fan all day when you know the machine you are running is more than capable. I have it suspended to so there is loads of air flow. I'll try your tips thanks.
     
  12. TzvikaB

    TzvikaB Bit Poster

    Messages:
    2
    same problem with parallel 17.

    and i do not get a respond from the tech - they send me to read the article.
    i do not have nothing installed on the windows else office.
    could something help me ?
     
  13. NickK7

    NickK7 Bit Poster

    Messages:
    6
    For anyone with Cisco AnyConnect 4.9.x installed on their Mac, please follow the recommendations in this thread: https://apple.stackexchange.com/a/420913

    I suspect the AnyConnect Socket Filter (com.cisco.anyconnect.macos.acsockext) was running at 100% CPU by monitoring traffic in/out of my Parallels VM, along with any network adapter on the Mac, even though the AnyConnect application was not in use. This caused kernel_task to kick-in, throttling the machine until the process which is a resource hog (in this case both the Cisco process and the Parallels VM process) settles down. I can confidently say my 2019 16" i9 5500M 8GB 64GB machine is no longer throttling itself (using Hot to determine CPU Speed Limit aka Thermal Throttling https://github.com/macmade/Hot/releases) with low power mode disabled on monterey 12.1 when attached to 2 external 1080p monitors using Parallels.

    Hopefully this helps someone out after fighting the issue for 2 years :)
     

Share This Page