Stop auto starting parallels VM

Discussion in 'Windows Guest OS Discussion' started by Lee4, Jun 6, 2019.

  1. Lee4

    Lee4 Bit Poster

    Messages:
    39
    Hi, if I click on something in OSX, I never want a Windows VM to be launched to run it. How do I disable this completely?

    thx
     
  2. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,843
    Please go to VM configuration -> choose Option -> Startup and shut down -> and choose "never" at the "Start automatically" option.
     
  3. Lee4

    Lee4 Bit Poster

    Messages:
    39
    Hi, makes no difference for me. If I click on an mp4 on my mac, it keeps launching a Win10 VM to launch media player.
     
  4. Lee4

    Lee4 Bit Poster

    Messages:
    39
    upload_2019-9-2_23-28-33.png
    I would also expect the "start up and shut down manually" to also never automatically start a VM.
     
  5. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,843
  6. GbengaS

    GbengaS Bit Poster

    Messages:
    1
    Was this ever resolved? I am plagued with the same issue, no matter what setting i chose it auto starts my windows VM on bootup. Currently using Parallels 16 and OSX Big Sur
     
  7. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,843
    Hello, did you try to reinstall Parallels Tools and check the issue?
     
  8. ParallelsU635

    ParallelsU635 Bit Poster

    Messages:
    2
    For anyone who came here via Google, the behavior Lee4 is describing has nothing to do with VM auto start settings. It's caused by app sharing. Open the VM settings, and click on "Applications" in the side pane. The top setting on that panel is "Share Windows applications with Mac". For some utterly inexplicable reason, turning this on makes *every file on mac that can possibly be opened in Windows default to being opened in Windows* and that automatically launches the VM whether you have auto start turned off or not.

    I mean good gosh, who thought that would be a good idea? The setting literally overwrites all your default app associations and replaces them with Windows equivalents. On a mac. We're talking *mp4* files for example. Sadly, running the Windows VM in coherence mode requires that setting to be on. But I don't understand why you can't "share" Windows apps with OS X *without* automatically making those Windows apps the *default* choice for file associations. Parallels: please stop.
     
    DanT15 likes this.
  9. DanT15

    DanT15

    Messages:
    1
    I'm happy that I'm not the only Mac user who was experiencing this (misery loves company, eh?), and was very happy to see this post, as I began to believe there was a remedy at hand. But alas, I'm not even allowed to change the settings. Even when I click on the padlock, and enter my password, everything is still grayed-out.
    So, I do what I'm told - resume the virtual machine, and shut it down. I start it up again, and I get back to this, infinite-loop style.

    Still, I appreciate your post, and the effort you made to determine the root cause. I just have to accept that the VM will always start when I boot up.

    Screen Shot 2021-04-28 at 5.41.57 PM.png
     

    Attached Files:

Share This Page