The Final Version of Parallels Desktop for Mac is Now Available!

Discussion in 'Announcements' started by Ben @ Parallels, Jun 15, 2006.

  1. japanime

    japanime Junior Member

    Thanks for the reply. That's what I expected, and it's entirely fair.

    Great product. Thanks again!
  2. Micheal

    Micheal Bit poster

    Can you please advise on USB issues.

    I purchased a license a while a ago to support your efforts and I have been anticipating this release. I have a mac book pro and anxiously await the time that I can run my windows apps (if only I could get mac versions of these) on my mac. Over the time I have spent lots of $$$ on trying to acheive this goal. Please do not misunderstand me, I am very appreciative of the efforts going into this and I would pay 10 times the amount for the functions that I need to use every day and keep up the good work.

    My main problem is USB. I use a Keyspan 4 port usb device for serial comms. I also use a p&e usb mulilink controller for programming embedded microcomputers. I have been trying to get these to work but with the serial device I am told to wait 5-10 seconds and try again and that I am plugging a High speed device into a low speed hub.

    Is there a possiblity of getting an answer on if there will be solutions to these USB problems in the short term. If not then I would rather know now so that I can persue another other options in the meantime.

    As far as running windows on a mac I have never used a PC that this is fast. I may not have experienced a real fast PC but it is very impressive none the less.

    Thankyou again

  3. Andrew @ Parallels

    Andrew @ Parallels Parallels Team


    From your description it seems that some app in Mac OS X is holding your USB device exclusevly and VM can't take over. Try to find what app is holding your device and try to release it or close this app.

    PS: I expirienced such problem with iPod. To pass it into VM I was forced to detach it from iTunes.
  4. Micheal

    Micheal Bit poster

    Re USB problems


    I uninstalled the Keypsan usb driver from my mac. This is the only way to disable it as it automatically makes the 4 serial ports available to the OS. I installed the correct driver in my windows XP and I get the notifications of loading and unloading but it does not work and the device is not powered.

    Is there a way of getting access to the serial ports on the mac by adding COM1 to one of them - this would be an acceptable workaround.
  5. pheily

    pheily Bit poster

    Is "Parallels Desktop for Mac" the new name for "Parallels Workstation 2.1 for Mac OS X"
  6. joem

    joem Forum Maven

    It is my sincere hope that making USB 2.0 pass through work will be something you consider "minor". :)

    If CD/DVD full pass through so guest based burning software could be used could be "minor" and happen fairly soon, that would be a good thing too.

    Of course, with unrestricted USB working, an external DVD burner could be used, solving the problem.

    And I hope multiple NICs and more than two USB devices at a time are on your near term roadmap.

    These are all things I would have asked for in the initial design if I had been asked, but of course at the time the design was happening, neither of us knew the other existed so that would have been difficult.

    That said, I want to thank the Parallels team for the rapid responses to the beta problems, and the no doubt many sleepless nights getting the product to where it is now. It's a good product with what appears to be a bright future.
  7. rcomeau

    rcomeau Member

    After little to no success with the betas, I have managed to get my single-port Keyspan adapter (USA-19HS) to work somewhat with the GA release. I think I still have to remove the driver from the Mac side, and I can do that using the kextunload command. There is a problem still in that the software on the client side (in this case GPS software) can only talk to the GPS once, then I have to unplug/plug the adapter to get it to work again. This might be a driver problem with Keyspan or a problem with the GPS software somehow leaving the port in a bad state, so I am not ready to blame Parallels yet :).

    I suggest you try the following:

    1: Make sure that on the WIndows side, you have loaded the correct driver for the Keyspan adapter. There are separate Windows drivers (and corresponding installers) for each device, in contrast tothe Mac which has one unified installer for all of them.

    2: Before launching Parallels (or at least connecting to the USB device in Parallels), plug in the adapter, open a terminal window and type:
    "sudo kextunload /System/Library/Extensions/KeyspanUSAdriver.kext"
    This will unload the driver on the Mac side to ensure that it does not compete for the device.

    3: In Parallels, connect to the USB device. You should hopefuly hear the USB-conect chime in WIndows. I often hear the connect chime, then the disconect chime, then the conncet one again. The key thing is that the last chime is a connect chime.

    4: Launch the Keyspan serial assistant and see if the device shows up in the list, and that it consistently shows a COM port. In the betas, it would constantly cycle between seeing the device and not.

    5L If it shows up in the list constantly, then try to use your software that needs to talk to the serial device. In my experience, this only works once, so if you get an error, try unplugging-plugging the device and connecting to it (if you have auto-connect disabled).

    6: When you are done with Parallels, unplug the Keyspan and type (in a terminal window)
    "sudo kextunload /System/Library/Extensions/KeyspanUSAdriver.kext"
    to reload the driver on the Mac side and make the adapter available again when you plug it in.

    I hope this helps. I think Parallels has a some way to go in the USB support department before I call it stable or what I would expect in a GA, but they have made enough progress to keep me from switching to boot camp and call myself a relatively happy user.

    Please keep the progress coming Parallels!


  8. Micheal

    Micheal Bit poster

    Thankyou for your comments. I will attempt these in the morning and comment.
  9. kirdes

    kirdes Bit poster

    No permanent key


    I have pre-orderd PARALLELS DESKTOP FOR MAC on 02.05.2006, but i have no permanent key received till yet and on my mail to has no one answered. can you help me?
  10. Roaster

    Roaster Member

    Congratulations for your new product, unless I do not need the Mac version ;)

    And now, please head over to include Vista support into the Windows version (and of course Mac, too) I need it very urgent now for programming tasks - thanks!
  11. unithom

    unithom Bit poster

    Michael, I have created a related thread here. It asks about sharing ports on the 4-port KeySpan adapter between OSes (say, 3 on the Mac and one for the PC?). I wondered if the SerialClient application would help us at all but when I tried it, it kills the connection between the other ports and the Mac stuff that's using them as well. I mentioned that in this thread.

    Hopefully we will get our USB to Serial stuff figured out! Personally I was just really happy last night when I followed the instructions here and got my Vt-x running properly on my core duo Mac mini!
  12. Fred Brinkman

    Fred Brinkman Bit poster

  13. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

    Fred Brinkman,

    Could you describe what is your problem please?
  14. seven

    seven Bit poster

    I was about to order it now (July 15th), but the order pages (checkout page) already charges $79.99.

    How can I order it at the sale price?
    It is still July 15th....
  15. virbing

    virbing Bit poster

    Early price increase?

    I am in the same boat. I realized that Parallels runs on Eastern time and tried to get in about 8:45 pm Pacific time. Went to the website - on the home page, the price still says $49.99. Go to the order page and the price in the basket is $79.99. I sent an email to sales and hope that they will honor the price to midnight July 15, EDT.

    The part that really sucks is that this is the second copy that I was planning to buy. The first time, I missed the beta pricing because I logged in the morning that the final release version shipped. After using the intelMac Mini with Parallels, I decided to go out and buy a MacBook as well. For the last couple of days, I have been using the demo version and have been trying to get Parallels to get an Activesync partnership reliably with my Cingular 8125. Part of the reason that I ended up leaving the purchase to the last minute was that I have been spending all day loading BootCamp and WinXP so that I can upgrade the 8125 to the newest firmware so that I could try to use Parallels for the ActiveSync. Running out of time, I went ahead to order the software, only to find that they had already raised the price on the order page.

    Hopefully, Parallels will be kind to both of us and offer us the introductory price. I am an individual and cannot afford to throw away money.
  16. virbing

    virbing Bit poster

    I am happy to say that my email seemed to have worked. I got an email back from Parallels allowing me to purchase the software at the promotional price. The only drawback is that the order processing does not seem to work with Safari. I ended up loading WinXP in Parallels and making the purchase through MIE in WinXP

Share This Page