Ubuntu 14.04: No Gui after Login

Discussion in 'Linux Guest OS Discussion' started by Andre Geisler, Apr 9, 2014.

  1. henry.sia

    henry.sia

    Messages:
    1
    Can you elaborate #1 (remove parallel's tool) and #2 (install parallel's tool) from the terminal?

    I did "sudo /usr/lib/parallels-tools/install -r" (http://kb.parallels.com/en/117044) for #1 and now I'm having trouble with #2. Please help.
     
  2. Gerry265

    Gerry265

    Messages:
    1
    This worked for me - I had a similar story

    Thanks for this post - very helpful.
    I installed Ubuntu 13-04 from the Parallels 9 default menu for new Virtual Machines.
    It ran ok (problems with WMV files playing) but I wondered where it got the .iso since it wasn't on my machine.
    It didn't tell me if it went to Ubuntu's site or if it was on the Parallels site…

    Anyway, I did updates this morning and lost the desktop.
    I gave up and made a new VM with Ubuntu14-04 but I couldn't get the menu bar on the left side of the screen and other GUI problems.
    Renaming Xorg.conf.06302014 (today's date) didn't help, but killing off the contents of .config and rebooting did the trick.

    I tried these steps on my 13-04 VM but it didn't work.
    Luckily I did a back prior to the updates, but now that I have 14-04 I think I'll continue on from there.




     
  3. Ram@Parallels

    Ram@Parallels Parallels Support

    Messages:
    763
    Hi All,

    Please follow the steps as suggested at http://kb.parallels.com/111603 and update Parallels Desktop 9 to the latest build.

    Parallels Desktop 9 for Mac (Latest build 9.0.24237) addresses overall stability and performance issues, please open the below link for Updates Summary.

    http://kb.parallels.com/117225
     
  4. dehrlich

    dehrlich

    Messages:
    1
    I don't have an xorg.conf.<date> file in X11 or anywhere else apparently. I only get wallpaper when I start up my VM. Any suggestions on what to do?
     
  5. PatrickBM

    PatrickBM

    Messages:
    4
    I'm having the same problem as the OP, but with Parallels 10. I'm running OS 10.10 public beta 3, Ubuntu 14.04, and Parallels 10.0.2. I cannot consistently log in to Ubuntu in console mode. Most of the time the "ubuntu login: " prompt does show up. However, it rarely allows any keyboard input and will usually, after about 10 seconds, switch to the typical GUI user login screen. Once logging in there, the menu bar shows up, but the entire desktop is blacked out.

    Is there any public bug-tracking system so that users may see the fix status?
     
  6. TomaszN1

    TomaszN1 Bit Poster

    Messages:
    1
    I ran into the same problem as OP after upgrading Parallels Desktop 10 to version 11 on OS X (El Capitan).

    Reinstalling Parallels Tools did not fix the problem. Strangely, I also did not have the file xorg.conf or xorg.conf.<date> in the folder /etc/X11. Also different was that I already had Ubuntu 10.04 running and did not upgrade Ubuntu.

    Based on information in this thread and on http://kb.parallels.com/en/121300, I managed to fix the problem by doing the following:
    1. Open a console via CTRL-ALT-FN-2 and login
    2. Go to folder /etc/X11: cd /etc/X11
    3. Create the file xorg.conf: sudo vi xorg.conf
    4. Paste the content as in PierreM's post (#19) above into xorg.conf
    5. Move xorg.conf to folder/usr/share/X11/xorg.conf.d/: sudo mv /etc/X11/xorg.conf /usr/share/X11/xorg.conf.d/xorg.conf
    6. Set display: export DISPLAY=:0
    7. Run: gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins
    8. Press CTRL-ALT-FN-7
    This made the desktop reappear after logging in in Ubuntu.

    I actually created xorg.conf first in my home folder on OS X and then copied the file in the console to the correct location. Your home folder can be found in the console in the folder /media/psf/Home/.
     

Share This Page