Ubuntu 14.04: No Gui after Login

Discussion in 'Linux Guest OS Discussion' started by Andre Geisler, Apr 9, 2014.

  1. Andre Geisler

    Andre Geisler Bit Poster

    Messages:
    16
    Hello,

    I just upgraded my Ubuntu 13.10 VM to Ubuntu 14.04.
    After login, I cannot see any graphical elements (see screenshot).

    Ubuntu14.04.png

    I am using Build 9.0.24229 of Parallels Desktop on Mac Os X 10.9.2.
    I already installed the VM Tools (Kernel Modules) and removed "~/.config/dconf/user but
    it did not help at all.
    Do you have any idea what is going wrong?

    regards
    eliot
     
  2. Gaetan

    Gaetan

    Messages:
    9
    Hi Eliot,

    Don't forget 14.04 Ubuntu is still no official release yet?!
    And then Parallels have to adapt their Parallels Tools again, taking some time as well!
    Guess your ol' Compiz is acting up (again)....

    I read the official release for 14.04 would be somewhere around April 17th....

    Rgrds,

    Ed
     
  3. bbranch10

    bbranch10

    Messages:
    1
    I did just get this working. I removed everything in ~/.compiz AND everything in ~/.config (by logging in via the console, accessed by CTRL-ALT-FN-1) then I rebooted. Then when I logged in everything was back to normal.
     
  4. AndriusJ

    AndriusJ

    Messages:
    1
    Didn't work for me with the same Build and OS X version. Although there is no ~/.compiz dir in my user home.

    For me what solved was rename file /etc/X11/xorg.conf.18042014 to what it should be /etc/X11/xorg.conf
     
    Last edited: Apr 17, 2014
  5. LinuxDudester

    LinuxDudester

    Messages:
    2
    I've tried all the suggested workarounds and none of them work from me! Parallels has to do something about this issue!! This is obviously related to the Parallels Tools...When the tools are not installed Ubuntu 14.04 works like a charm, as soon as I install them I have no GUI!
     
    Last edited: Apr 18, 2014
  6. Thomas Hartwig

    Thomas Hartwig Bit Poster

    Messages:
    24
    Did you try to run ccsm? This is the compiz configurator. install it if not available. Change to a text console CTRL-ALT-F2 and login. Set the DISPLAY to :0.0 and run ccsm.
    Check if "Ubuntu Unity Plugin" is enabled in the Desktop section.
     
  7. LinuxDudester

    LinuxDudester

    Messages:
    2
    Thanks for your help, but it's still not working. I am at my wits end here. All I have is a parallels folder on the desktop. No work around seems to work..wtf..
     
    Last edited: Apr 18, 2014
  8. Thomas Hartwig

    Thomas Hartwig Bit Poster

    Messages:
    24
    When you are in a console you can kill the X session via: sudo killall Xorg
    This will logout you and you can choose a different window manager for your X session. I have a lot of glitches with unity still, so I use xfce.
     
  9. James Rome

    James Rome Kilo Poster

    Messages:
    107
    This formula worked for renaming Xorg.conf, insyalling ccsm, deleting ~/.config contents, and running ccsm
     
  10. EricS

    EricS Bit Poster

    Messages:
    10
    I've had no luck with any of these suggestions. The Parallels Tools installer runs successfully, but all I get on the desktop when I log in (with the default GNOME/Unity) is the Parallels Shared Folders link.

    I see these errors in the Xorg.0.log:

    Code:
    [     6.173] (II) PRL-GLX: Compiled for 1.15.0 XServer
    [     6.173] (WW) PRL-GLX: Can't load PrlCtlCreateGLXDrawable function: /usr/bin/X: undefined symbol: PrlCtlCreateGLXDrawable
    [     6.173] (EE) PRL-GLX: Can't load needed external symbols!
    [     6.173] (EE) PRL-GLX: Can't initialize GLX screen
    [     6.173] (EE) PRL-GLX: Can't register GLX extension
    
    It appears that the GLX module from the tools installation isn't built right, but I'm not sure how to go about fixing it. Hopefully this helps someone else.

    I haven't tried other desktop sessions, but Unity worked great with 13.10 so I was trying to get that working.

    Thanks in advance!
     
  11. Thomas Hartwig

    Thomas Hartwig Bit Poster

    Messages:
    24
    I posted in an other thread a xorg.conf recommendation. Check this if 3D is supported then. Also did you enable 3D support in the Parallels engine setup.
     
  12. MarkRoberts

    MarkRoberts

    Messages:
    1
    I did a clean install and had exact same problem on a 2011 iMac 27" and a 2013 13" MacBook Pro The xorg.conf was the problem. Copied to to xorg.conf and restarted. Came up good on both machines.

    Follow up: On the laptop I forgot to mention I also had to delete everything in ~/.config after copying xorg.conf file. As soon as I did that the desktop was restored.

    So:
    cd /etc/X11
    sudo cp ./xorg.conf.04172014 ./xorg.conf
    sudo reboot
    cd ~/.config
    rm -Rf *

    Desktop will reload and work correctly. I've rebooted a few times and it seems to be working. On the laptop I did have to do the remove of everything in .config twice so there is still something a little messed up there I think.
     
    Last edited: Apr 18, 2014
  13. DodgeV

    DodgeV

    Messages:
    1
    Perfect, this worked for me, thanks!

    cd /etc/X11
    sudo cp ./xorg.conf.04172014 ./xorg.conf
    sudo reboot
     
  14. DaleRo

    DaleRo

    Messages:
    2
    I am in the same boat. Any idea how long before Parallels addresses?
     
  15. FadhelA

    FadhelA

    Messages:
    1

    I try this but still I don't get GUI after login, I just upgrade yesterday from 12.04 to 14.04 I am getting only my wallpaper.

    Any other fix for this issue?
     
    Last edited: Apr 19, 2014
  16. DaleRo

    DaleRo

    Messages:
    2
    Hi,

    I had good luck installing clean entirely, I was trying to upgrade from 13.04.

    I installed 14.04 in a new Virtual Machine,
    This was a manual install, I like to configure the memory to 4 Gigs instead of the default 1 Gig of RAM.
    Then going to /etc/X11 and copying the xconf file from xconf.date to xconf as mentioned in other threads.

    Then I went into Parallels -> Install Parallels Tools (Not a reinstall, I installed each time)
    I did the ctl alt fn f1 to get a terminal.
    Then I moved to the /media/[userid]/Parallel Tools directory
    Did the ./install (after sudo to su).
    This was where the Good Completion was different from the earlier tries, there were a lot of log outputs from the terminal, on the tries that failed, the update just completed but no output.
    Then I did the rm -rf ~/.config and rm -rf ~/.compiz as mentioned in other threads. (As the user)
    Finally sudo su and
    Reboot

    One other post mentioned they had to do this more than one time. That is what my experience was. I had to repeat the effort several times. The fourth or fifth time, I don't know why, the menu bar and dock returned.
     
  17. PierreM

    PierreM

    Messages:
    2
    I have make a test with an upgrade process from 13.10 to 14.04 LTS on my VM. The GUI came back only on this way:
    1) remove Parallel's tool and reboot
    2) install Parallel's tool and reboot
    3) copy /etc/X11/xorg.conf.<Date> to /etc/X11/xorg.conf
    4) for each users, remove every file and directory concerning session:
    # sudo rm -Rf .Xauthority .ICEauthority .gconf .parallels .gtk-bookmarks .cache .config

    After that, everything is Ok. :)
     
  18. lightningmonkey

    lightningmonkey

    Messages:
    1
    I also tried deleting .config to no success. I currently do not have any xorg.conf with or without a date in my folder. An official parallels patch for this would be greatly appreciated.
     
  19. PierreM

    PierreM

    Messages:
    2
    Here, that's my /etc/X11/xorg.conf:
    Code:
    #
    # X.Org server configuration file generated by Parallels Guest Tools.
    #
    
    # Parallels Video section
    Section "Device"
    	Identifier	"Parallels Video"
    	Driver	"prlvideo"
    EndSection
    
    # Parallels Monitor section
    Section "Monitor"
    	Identifier	"Parallels Monitor"
    	VendorName	"Parallels Inc."
    	ModelName	"Parallels Monitor"
    EndSection
    
    # Parallels Screen section
    Section "Screen"
    	Identifier	"Parallels Screen"
    	Device	"Parallels Video"
    	Monitor	"Parallels Monitor"
    	Option	"NoMTRR"
    	SubSection	"Display"
    		Depth	24
    		Modes	"1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    
    # DefaultFlags section
    Section "ServerFlags"
    	Option	"AllowEmptyInput"	"yes"
    	Option	"AutoAddDevices"	"yes"
    EndSection
    
    # DefaultLayout section
    Section "ServerLayout"
    	Identifier	"DefaultLayout"
    	Screen	"Parallels Screen"
    EndSection
    
    Try to paste it with a "sudo vi /etc/X11/xorg.conf" in a terminal.
     
  20. inlikealion

    inlikealion

    Messages:
    2
    This worked for me. Parallels needs to release a patch, though.
     

Share This Page