Ubuntu 19.04 can't install Parallels tools

Discussion in 'Linux Guest OS Discussion' started by Parkd2, Apr 18, 2019.

  1. Parkd2

    Parkd2 Bit Poster

    Messages:
    1
    /var/log/paralles-tools-install.log
    .../prl_fs/super.c:
    120:21: error : 'MS_MANDLOCK' undeclared ( first use in this function); did you means 'IS_MANDLOCK'? (( *flags) & MS_MANDLOCK))
    123:12: MS_SYNCHRONOUS <-- SB_SYNCHRONUS ?
    277:17 : MS_NOATIME <-- S_NOATIME

    How can i fix it ?
     
    Last edited: Apr 18, 2019
  2. JulsS

    JulsS Bit Poster

    Messages:
    35
    It does not work for me either. Parallels 14.1.3 fails when installing tools into Ubuntu 19.04.
    julius
     
  3. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    123
    Look at the kernel 5.0.3 thread.
     
    (GalaxyMaster) and JeremyM5 like this.
  4. F.A.

    F.A. Bit Poster

    Messages:
    2
    I'm currently running the Parallels Desktop for Mac Home Edition Version 13.3.2 (43368) and I can't install the Parallels Tools either. I even can't change the Display Resolution. Will the issue also be fixed in this Version?
     
  5. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    123
    Think you need Version 14.x.x, and even then, Tools needs to be slightly modified to work with the new kernel since they don't support Kernels above 4.x.x yet.
     
  6. F.A.

    F.A. Bit Poster

    Messages:
    2
    So Ubuntu 19.04 won't work with Parallels Desktop for Mac HE 13.x.x ? That means I have to Upgrade first to Version 14.x.x ?
     
  7. DanielB28

    DanielB28

    Messages:
    1
    I run parallels desktop 14.1.3 and i cannot install Ubuntu 19,04 I think that Parallels don't really follow Ubuntu to make necessary update, it's probably not a priority for them.
     
  8. Mykhailo Yurevich Shtanko

    Mykhailo Yurevich Shtanko Bit Poster

    Messages:
    1
    The same thing. I send log to support, they said that they working on update, but can't say when it will be available.
     
  9. BryanK2

    BryanK2 Bit Poster

    Messages:
    2
    Would like an update on this
     
  10. Niklas3

    Niklas3 Bit Poster

    Messages:
    1
    I'm on the trail and need 19.04 to work, so I have to go with vmware fusion instead. (Would have loved to use parallels instead)
     
  11. MichalK2

    MichalK2

    Messages:
    1
    Hello, I can confirm the problem with installation of Parallels Tools in Ubuntu 19.04. The error is the same as "Parkd2" said. Please solve the issue ASAP. Ubuntu 19.04 is almost 1 month available and no fix from Parallels's side until now. I created support ticket of the problem. Let's see what Parallels developers do with it.
     
  12. JesusG2

    JesusG2 Bit Poster

    Messages:
    1
    It's likely that Parallels won't fix this in the current release. Their only way to get continued revenue from customers is to delay critical updates like this to the next version of parallels, which will only be compatible w/ the next version of MacOS.

    This will likely be the last version of Parallels that I will purchase. I've been a loyal customer since 2008, but their customer support is seriously lacking.

    Anyone else wonder why it is that every version of parallels magically gets 30-50% faster (per their advertisements)?

    Once apple switches over to ARM, it will be interesting to see how Parallels brings value to its customers.
     
    pechar likes this.
  13. PhilippeW2

    PhilippeW2 Bit Poster

    Messages:
    1
    Well Parallels should really look at solving the issue. They should remember:
    - some customers are on their subscription-based model and could end it at any time
    - being compatible with the last Ubuntu version is not "a minor concern" for many of us developers
    If ever not solved with a week or so, will just HAVE to move to VMWare.
     
  14. chienpo

    chienpo Bit Poster

    Messages:
    6
    Also, just be be clear, the issue isn't just with the latest release of Ubuntu (19.04) but the latest version of older releases too (my VMs are still running 16.04 but w/the latest dist-upgraded kernel version for that release which has similarly broken Parallels Tools).
     
  15. MagnusN1

    MagnusN1 Bit Poster

    Messages:
    1
    Roderickd and shevek like this.
  16. Roderickd

    Roderickd

    Messages:
    1
  17. DiegoG3

    DiegoG3 Bit Poster

    Messages:
    1
    Seriously Parallels!?! TWO MONTHS and you haven't fixed this YET ?
     
    JulsS likes this.
  18. ChrisJ18

    ChrisJ18

    Messages:
    1
    C'mon Parallels. Let's get this working. Ubuntu 19.04 works fine with VMware Fusion. For a subscription product, I expect that you'd support new operating system versions more quickly.
     
    ShawnC4 likes this.
  19. ParaKitty

    ParaKitty Bit Poster

    Messages:
    20
    Follow the money. The number of users wanting to install Windows or macOS as a guest, vs users wanting to install Linux as a guest, vs users wanting to install BSD as a guest. They are prioritizing. Except they forget that MANY of us do ALL of those as guests, and we get just as pissed-off as those that only use BSD (for example). So while they are ATTEMPTING to follow the money, they aren't very smart about it.
     
  20. MabryD

    MabryD Bit Poster

    Messages:
    3
    I'm also waiting on support for Ubuntu 19.04. It's been out for a while now.

    Is there any hint in when this may be addressed?
     

Share This Page