ubuntu 22.04 for ARM64 stuck at "EFI_STUB: on Parallels Desktop 18 for Mac M1

Discussion in 'Linux Virtual Machine' started by ChangL2, Mar 3, 2023.

  1. ChangL2

    ChangL2 Bit poster

    I install ubuntu 22.04 for ARM64 on Parallels Desktop 18 for Mac M1, it work pretty well for months, but recently i install a update of parallel tools autmatically pushed then the ubuntu end up with stucking at the booting and the information prints on screen as follows:

    EFI stub: Booting Linux Kernel...
    EFI stub: EFI_RNG_PROTOCOL unavailable
    EFI stub: Using DTB from configuration table
    EFI stub: Exiting boot services...

    What does it means and what i can do to recover my system from the error above?

    PS: this annoying problem takes place at least three times on my Parallels, i tried anything could found on internet and end up with reinstalling ubuntu.
  2. Greg14

    Greg14 Bit poster

    I'm getting the same error after upgrading Parallels. Worse: Ubuntu 22.04 now will not let me login. Trying my password prompts the error: "Sorry, password authentication didn't work." This is true despite the fact that certain applications are loading, using that same username/password combination, and are accessible after booting without me logging in.
  3. SergeM2

    SergeM2 Bit poster

    Had the same issue just now on Parallels Desktop 18 for Mac M1 version 18.3.2 (53621)
    after a parallels tools update failed to boot into anything even the recovery options didn't work... Forced to re-install. Not great!
  4. Krisstoff

    Krisstoff Bit poster

    Parallels Desktop 18.3.2
    Same problem when installing Ubuntu Server 23-10 ARM
    Unable to boot.
    Is there a solution?
    This problem is very annoying.

Share This Page