Ubuntu guest - No internet connection

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by FelixM, Apr 14, 2021.

  1. FelixM

    FelixM Bit Poster

    Messages:
    4
    i have installed ubuntu 20.10 server and the vm-tools from parralels .

    But Ubuntu told me that no connection is existing . The network symbl is "disconncted" .

    Have someone a workaround for that ?
     
  2. HaraldSt

    HaraldSt Bit Poster

    Messages:
    37
    Odd, it is working for me.
     
    Maria@Parallels likes this.
  3. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,801
    Hello, did you check the same issue with Bridged network mode (or Shared network mode)?
     
  4. Elric

    Elric Parallels Developers

    Messages:
    1,673
    Hi,
    please switch to shared networking. Then start Terminal in Ubuntu and execute "sudo dhclient eth0". If the command helps, then it is some misconfiguration in Ubuntu. Otherwise, post here output of "ifconfig -a" from Ubuntu side. And also send a problem report (menu Parallels Desktop -> Help -> Send Technical data) and post here its number
     
  5. FelixM

    FelixM Bit Poster

    Messages:
    4
    Hi ,

    here is the number :
    366962695

    I have installed ubuntu from iso file withh budgie desktop .

    Wahat is curios is that Firefox can open sites but evolution mail said it is offline.


    Output :
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 10.211.55.14 netmask 255.255.255.0 broadcast 10.211.55.255
    inet6 fdb2:2c26:f4e4:0:21c:42ff:fe10:78b7 prefixlen 64 scopeid 0x0<global>
    inet6 fe80::21c:42ff:fe10:78b7 prefixlen 64 scopeid 0x20<link>
    ether 00:1c:42:10:78:b7 txqueuelen 1000 (Ethernet)
    RX packets 76 bytes 8601 (8.6 KB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 81 bytes 10156 (10.1 KB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
    inet 127.0.0.1 netmask 255.0.0.0
    inet6 ::1 prefixlen 128 scopeid 0x10<host>
    loop txqueuelen 1000 (Local Loopback)
    RX packets 120 bytes 10002 (10.0 KB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 120 bytes 10002 (10.0 KB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
     

    Attached Files:

  6. KevinB21

    KevinB21 Bit Poster

    Messages:
    16
    I had been having this problem on Ubuntu Server as well. I just kept running "sudo dhclient" to get it working and ignored it in the preview because I had similar issues in Windows. But now with the final release, Windows was working but ubuntu still was not. I looked at my netplan config and it had an entry for enp0s2 but not eth0. I changed enp0s2 to eth0 and now it gets an address automatically without issue.
     
  7. FelixM

    FelixM Bit Poster

    Messages:
    4
    In the menu in the above right corner i see "Wired unmanged " .

    With your command also no success .

    Firefox is working fine . But when i try to download a new language etc.. i get the error : Please connect Ubuntu to the internet .
     
  8. FelixM

    FelixM Bit Poster

    Messages:
    4
    So i have tested now the Dembia 10.9 build . Here it is working now .

    But Ubuntu 20.04/20.10 have problems explained above
     

Share This Page