Unable to increase memory (RAM) to VM

Discussion in 'Installation and Configuration' started by NickL6, Jan 9, 2018.

Tags:
  1. NickL6

    NickL6 Bit Poster

    Messages:
    1
    I've gone through multiple posts and articles showing how to increase your RAM through Configure->Hardware when the VM is not running but I'm still unable to change the current amount allocated. I recently downloaded Parallels desktop 13 for Mac and have a new iMac purchased in the last year with 16 GB of RAM but I'm unable to allocate more than 2 GB. I get the same error message others have mentioned: "to be able to change the settings, resume the virtual machine and then shut it down." It doesn't matter whether the VM is running or not, still can't change the memory or hard disk settings. Any suggestions or advice is much appreciated!
     
  2. TristaJ

    TristaJ Bit Poster

    Messages:
    22
    did you ever figure this out? I have same question
     
  3. Sathiya@Parallels

    Sathiya@Parallels Staff Member

    Messages:
    448
    Start the virtual machine and shut it down by selecting Actions (from Mac menu bar) -> Shut down. Then open virtual machine's configuration window, navigate to Hardware -> CPU and Memory -> allocate the memory as required. If you are still unable to change the memory for the virtual machine, try reinstalling Parallels Desktop which should resolve the issue if there is any misconfiguration.
     
  4. RolandH1

    RolandH1 Bit Poster

    Messages:
    14
    There is NO Actions from Mac menu bar! Not under the Parallels icon mate! Terrible advice. I cannot fathom how one shuts down a virtual machine because then i lose the parallels icon.
     
  5. RolandH1

    RolandH1 Bit Poster

    Messages:
    14
    So where is this Actions?
     

    Attached Files:

  6. Sathiya@Parallels

    Sathiya@Parallels Staff Member

    Messages:
    448
    From the screenshot, I see that the virtual machine is already shut down. Hence, select 'Control center' from the menu, select the 'Cog wheel' icon from the control center to open the configuration window, navigate to Hardware -> CPU and Memory -> allocate the memory as required.
     
  7. RolandH1

    RolandH1 Bit Poster

    Messages:
    14
    Many Thanks Sathiya! But it is still "greyed out" as an option. . . (after hitting the cog in windows 10 Control Center box) Further thoughts/suggestions?
     

    Attached Files:

  8. Sathiya@Parallels

    Sathiya@Parallels Staff Member

    Messages:
    448
    Please refer this article and set 'Start Automatically' option to 'Never' and 'On VM shutdown' as 'Keep Window' open. Then select Actions (from the Mac menu bar) -> Shut down to the virtual machine. Now open the configuration window, navigate to Hardware -> CPU and Memory and check whether you are able to change the RAM.
     
  9. RolandH1

    RolandH1 Bit Poster

    Messages:
    14
     
  10. RolandH1

    RolandH1 Bit Poster

    Messages:
    14
    Um WHAT article? Where do i set Start Automatically option to never? Nothing in preferences that i see which matches this . . . why is this so difficult? Doesn't everybody want to maximize one's RAM?? OY vey this is dumb.
     
  11. RolandH1

    RolandH1 Bit Poster

    Messages:
    14
    The cog prefs are greyed out mate!
     

    Attached Files:

  12. Sathiya@Parallels

    Sathiya@Parallels Staff Member

    Messages:
    448
    Once the virtual machine is shut down, it will be easy to edit the configuration settings. Please refer < https://kb.parallels.com/120414 > to change the startup and shutdown options as mentioned above.
     
  13. RolandH1

    RolandH1 Bit Poster

    Messages:
    14
    Horrendously badly designed method. You should immediately redesign with a big ol Memory icon and put it front and center. The process of shutting down virtual machine is labyrinthian - she had to do something in Windows in order to make the option be un-greyed out! For us Mac folk delving into Windows is a bit like one must assume dumpster diving must be like :)
     
  14. Ajith@Parallels

    Ajith@Parallels Parallels Support

    Messages:
    1,708
    The feature you are requesting is not possible in any virtual environment or in a real PC. You are going to change the RAM (Main Memory) of a virtual machine (virtual PC). If Windows is running (using RAM) at the time you are changing the memory, Windows cannot use the memory to keep its operations running and will result in a crash or fatal error from which Windows might not recover. To avoid this you have to shut down the Windows and change/increase the virtual memory/virtual RAM. You can shut down Windows simply using Actions > Shutdown or selecting Windows logo and select the Power button.
     
  15. RolandH1

    RolandH1 Bit Poster

    Messages:
    14
    You are being suggested by a long term client to make the process more clear mate! Don't go on about problems with windows. . . just fix the process eh?
     
  16. Ajith@Parallels

    Ajith@Parallels Parallels Support

    Messages:
    1,708
    Thank you for your feedback. You can share it as a feature request on this thread.
     

Share This Page