Unable to resolve dependency: user requested 'vagrant-vbguest (= 0.15.2)'

Discussion in 'Parallels Provider for Vagrant' started by JustinK3, Oct 11, 2018.

  1. JustinK3

    JustinK3

    Messages:
    1
    Trying to install the vagrant plugin gives this error:
    Unable to resolve dependency: user requested 'vagrant-vbguest (= 0.15.2)'
     
  2. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    543
    Hello JustinK3, Kindly follow the instructions from this link and check if it helps.
     
  3. bbaassssiiee

    bbaassssiiee Bit Poster

    Messages:
    2
    vagrant-vbguest is for VirtualBox, not for parallels. It might be in your Vagrantfile because it is very common. You can work around it by enclosing a conditional:

    if Vagrant.has_plugin?("vagrant-vbguest")
    config.vbguest.auto_update = false
    end
     

Share This Page