Upgrade Trial Installation Stalls at Windows Logo

Discussion in 'Installation and Configuration of Parallels Desktop' started by BillH3, Aug 26, 2023.

  1. BillH3

    BillH3 Junior Member

    I was trying to reinstall Parallels desktop on my old 2014 Macbook running BigSur OS. It was running Parallels 11 but I haven't used or needed Windows through Parallels for a couple years and when I tried to start Parallels it would not start and and got a error message saying missing files or something like that. I followed the instruction on how to fix it but apparently I downloaded a trial version of the latest version of Parallels. When I open Parallels I get a window "Parallels Desktop Trial" and I click Continue Trial and get the Windows logo screen and then it stalls and I have to Force quit. Tried multiple times. Is there a fix? Or maybe the BigSurOS is not compatible? Any way an older version of Parallels would work? I was hoping to get Windows running again because I now have a requirement for a Windows only CAD app and I wanted to try it out. If the app was acceptable I would probably upgrade and transfer Parallels to a newer MacMini I have. Any help would be appreciated.

Share This Page