[Urgent Help] Can't start my Windows XP cause of msvcrt.dll. Need to recover a file

Discussion in 'General Questions' started by JakeMathew, Mar 15, 2014.

  1. JakeMathew

    JakeMathew

    Messages:
    3
    Hi,

    I was trying to install a software and I got an error regarding the Msvcrt.dll file. I tried replacing it with a different Msvcrt.dll file, but now when I restart XP, Windows does not start and keeps crashing (goes to blue screen and again restarts).

    I can view the System 32 folder through my Mac OS Mavericks finder but I can't replace it with the old Msvcrt.dll file as I am only allowed to view the files (Read only access) in Windows folder through Mac.


    My first urgent requirement: I have some very important files under in the AppData folder in Windows that I need to urgently recover. Can I take the files out via Mac? I can't locate "C:\Documents and Settings\<username>\Application Data\" folder through Mac OS. Can someone please help?

    Second, if you can also let me know how I can resolve the Msvcrt.dll issue and allow Windows to start.

    Note: safe mode does not work.
     
    Last edited: Mar 15, 2014
  2. Specimen

    Specimen Product Expert

    Messages:
    3,244
    1. If you can/know to navigate to C:\Windows\System32 in Finder you can do the same for C:\Documents and Settings\<username>\Application Data\ and copy your files from there, you should see a "Documents and Settings" folder like you see a "Windows" folder when you open the disk in OS X and then navigate the same way as you did for System32.

    2. You simply copy the files to a 'safe' place via Mac, like you copy any other file under OS X, the contents of the files will remain intact and unaltered on the OS X side.

    3. Here's an article of the steps you can follow to recover Windows from the dll problem: http://pcsupport.about.com/od/findbyerrormessage/a/msvcrt-dll-not-found-missing-error.htm

    3. However, you likely need to use step 10 of the previous article, as the ones before probably will not work from what you have said. In that case the correct way to solve this problem in Windows is via a Repair Install, this requires a that you have the Windows XP CD (preferably with SP3), if this is a Bootcamp install it also should be done while booting natively, this procedure is almost like installing a fresh copy of Windows except your files, settings and programs will remain intact. This will require that you re-download and reinstall all updates via Windows Update, might require some drivers to to reinstalled, and Parallels Tools also.

    http://pcsupport.about.com/od/operatingsystems/ss/instxprepair1.htm

    4. [Dangerous, proceed with caution] Finally, it's possible to replace the file in Windows by having read and write access to the Windows volume, you can do that by using OSXFUSE (more on that later), but you really have to be sure that you know what you are doing, meaning, that the file you'll be putting there is the one that's right for the system, the correct version of it, that you don't delete or modify any other file inside the Volume.

    Read this first: http://pcsupport.about.com/od/findtheproblem/qt/dll-download.htm

    OS X FUSE: http://osxfuse.github.io/
    NTFS 3G of Mac OS X (this is what will give you read and write access to Windows): https://github.com/osxfuse/osxfuse/wiki/NTFS-3G
     
  3. JakeMathew

    JakeMathew

    Messages:
    3


    Thanks for the quick reply.

    As you seen in the screenshot below, there are no files under Doc & Settings via Finder. At the moment, I am worried about getting a file from the App Data folder. After I have got that, I don't mind reinstalling Parellels or Windows as I need to only extract 1 file from App Data folder. I don't have any other data in my XP that I need and I can happily reinstall it.

    Thanks again!

    1.png 2014-03-16 01.46.05 pm.png 2014-03-16 01.46.21 pm.png 2014-03-16 01.46.52 pm.png
     
  4. Specimen

    Specimen Product Expert

    Messages:
    3,244
    These are actually the type of posts I care more to answer to in these forums, people with REAL problems.

    I'm not sure how I can help you further, if there's no file in docs and sets there isn't much else to be done, it's not there, that folder seems to be empty, this can either mean a problem with the disk, or it's really empty. I can't help you further to locate it, you might try booting a LINUX live cd to look into the Bootcamp partition for your file.

    I can tell you this, since you have a Users folder in Windows that means it's not Windows XP 32 bit, you also have a Program Files (x86) folder, which means it's a 64bit Windows, and although there is such a thing as Windows XP 64bit, it's extremely rare to see actually someone running it. My guess is that you have tried to install Windows Vista/7/8? And now you have a Frankenstein system?

    Isn't the file you are looking for in the Users folder? I see an AppData folder there, above Application Data. And you seem to have navigated there, what's holding you from copying the file you want?

    Finally, I strongly suggest you do the repair install so you'll be able to boot windows and get the file, then you can reinstall Windows from scratch.

    This is all I can do to help you with, good luck.
     
    Last edited: Mar 16, 2014

Share This Page