URGENT: Windows Phone 8 emulator fails to start

Discussion in 'Windows Virtual Machine' started by MichaelBiermann, Nov 1, 2012.

  1. MichaelBiermann

    MichaelBiermann Bit poster

    I run latest Parallels version on Retina Macbook Pro to develop for Windows8/Windows Phone8, Android, HTML5 and iOS.

    Everything works great, BUT the emulator of Windows Phone 8 fails to start.

    The error message is:

    The Windows Phone Emulator wasn't able to create the virtual machine:
    Generic failure

    To overcome other issues, I have already changed memory of virtual machine to 3GB, according to your document http://kb.parallels.com/en/113875.

    This article describes this crazy showstopper issue in details:

    As a workaround, in Germany I will be able to buy a Lumia 920 next monday.
    But I also need to test different screen sizes and resolutions.
    Last edited: Nov 1, 2012
  2. Specimen

    Specimen Product Expert

    The emulator is actually a virtual machine, so we are talking about a vm inside a vm, this requires support for nested Hyper-V, which afaik is planned but not implemented yet although Windows doesn't actually support its Hyper-V being nested, also VMWare Fusion already supports this exprimentally, if you are so desperate, but don't count too much on this feature because, as I said, Windows doesn't support this well.

    The KB you linked talks about Phone Emulator 7, which is actually an emulator and not a virtual machine, Phone 8 Emulator is a virtual machine, complain to MS, it was their decision.
    Last edited: Nov 1, 2012
  3. Koen.H

    Koen.H Bit poster

    It is now available in de latest build of PD8.
  4. LiqingT

    LiqingT Bit poster

    I tried the latest version of PD8, it still didn't work. Can you give some more details?


  5. Specimen

    Specimen Product Expert

    This is kb article is mentioned in other threads (there at least 2 others that refer to the same issue):

Share This Page