VPN sharing to Windows 11 ARM not possible?

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by Patrickv9, Feb 25, 2023.

  1. Patrickv9

    Patrickv9 Bit poster

    Messages:
    3
    Hi everybody,
    I am trying to share an established VPN connection from my Mac M2 to parallels Windows 11 ARM guest.
    An old KB post suggests that this should be working by simply using the shared network option:
    https://kb.parallels.com/123071
    This however does NOT work for me :( Any ideas? I have seen a lot of threads where this is mentioned but found no answer.
    Is it simply not possible? And why is it not possible - maybe in the future?
    Thansk!
     
  2. MikeH27

    MikeH27 Junior Member

    Messages:
    14
    Just load up the VPN client on the Windows VM?
     
  3. Patrickv9

    Patrickv9 Bit poster

    Messages:
    3
    Sure, but parallels is saying it should work by simply using the shared network option. So I would prefer that.
     
  4. Aydaskhan Asochakov

    Aydaskhan Asochakov Staff Member

    Messages:
    177
    Greetings Patrick9,
    To let us better understand the situation, kindly provide us with more information:
    1) Tell us your's VPN name.
    2) Reproduce the issue.
    3) Collect a technical report as per this article: https://kb.parallels.com/en/9058
    4) Provide us with 9-ID of the report report in a reply message (do not forget to attach screenshots of your network settings within macOS)
    We are looking forward to hearing from you.
     
  5. Patrickv9

    Patrickv9 Bit poster

    Messages:
    3
    Hi,
    1.) Palo alto and OpenVPN
    2.) done
    3.) done
    4.) 419851110
     
  6. GedM

    GedM Bit poster

    Messages:
    3
    Hello
    I am also experiencing the same issue

    1) Cisco Checkpoint Endpoint Security
    4) 421033737
     
  7. pvonauf

    pvonauf Bit poster

    Messages:
    1
    Hi,
    I had a support session with the Parallels team which was very helpful. In the end the solution was to install the parallels version from the website not the apple app store. After that all VPN sessions worked fine.
    I hope this helps.
    Cheers,
    Patrick
     
  8. GedM

    GedM Bit poster

    Messages:
    3
    Thanks for the info. This hasn't worked for me. I still cannot access web sites via the VPN from my Windows instance :-(

    I'll raise another ticket with my details
     
  9. GedM

    GedM Bit poster

    Messages:
    3
    It appears to have started working for me now. I locked the Mac Book and came back a few hours later and, hey presto, it was using the VPN from Windows. Not sure what has changed - I've changed no settings.
     
  10. SamK16

    SamK16 Bit poster

    Messages:
    2
    Hello I'm also experiencing similar issues
    OpenVPN
    Tech Report number: 438753683
     
  11. Avinash Bundhoo

    Avinash Bundhoo Staff Member

    Messages:
    458
    Hello,
    Thank you for your feedback.

    Kindly follow the steps below:

    1. On Macos (host), Open Terminal (Applications > Utilities > Terminal) and execute the following command

    sudo tcpdump -i all -w net-host.pcap

    (You will be prompted to input your password)

    2. On the virtual machine (Windows10), Open command prompt as administrator and execute the command below:

    cd c:\

    pktmon start -c --pkt-size 0

    3. Reproduce the issue by establishing the VPN connection on the host.

    4. On Macos, Open Terminal, on the same window on which the command on step 1 was executed, press Ctrl+C to terminate tcpdump to stop recording.

    5. Go to Finder -> "Go" (on the menubar) -> "Home" and locate the file net-host.pcap and upload the resulting file net-host.pcap on a cloud link

    6. On the virtual machine (Windows10), Open the same command prompt window from step 2, and type the following command to stop the recording:

    pktmon stop

    pktmon etl2pcap C:\PktMon.etl --out net-guest.pcap

    7. Open Windows Explorer on the Windows 10 virtual machine, Go to C:\ and upload the file net-guest.pcap on a cloud link

    Once the logs have been collected, please disable the ipv6 DHCP for Shared Network and check if the issue persists:

    1. Shut down the Virtual Machine. Make sure that the virtual machine is shut down. If it is in a suspended state, please run it and then shut down (Actions > Shut Down).

    2. Click on the Parallels Desktop icon in the Mac menu bar -> select "Preferences".

    3. Go to "Network" tab -> select "Shared Network".

    4. Click on ipv6 -> uncheck the "Enable ipv6 DHCP" option.

    5. Shut down your virtual machine and restart Parallels Desktop.

    6. Check if the issue persists.

    Thanks
     
  12. JonK19

    JonK19

    Messages:
    1
    Hi I am having the same issues
    1.) WatchGuard Mobile VPN
    2.) done
    3.) done
    4.) 449377664
     
  13. Avinash Bundhoo

    Avinash Bundhoo Staff Member

    Messages:
    458
    Hello,
    Thank you for the provided data.

    Please uninstall SentinelOne from you Mac and try again.

    Let us know if this helps.

    Thanks
     

Share This Page