VS Studio freezes on Parallels 12 upon awakening from sleep

Discussion in 'Windows Guest OS Discussion' started by Migueld1, Feb 15, 2017.

  1. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    563
    Hi Ian, can you please share some more details about this: "now happens 100% of the time after my VM sleeps."?
    Do you mean that it happens every time you wake up your Mac? Or you put VM to sleep manually?
    Also, can you please generate core dump and send us technical data report once the freeze happens?
    Use there instructions: http://kb.parallels.com/en/121323
    I will send you the upload location in private.
     
  2. MtnViewJohn

    MtnViewJohn Bit Poster

    Messages:
    15
    I just updated to version 12.2.0 (41591) and the problem went away.
     
  3. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @MtnViewJohn, that's good! Please let us know if you have any questions about the product and we are love to help!
     
  4. AnthonyB2

    AnthonyB2 Bit Poster

    Messages:
    23
    This is a different problem to the topic of this thread. So much so it should have had its own thread.
    The topic of this thread - that Visual Studio crashes regularly after a system resumes from sleep - is still very much present on 12.2.0 (41591).
     
  5. Chong

    Chong Bit Poster

    Messages:
    1
    I'm also experiencing the same issue on v12.2.0 (41591). Still happening as of this morning (4/23/2017).
    Windows 10 with Visual Studio Enterprise 2017 v15.1 (26403.7) on host machine Macbook Pro 2015 with 16 gigs.
    This seems to happens when coming out of sleep. Sometimes I can't even kill the process and have to reboot the whole Windows.
     
  6. HannesP

    HannesP Bit Poster

    Messages:
    1
    I have the same problem using VS2015 on window 10, this is driving me nuts. Hope you find a solution soon.
     
  7. IanD5

    IanD5 Bit Poster

    Messages:
    3

    Ironically, I have been suffering with this for months and months, and just the other day there was some windows updates and an Update to Visual Studio 2017 and the issue has now totally disappeared :| I could't tell you which update fixed it - Sorry !!
     
  8. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    563
    Thank you for the update, @IanD5!
    Guys, who have the same issue, please check if there are any Visual Studio updates available as well.
     
  9. RichardP10

    RichardP10 Bit Poster

    Messages:
    17
    Happened to me again yesterday with both Visual Studio 2015. I am getting pretty frustrated there seems to be nothing being done about this issue (but the Windows taking forever to boot issue is much worse). I waste so much time with this program...
     
  10. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    563
    Hi @RichardP10, I am sorry to hear that.. Do you want to help investigate the issue? We would need you to collect a memory dump and send a report. Please let me know, if yes - I will send you the details in private message.
     
  11. RichardP10

    RichardP10 Bit Poster

    Messages:
    17
    Sure, send me what you need.
     
  12. ChenS1

    ChenS1 Bit Poster

    Messages:
    1
    I have encountered the same problem. It's very annoying to me. I'd like to help you guys to investigate this issue. Please let me know what I can do for you.

    Thanks
     
  13. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    563
    Thank you, @RichardP10, @ChenS1.
    Sent you both instructions to collect dumps and with upload locations.
     
  14. JonC3

    JonC3 Bit Poster

    Messages:
    2
    This issue is happening to me as well with VS 2015. Has there been any resolution?
     
  15. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @JonC3, as a workaround, please, check "autopause" state: VM Configuration -> Options -> Applications -> Pause Windows when no applications are open. If it is enabled you may try to disable it.
     
  16. NeilB1

    NeilB1 Bit Poster

    Messages:
    1
    This only seems to happen to me when I unplug my Mac from power, my USB hub (keyboard, mouse etc) and external display. I think it's something to do with display drivers. When the Mac is left plugged-in, it's fine, even with multiple sleeps. Unplugged is when the issue starts occurring.
     
  17. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @NeilB1, please create a Problem Report for the virtual machine as described here and provide us with the Problem Report ID to further investigate the issue.
     
  18. JonC3

    JonC3 Bit Poster

    Messages:
    2
    I could see this being a graphics acceleration issue or something, because if I have chrome open in windows VM, when I wake up the macbook, chrome app doesn't render properly until I do something in the web browser.
     
  19. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @JonC3, try switching between integrated and discrete video cards will resolve the issue.
    To switch between the adapters, go to virtual machine configuration window -> Options -> Optimization - Power
    * For integrated graphics (CPU) set 'Longer battery life'
    * For discrete video card set 'Better performance'
    You can also choose "No limit" for Resource usage.
     
  20. BoukeH

    BoukeH Bit Poster

    Messages:
    3
    Version 12.2.1 (41615) appears to have resolved this issue for me.
     

Share This Page