VT-X Error on MacPro fixed or not?

Discussion in 'Parallels Desktop for Mac' started by amorph, Oct 1, 2006.

  1. webdeck

    webdeck

    Messages:
    21
    Unfortunately, that workaround doesn't work for me. I've put my Mac Pro 3.0GHz to sleep numerous times, leaving it sleeping for 30 seconds, and I get the VT-x error every time I start Parallels. My only guess is that one of my peripherals isn't letting my Mac get into a "deep enough" sleep. When it goes to sleep, it turns off the monitors and spins down the hard drives, but the power light stays lit steadily - isn't is supposed to pulse?

    -Mike
     
  2. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Messages:
    1,507
    You mean that on 1-st start you have VT-x message and do not have VT-x in About box and on 2-nd start you do not have message and have VT-x on in About? Without Mac OS reboot or sleep/wake between attempts?
     
  3. jeffsure

    jeffsure

    Messages:
    10
    Correct (I think.)

    After 1st start from off (cold boot), I open PD and get VT-x message, and do not have VT-x in About box. I then quit PD, sleep/wake the computer, restart PD and do not get VT-x message, and I have VT-x in About box.

    I then restart via Apple menu (warm boot), restart PD, and I do not get VT-x message, and I have VT-x in About box.

    So it seems that I don't get VT-x when booting from machine off. If I enable it by sleep/wake, it stays enabled through restart (via Apple menu.)
     
  4. AlanH

    AlanH Kilo Poster

    Messages:
    316
    I've been working with build 1920 for a few days, and decided to try 1922 to see if the copy/paste was any better from OS X to Win98 (it wasn't). I uninstalled 1920, installed 1922, and had my first kernel panic since I started with Parallels. After a couple of reboots it did run, but it imediately raised the error message about virtualisation being switched off. So I've reverted to 1920, where virtualisation seems to be on consistently, and all is sweetness and light ... except for copy/paste to Win98.
     
  5. bcohen44

    bcohen44

    Messages:
    7
    I just got my new Mac Pro 2.66Ghz (4gig RAM), and would like to try to attempt to go through the rEFIt and vmx-var-set.efi steps (in this thread: http://forum.parallels.com/thread3273.html )to get VT-x enabled. I realize some folks got it working, some did not. I have upgraded my firmware using EFI 1.0 firmware upgrade, and also am running 10.4.8.

    Two questions:

    1. Does anyone who has done the EFI 1.0 firmware update and that is running 10.4.8 on their Mac Pro gone through these steps, and have VT-x working, w/o then having to do the sleep trick anymore?
    2. Are there any risks to attempting these steps? Risks meaning hosing the EFI firmware or something else serious?
     
    Last edited: Oct 12, 2006
  6. webdeck

    webdeck

    Messages:
    21
    I have gone through all of those steps and then some, and none of them solve the Mac Pro VT-x issue. The only thing that fixes it is sleeping. Unfortunately, my Mac Pro refuses to go into a deep enough sleep because of the ATTO UL5D SCSI PCIe card that's installed, so no VT-x for me yet...

    -Mike
     
  7. bcohen44

    bcohen44

    Messages:
    7
    Bummer.....I was hoping it would work...I am dying to see the WinXP performance on the Xeon chips with VT-x

    Wondering if it's worth the effort to try...
     
  8. miker51

    miker51

    Messages:
    41
    Without getting the message about sleeping, how do you know whether VT-x is enabled or not? Is there a log entry or something to use to check?
     
  9. BlueSkyISdotCOM

    BlueSkyISdotCOM Bit Poster

    Messages:
    68
    Mac Pro 2.66 Ghz, 4GB RAM, all Apple updates, Parallels build 1940 and I no longer have the VT-X error.
     
    Last edited: Oct 12, 2006
  10. demnos

    demnos

    Messages:
    7
    Build 1040? Did you mean 1940? If so, I just installed 1940 and still get the same message every time. Am I right in assuming though that no matter what parallels does this problem can not be fixed by them? Isn't this an Apple Firmware issue that Apple needs to fix?
     
  11. Victor

    Victor

    Messages:
    63
    How are you suppost to check if its enabled? The only thing I can see in the About box is if I then click on More info where I find


    Virtual Machine Features:


    Virtualization Mode: Software mode 2
    Remote Session: Off

    But only after I start a VM.

    Or am I looking in the wrong place?
    What difference does it make anyhow?
     
  12. BlueSkyISdotCOM

    BlueSkyISdotCOM Bit Poster

    Messages:
    68
    I meant 1940. On the last Apple software update (10.4.8), both my Mac Pro and Mac Book Pro re-booted themselves after restarting after the upgrade. That 'seemed' like some type of firmware or lower level software update happening. Regardless, I don't get the VT-X message any more.
     
  13. jeffsure

    jeffsure

    Messages:
    10
    Can you try to shut down for 30 seconds or so, then start up again, then start PD and see if you have VT-x? I know that when I shut down instead of restart, I have to sleep my Mac Pro to get VT-x back.

    I'm just wondering if it's just me. Let us know. Thanks!
     
  14. rickross

    rickross

    Messages:
    26
    Mac Pro, dual 2.66 Ghz, 4Gb ram, all Apple updates applied

    On build 1922 I had the VT-x problem all the time.

    On build 1940 I have not seen it occur yet, even after reboots and no sleep.

    Rick
     
  15. Pleiades

    Pleiades

    Messages:
    79
    My VT-X problem on my Mac Pro seems fixed too even if it is an Apple bug. I installed build 1940, tried to start up, but it told me I needed to reboot due to a virtual memory problem. So I rebooted. I DID NOT SLEEP THE MAC. I then ran Parallels with both my WinXP and WinVista virtual machines and neither one warned me about VT-X. After each one started up, I'd go to the about box to check the status and both times it would say that it was in VT-X mode.

    So somehow, a combination of 10.4.8 and Parallels 1940 seems to have made the VT-X problem go away. Before that, I'd always get that error if I hadn't slept the Mac.

    I suppose I'm happy about it, but is it possible PD is misreading the current state of VT-X? Maybe it really is off but PD thinks it's on? Is that possible?

    Is there an independent way of verifying if VT-X is indeed on?
     
  16. rickross

    rickross

    Messages:
    26
    Well, I am sad to report that the VT-x problem has reappeared on my Mac Pro. When I first installed 1940 I didn't see it for a couple of days, but now it is back every time (unless I do the sleep trick.)

    BTW, how much performace are we actually talking about here? Is is a significant loss, or is is actually just a minor item? ANyone have some test metrics?

    Rick
     
  17. SteveCook

    SteveCook

    Messages:
    3
    I have never gotten VT-X to work!

    I have a Mac Pro 3.0ghz, 4GB Ram and I've installed, uninstalled, rebooted, resinstalled every version I can think of even the new 1940 and I have never ever been able to get VT-X to work.

    This put the computer to sleep does nothing!!!!!

    HELP!!!!
     
  18. SteveCook

    SteveCook

    Messages:
    3
    Tried to run the rEFIt as well - still no go!

    Tried to run the rEFIt as well - still no go!

    Steve
     
  19. davert

    davert Bit Poster

    Messages:
    53
    FWIW, still a problem on buidl 1970.
     
  20. palter

    palter

    Messages:
    243
    Again, this is not a Parallels problem, it's a bug in the Apple firmware. Apple will need to issue a firmware update to finally put this problem to rest.
     

Share This Page