Why is there no "External Device" menu item under "Devices" menu?

Discussion in 'Windows Guest OS Discussion' started by charliez, Nov 19, 2015.

  1. charliez

    charliez Bit Poster

    Messages:
    21
    I'm having a strange problem, I can't connect _any_ USB devices to my Windows 7 VM. I don't know if it was always this way as it's a fairly new installation (a week or so).

    I can plug in a USB drive and I'm prompted whether to connect it to the Mac or the Linux VM but _not_ the Windows 7 VM. When I shutdown the Linux VM, the USB drive auto connects to the Mac.

    I can't take control and assign the USB drive to Windows 7 VM because there is no "External Device" menu item.

    What would cause that?

    Thank you, Caesar.
     
  2. charliez

    charliez Bit Poster

    Messages:
    21
    Also note that this VM was migrated from VirtualBox. I just tested installing brand new from the install DVD and it does have "External Devices" and can capture the USB drive.

    How do I get the "External Devices" menu item back? There is a lot of software installed and Windows 7 is already activated in the VM.
     
  3. charliez

    charliez Bit Poster

    Messages:
    21
    One more clue is when using "Action" -> "Configure" -> "Hardware" there is no "USB & Bluetooth" configuration item. Clicking on "+" doesn't list it there either.
     
  4. charliez

    charliez Bit Poster

    Messages:
    21
    I spoke too soon, somehow this time around "USB & Bluetooth" is listed when clicking "+". I added it and now "External Devices" works!
    Hope this helps somebody.
     

Share This Page