Windows 10 very slow and crash-happy

Discussion in 'Windows Guest OS Discussion' started by QuantumDotter, Sep 14, 2020.

  1. QuantumDotter

    QuantumDotter Bit Poster

    Messages:
    10
    Hi all
    I'm wondering if there's something I'm doing wrong. I'm running Windows 10 on Parallels 16 and I'm finding I get really terrible performance. I'm not running anything exotic: Outlook, a handful of Excel files, Chrome, Teams, etc. Not doing any big games, PhotoShop or anything like that. This is on a late 2017 iMac with the quad-core i7 (4.2GHz) and 24GB RAM. I dedicate 2 processor cores and 8GB of RAM to the VM. Graphics set to "Auto" (Best for Retina display).

    When I say terrible performance, I mean that sometimes switching between windows, copying some cells from Excel or opening an email will periodically lock up the VM for up to five minutes. I've also had two complete BSOD-style crashes in the last week. It also tends to slow down everything on my Mac, though not as dramatically (it did crash the Mac once).

    Is there anything I should be doing differently? Should I give it more RAM? Tinker with the graphics settings? Anything else?
     
  2. QuantumDotter

    QuantumDotter Bit Poster

    Messages:
    10
    Hi, anyone have any ideas? Just had a full on Windows crash again today, despite having run the update the dropped today. Again, wasn't running anything outside the standard Office 365 suite and even then didn't have that much open. So I don't know why it would strain the system?
     
  3. MichaelB86

    MichaelB86 Bit Poster

    Messages:
    4
    I am having the same problem. I did a bunch of updates this week, paralells, iOS etc. and haven't been able to determine what it is. I am starting to agree its PD16. I am having windows explorer "not responding" issues a few times an hour, and also in other basic software (365, chrome etc.).
     
  4. UlrichJ2

    UlrichJ2 Bit Poster

    Messages:
    3
    same issue! poor performance on latest Macbook Pro 2021 15' and crashes incl. host system!
    running on batteries is terrible - despite power safe is switched off, it gets switch on again.
    Until update to 16.0.1 no crash anymore when in Powersafe mode (was the case frequently under version 15).
    Parallels blocks power safe on OS X host machine, hence machine continues to run.... heating up.
     
  5. QuantumDotter

    QuantumDotter Bit Poster

    Messages:
    10
    The fun continues. Just today had a full on host system freeze, where everything locked up entirely for about ten minutes except my Teams call kept working. About two hours later, full-on BSOD. At the time, I had open Teams, Outlook and Excel, that's it. Is there anyone from Parallels who can help us here, please? Right now, I'm basically having to give up, as it's just too unstable.
     
  6. QuantumDotter

    QuantumDotter Bit Poster

    Messages:
    10
    I have also tweeted Parallels support about this and got nothing. Feeling pretty ripped off, to be honest.
     
  7. UlrichJ2

    UlrichJ2 Bit Poster

    Messages:
    3
    hint to parallels guys: similar error was V15 two releases before update to V16.... I guess they missed a change ;-)
     

Share This Page