Windows 10 VM freezes for 5 to 15 seconds regularly since High Sierra - Parallels 13.0.1 (42947)

Discussion in 'Windows Guest OS Discussion' started by AndrewB24, Oct 4, 2017.

  1. AndrewB24

    AndrewB24 Bit Poster

    Messages:
    4
    Hello, I've got Parallels Desktop 13 for Mac Pro Edition running on High Sierra with a Windows 10 Pro VM.

    The Mac itself is running completely fine.

    However, the Windows 10 VM freezes a LOT... the freezes last between 5 and 15 seconds usually, and happen maybe 30 seconds to a minute apart. During that time, no keyboard or mouse activity has any influence on the VM. The mouse moves around the windows screen, and I sometimes see a windows spinning circle (telling you to wait). When it Unfreezes, sometimes II suddenly see windows pop up or scroll etc -- I also sometimes get application not responding message. It's almost as if the virtual hard drive access is very slow.

    Again, the Mac itself is fine and nothing else appears as if it's under load.
     
    SANDHYAKUMARIR likes this.
  2. KenT2

    KenT2 Bit Poster

    Messages:
    1
    I have Windows Home (not Pro) and I too am getting the freezes as describe. Further, the Windows Task Bar shuts down until I click on it, including the time and date. I have reinstalled Parallels Tools several times and that does not fix the issue.
     
  3. AndrewB24

    AndrewB24 Bit Poster

    Messages:
    4
    I've also reinstalled Parallels tools.

    I think the (virtual) disk access seems very slow.
     
  4. SethL

    SethL Bit Poster

    Messages:
    1
    I'm having the same issue. The entire system will freeze and force me to restart. I have noticed while monitoring this in Activity Monitor that the Parallels Service is Not Responding when it occurs, but there is plenty of available memory.

    FYI I'm running Windows 10 on Parallels 13, Mac High Sierra. All are completely up to date and patched. There is 16GB of memory on A1386 hardware. 2.Ghz i7
     
  5. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,359
  6. BernhardU

    BernhardU Bit Poster

    Messages:
    1
    I'v the same issue (MBP 13" A1278, 16 GB RAM, i7 2,9 GHz, Win 10 Pro, MacOS High Sierra 10.13.1, SSD 1 TB, Pralles 13.0.1, VM with 2 Kernels, 4 GB RAM, 512 MB VRAM). Nothing helps!
     
  7. JoshuaL3

    JoshuaL3 Bit Poster

    Messages:
    1
    I have a similar problem. Only after upgrading to High Sierra. I use Parallels to demo our software, and this impacts my demos. Is there any support (paid or otherwise) available for this type of production-impacting issue?
     
  8. TrentT1

    TrentT1 Bit Poster

    Messages:
    1
    Arun I read the article that you suggested. It doesn't help. The activity usage shows the only program using the CPU is the windows disk (using between 85 and 145% of the CPU
     
  9. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,359
    Hi @TrentT1 , please check this article and let us know if that works.
     
  10. JonathanW7

    JonathanW7 Bit Poster

    Messages:
    1
    I'm having the same problem with my Windows 10 VM running on the latest version of Parallels 13 and Mac OSX High Sierra. My Windows VM will suddenly stop responding to all requests and some windows will appear "blacked out" on the screen. This has happened once per day for the past two days. Yesterday I reset the VM, reconfigured some performance settings based on the provided article, and everything was running smoothly until today. Today the same freezing issue occurred.

    Today I discovered a workaround that's better than resetting the VM. I had applications running with unsaved work in my VM, so resetting the VM would have been less than ideal. I was able to suspend the VM and then start it from the suspended state. This allowed me to continue working from the same state the VM was in before it froze. Based on this and the way the VM screen frames appear to be blacked out, I'm not sure if the VM is actually freezing, or if Parallels is simply not refreshing the UI graphics for the VM.

    It's also worth noting that I have the VM configured to run in coherence mode with multiple monitors.
     
  11. LarryR3

    LarryR3 Bit Poster

    Messages:
    5
    Just for giggles when it starts slowing down disconnect one of your monitors and reconnect it again after 30 secs to see if that helps. It's the only thing thats been helping me with my thunderbolt display while in coherence. Exiting coherence mode and running full screen helped for a little bit. Not a fix by any means.
     
  12. DomotorG

    DomotorG Bit Poster

    Messages:
    2
    I am seeing the same thing, though Win10 in windowed mode. Sometimes, have to suspend then resume different VMs because the GUI stops being updated, in addition to exteme slowdowns in displays updates that are only sometimes resolved by a complete reboot.
     
  13. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @TrentT1, we released a new update Parallels Desktop 13 for Mac Update 2 Hotfix 1(13.2.0-43213) and this update addresses this issue. To check for updates, click on the Parallels Desktop menu on Mac menu bar and select Check for Updates: http://kb.parallels.com/124262
     
  14. DavidR29

    DavidR29 Bit Poster

    Messages:
    2
    Hello, this appears to be an older post but I'm running into exactly the same issue described here with my Windows 10 VM, and I am running the latest version of 13.3.2. What can I do to correct this problem, as I am experiencing the freezing issue several times a day? Any help appreciated ...
     
    BorjaG likes this.
  15. GaurangJ

    GaurangJ Bit Poster

    Messages:
    5
    As DavidR29 has stated, I am also on 13.3.2 (43368) and this is now actually much more frequent than it was before. Unlike DavidR29, my freezing happens every 30 seconds or so, with NO APPs running on the MAC and ONLY the Windows 10 PRO VM running.
     
    BorjaG likes this.
  16. BorjaG

    BorjaG Bit Poster

    Messages:
    2
    +1.

    • MacOs High Sierra + Parallels 13 + Windows 10 Pro + Visual Studio 2017 + Google Chrome (openning in MacOs).
    • Macbook Pro Touchbar (16Gb RAM, i7 2.7Ghz).
    • All updated (MacOs, Windows, Parallels, ...)

    The vm suddenly stops responding to all requests each 5-10 minutes. Sometimes, all system is blocked (macos) and the only solution is turn off the computer with the power button. After that, I try to open again the vm and parallels stays locked in the "Parallels..." spinner. Then, the only solution is to kill from Activity Monitor all processes that start by "prl_xxx" and restart the macos system (it does not always work, sometimes I have to repeat it 2-3 times).

    I attached two images:
    • Activity monitor, that shows a high cpu usage of the windows 10 vm.
    • Task manager, that shows the process opened at this moment.
    I have the recommended vm configuration (8Gb RAM, 4 processors, hypervisor activated, 3D acceleration is set to DirectX 10, ...)

    Please, we need a solution! it's not productive to work like this.
     

    Attached Files:

    sf10 likes this.
  17. Hi BorjaG. If you have any antivirus/firewall application installed on the Mac, please disable/uninstall it and check for the performance of the virtual machine.
     
  18. BorjaG

    BorjaG Bit Poster

    Messages:
    2
    Hi Sathiya. I have not any antivirus or firewall application installed :(
     
    sf10 likes this.
  19. sf10

    sf10 Bit Poster

    Messages:
    7
    Same issue for me after upgrading to parallels 13. just started today even though I upgraded last week. VM stops responding and then crashes. Windows apps stay active for a while but then stop responding. Osx and mac apps are fine. Parallels 13.3.2 + osx 10.12.6 + windows7. Just tried allocating more RAM to the VM (from 2gb to 5gb of 16gb) so we'll see if that helps. nothing else really to tune in parallels. this is really annoying.

    !!!Found a sol'n from Parallels tech support: Go to Apple logo > System Preferences > Energy Saver, then turn OFF the 'Automatic graphics switching' checkbox.!!!
     
    Last edited: Jul 26, 2018
  20. sf10

    sf10 Bit Poster

    Messages:
    7
    This is now critical for me. I need to give presentations and I cannot have my VM crash. It appears there is no fix so I'm going to have to look at other non-Parallels solutions. It is really a shame because I've used Parallels for many, many years without issue.
     

Share This Page