Windows 10 VM in Parallels 11 Extremely Slow

Discussion in 'Windows Guest OS Discussion' started by NicholasV2, Oct 18, 2015.

  1. NicholasV2

    NicholasV2 Bit Poster

    Messages:
    7
    First let me say thanks in advance for anyone who responds and tries to assist me with this. I'm hoping someone from Parallels will reach out as it seems theres a gap in their knowledge base related to this issue. That or maybe I just haven't dug deep enough, but then again I don't really think I should have to.

    Now as for background on my issue, I had been running Windows 8 on Parallels 8 for 3 - 4 years with no performance issues to speak of. I'd always get notifications when a new version of Parallels was released and considered upgrading before, but honestly saw no need and figured "if it ain't broke don't fix it". You know that old saying. Well it seems I should have stuck to my guns.

    Long story short, I wanted to upgrade Win 8 to Win 10 and figured it would be a decent idea to buy Parallels 11 since no earlier version of the software supports the new MS OS. OK, so I upgrade to Parallels 11, get things humming along again, and sure enough Win 10 starts to run really, really slow. I don't have an SSD, but I do have 16GB of RAM and performance has never been an issue before installing Parallels 11. When pressing the start button, Cortana, or the notification icon in Win 10 my iMac struggles to process the command, sometimes lagging a good 30 seconds and sometimes not completing the process at all. Things as simple as quickly typing in Word has the system struggling to keep up, something which is completely unacceptable. Opened up Activity Monitor in OS X and sure enough Win 10 VM is using between 100% and 110% CPU. I didn't even think that was possible!

    As for troubleshooting, I followed the uninstall-reinstall procedure found in KB 116263. Ran OK for about five minutes and then back to the same thing. Tried KB 112091 for good measure and still no dice.

    So can someone please show me the light and restore my faith in Parallels? Otherwise I might as well go back to my many years old Parallels 8 and pray for the best. Hoping I can be shown that my investment in the new software wasn't a complete waste. TIA
     
    OzguerK likes this.
  2. NicholasV2

    NicholasV2 Bit Poster

    Messages:
    7
    Can no-one (Parallels Support...) assist me with this?
     
  3. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,142
    Hi Nicholas, Please follow the steps mentioned below:
    1.Make sure Time Machine backup is not taking place while you are running the virtual machine. The backup creation process may slow down overall system performance.
    2.In the Parallels Desktop menu, go to Preferences > Advanced. Make sure "Detailed log messages" option is not enabled
    3.Go to Actions > Configure > Options > Optimization > disable Free Space: Real-time Virtual Disk Optimization.
     
  4. NicholasV2

    NicholasV2 Bit Poster

    Messages:
    7
    Paul, that didn't work but I appreciate your response.

    The Parallels 11.1.0 update that I downloaded and installed today does seem to have resolve the issue though. I'm hoping this is a permanent fix.
     
  5. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,142
    Glad your issue has been resolved in the new build. Feel free to reach out anytime. We are here to help.
     
  6. NicholasV2

    NicholasV2 Bit Poster

    Messages:
    7
    My issue started to occur again in December and continues to this day. I tried to request support using a support code generated in Parallels, but it states I have the wrong support code. Can you please help me get this resolved?
     
  7. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,142
    Hello NicholasV2, please be informed that Parallels Desktop 11 Update 1 Hotfix 3 (11.1.3-32521) was released and the issue has been addressed. Please update Parallels Desktop to the latest build. Latest version always available here: http://www.parallels.com/directdownload/pd11/ Please note that Parallels Tools also needs to be updated (Actions > Update Parallels Tools) and let us know how it works. Thanks!
     
  8. NicholasV2

    NicholasV2 Bit Poster

    Messages:
    7
    I've updated to the latest version and also completely removed and reinstalled Parallels tools using http://kb.parallels.com/en/117753. It uses low CPU for a few minutes and then goes right back up to over 100%. This is very frustrating. I wish I had just stayed on Parallels 8 which worked fine.
     
  9. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,142
    Since we need to investigate deeper, please email us the issue description along with the screenshot of the CPU usage to cs@parallels.com, so we can check it for you.
     
  10. NicholasV2

    NicholasV2 Bit Poster

    Messages:
    7
    Thanks for your response. I've sent the email as directed.
     
  11. JohnS20

    JohnS20 Bit Poster

    Messages:
    3
    My experience is identical to NicholasV2. I've gone through the procedure to create a new VM and to uninstall/reinstall Parallels 11 and Parallels Tools. The program worked OK for a short while and then resumed the behavior of very high consumption of CPU resources. (Over 100% for much of the time with Windows 10 running; I don't understand how it can consume more than 100%.) I'm now running Parallels 11.1.3 (32521). I'm keenly interested to see what you learn from looking at NicholasV2's problem.

    Cheers,
    John
     
  12. Arunn

    Arunn Parallels Support

    Messages:
    300
    Hi John, Kindly check if the RAM memory you have provided for Windows 10 is more than or equal to 2 GB. If it is less than 2 GB please increase the RAM memory & restart Windows to check the performance.
     
  13. NicholasV2

    NicholasV2 Bit Poster

    Messages:
    7
    John,
    I spent a lot of time with Parallels support trying to resolve the issue I was having. In my case, it turned out to be excessive CPU usage by a Windows 10 process called "Runtime Broker". According to Microsoft, this process "helps manage permissions on your PC for apps from Windows Store". I had no need for it, so a Parallels Level 2 support representative turned it off for me in the registry. Take a look at the processes tab in Task Manager and see if Runtime Broker is also the culprit in your case. If it is, I believe the instructions given in post #4 of the following thread detail how to disable this process: http://www.tenforums.com/network-sharing/7907-runtime-broker-process.html. Obviously be careful when making changes to the registry should you decide to do so and seek professional assistance if you aren't comfortable.
     
  14. Dhruba@Parallels

    Dhruba@Parallels Kilo Poster

    Messages:
    779
    Hi all, yes you can try the steps suggested by @NicholasV2. Please make sure to take a snapshot before making any changes in Windows registry.
     
  15. JohnS20

    JohnS20 Bit Poster

    Messages:
    3
    I checked the RAM designated for Windows 10 and increased it from 2GB to 4GB. I also disabled Runtime Broker and shut down OneDrive. Then I restarted Windows 10. Windows apps appear to be running faster, for now. MacOS apps may be somewhat I'll keep an eye on this. Many thanks to Dhurba and NicholasV2 for their constructive suggestions.
     
  16. Dhruba@Parallels

    Dhruba@Parallels Kilo Poster

    Messages:
    779
    Great! Let us know if you have more questions.
     
  17. JohnS20

    JohnS20 Bit Poster

    Messages:
    3
    After a week, the slow performance returned with a vengeance. Following a fresh boot-up of my Mac, Parallels starts OK and doesn't consume a lot of resources according to the Activity Monitor. But once I start Windows 10, everything in the VM and Mac OS slows to a crawl. After shutting down Win 10 and quitting Parallels, the computer remains sluggish.
    I'm going to enlarge the virtual disk for Win10 (after making a backup, of course). Are there any other suggestions? This issue is affecting my job!
    Thanks,
    John
     

Share This Page