Windows 11 ARM running slow

Discussion in 'Installation and Configuration of Parallels Desktop' started by colins7, Aug 18, 2023.

  1. colins7

    colins7 Bit poster

    Messages:
    8
    Hi all, I installed Parallels 18 Standard on my new imac M1 and also installed windows11 ARM and windows is running quite slow. I have only one application that I installed my windows VM and thats a trading program, technical analysis software. I would say that when I'm using this program its about 40% slower then my old iMac that was running Parallels 17 on an intel chip. My installation was the default install.
    Ive only had Ver18 for 3 weeks any suggestions on how I can make my Windows run faster would be much appreciated, Should I have purchased Parallels pro?
    Regards
    My M1 iMac has 8GB Ram
     

    Attached Files:

    • Arm.png
      Arm.png
      File size:
      273.9 KB
      Views:
      11
  2. Trishna Oobeyram

    Trishna Oobeyram Staff Member

    Messages:
    267
    Hello @colins7
    For further investigation, kindly provide us with a technical report (right-click Parallels icon in Dock > Help > Send technical data > check "Attach screenshots..." > press Send Report) and send the report's 9-digit ID in a reply.
    Thank you!
     
  3. colins7

    colins7 Bit poster

    Messages:
    8
    433466623
    thanks
     
  4. colins7

    colins7 Bit poster

    Messages:
    8
    Hello Trishna
    On Saturday 19/8 I uploaded the file and sent the report number back to you and was wondering if you have assessed the issue I'm experiencing with Win 11 ARM running slow.
    Thankyou
    Colin
     
  5. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    500
    Hello,
    Thank you for your response.
    Try increasing the amount of RAM assigned to the VM to 4GB (shut down VM > open VM configuration > Hardware tab > CPU & Memory > Manual > assign 4 GB).
    If the issue remains, please collect a fresh technical report at the moment of reproduction and share the report ID with us. I'd also appreciate if you recorded the issue and attached it to the report (or just share the link to it).
    One more question - does the issue happen only when you run this app inside the VM or it's a general slowness of the VM?
     
  6. colins7

    colins7 Bit poster

    Messages:
    8
    Hello, I have set the RAM to 4GB and it seems to be a little bit better but now experiencing a little lag in my apple OS.
    I have sent the data to you the Code is - 433849351.
    It's the slowness of the VM - when Im working on my program within VM everything runs slow, I is a technical charting program in Windows 11 ARM it dose do a lot of number crunching and producing charts, My old iMac 2017 running Parallels 17 was a lot faster than what I am running now. iMac 2021 M1 chip.
    I notice that I have a old link for windows 10 showing in control centre, should this be deleted??
    see attached
    Cheers
    Win10
     

    Attached Files:

Share This Page