Windows 11 thinks I'm on a Public Network -- how to change?

Discussion in 'Windows Virtual Machine' started by ScottB47, Aug 19, 2023.

  1. ScottB47

    ScottB47 Bit poster

    I'm running Parallels Desktop 18 on an Intel-based Mac, OS 13.4.1 (Ventura), and the guest OS is Windows 11. I noticed that Windows thinks that the network connection is Public, even though it's not, and Windows Security (or is it Defender) thus is scrutinizing everything and dragging down performance. How do I force it to always treat the connection as Private or even Domain? I've tried researching this and so far haven't found anything useful.

  2. Adeboye Adeotan

    Adeboye Adeotan Staff Member

    Best Answer
    Hello ScottB47,

    Kindly perform the following steps to attempt a resolution of this issue.

    1. Start your Windows virtual machine.
    2. Select the Start button, then type settings. Select Settings > Network & Internet > Ethernet.
    3. On the Ethernet network screen, under the Network profile type, select Private.
    Kindly let us know if this resolves the issue.
    Mikhail Ushakov likes this.
  3. ScottB47

    ScottB47 Bit poster

    It appears to have resolved the issue -- hopefully it doesn't reset itself later, but now I know how to fix it! Thank you.
  4. IanS22

    IanS22 Bit poster

    The error's message says any web site it blocks "uses encryption to protect your information. When Microsoft Edge tried to connect . . . , the website sent back unusual and incorrect credentials. This may happen when . . . a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Microsoft Edge stopped the connection before any data was exchanged.

    You can't visit 'it' right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later."

    I've tried everything to get rid of it, but the error still remains.

Share This Page