Windows not repainting/refreshing correctly

Discussion in 'Windows Guest OS Discussion' started by flakshack, Jan 4, 2013.

  1. flakshack

    flakshack Bit Poster

    Messages:
    24
    Having a problem where window contents do not display correctly. In the image below, you can see that a popup menu only displays the first few lines. If I run my mouse over the rest of the menu, it will repaint correctly. This happens not just with menus, but with dialog boxes as well (title bar with minimize and maximize buttons just appears white until I click on it).

    [​IMG]

    Running Windows 7 x64 (Coherence) in latest Parallels 8 on my Mountain Lion MacBook. Video settings are 256 MB with 3d turned off.

    I've tried turning off Crystal Mode, but it still happens. I also tried reinstalling the Parallels Tools/Drivers.

    I've been using Parallels for years and never had this problem until recently. Not sure what has changed.
     
  2. nickolay

    nickolay Bit Poster

    Messages:
    3
    Try turning 3D acceleration on (Virtual Machine menu -> Configure... -> Hardware tab -> Video). This is a fix suggested by support that worked for me.

    This started happening to me as well when I updated Parallels desktop from 7 to 8. (In my case the guest is XP, host is 10.7.)

    Support said the glitch was an unintended side-effect of other improvements that went into PD 8 and that unless turning 3D acceleration on causes other problems, this is the fix (i.e. keeping 3D acceleration on will be required).

    I'm a little surprised no-one else complained about this issue though...
     
  3. BrianNydish

    BrianNydish Bit Poster

    Messages:
    42
    Running Windows 7 x64 (Coherence) in latest Parallels 8 on my Mountain Lion MacBook. Video settings are 256 MB with 3d turned off.



    Turn off Coherence. It has not worked correctly since Mountain Lion.
     
  4. flakshack

    flakshack Bit Poster

    Messages:
    24
    Seems to be better since enabling 3D. Thanks.
     
  5. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Messages:
    643
    Hi,

    Is it just better, or you don't observe the issue anymore?
    If you do, please send us the problem report: http://kb.parallels.com/9058 and post the ID here
     
  6. flakshack

    flakshack Bit Poster

    Messages:
    24
    It seemed a little better, but I still had problems. To be honest, I switched back over to Fusion until you guys get it figured out.
     
  7. flakshack

    flakshack Bit Poster

    Messages:
    24
    I take it back...Fusion is useless. Guess I'll be doing Parallels Full Screen for a while.
     
  8. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Messages:
    643
    Please send us the problem report: http://kb.parallels.com/9058 and post the ID here
     
  9. flakshack

    flakshack Bit Poster

    Messages:
    24

Share This Page