Workaround found for 'Black Screen' on Mac 10.9.3 Guest

Discussion in 'Mac OS X Guest OS Discussion' started by AshkanS, May 16, 2014.

  1. AshkanS


    Under Parallels Desktop 9 for Mac, upgrading a Mac OSX guest VM to 10.9.3 (official) results in a 'black screen' upon reboot.

    Multiple other people have identified this issue as well:

    The issue appears to be due to the Parallels Tools guest video driver not being compatible with 10.9.3
    I've managed the following workaround which allows the guest to boot (and "Shared Folders" work), but the video is limited to the default 1024x768.

    I hope Parallels resolves this quickly. Based on the above posts, this has been a Known Issue since early April.


    1. Configure the Guest to 'Select Boot Device on Startup'
    > Guest -> Configure -> Hardware -> Boot Order -> 'Select boot device on Startup' is checked.

    2. Boot the Mac guest OS into 'Single User' mode
    > Start the Guest, hit 'return' when prompted to enter startup options, then indicate '-s' as a boot option

    3. Mount the root partition 'read/write' by issuing the command
    > Enter 'mount -o update /' on the command prompt once the guest has booted.

    4. Delete Parallels tools video Kernel extension.
    > rm -rf /System/Library/Extensions/prl_video.kext

    5. Reboot the machine
    > Enter 'reboot' on the command line

    That should give you access to the VM, but the video limited to default (1024x768)
    Last edited: May 16, 2014
  2. ClaytonG


    I updated to 10.9.3 through the app store in my guest. I don't have a black screen problem, I just get stuck on the grey boot screen with the grey spinner frozen. I tried your workaround but it didn't help.
  3. beta_shinkle


    I just updated 2 VMs to 10.9.3 and both hang at the boot spinner frozen. :(
  4. Breakout


    Parallels -- Where do you stand on this issue? This is creating a serious problem for my development effort. Please advise ASAP!!!
  5. Breakout


    Your step 2 is not appearing for me. I'm presented with two images, the first to boot OS X and the second to boot the Recovery Partition. Striking Enter on either one doesn't provide an option to enter -s. I did set -s on the boot options on the Parallels config screen but to no avail. What else might I try to boot into single user mode and/or a Safe mode? Thanks!
  6. Breakout


    Never mind. Found it. When presented with the two boot options one must strike the Space key. There will be a prompt at the bottom left of the display where -s may be entered. I've successfully booted and can see a display again instead of just the black screen. Thank you soooooo much!!!

    Hey Parallels, let's get this fixed!!!! There's no excuse for something so easy to test to not have tested at all.
  7. etresoft

    etresoft Bit Poster

    I suggest everyone just restore from backup and wait for a fix. This is a great opportunity to use Undo Disks. I don't know about Parallels, but Apple now uses "continuous integration". That means that there is really no such thing as a develop, build, test, release cycle anymore. All releases are beta releases. This applies to your native hardware and VMs. Parallels already knows this and was probably waiting for 10.9.3 to be officially released before supporting it. Otherwise, they could have easily wasted a lot of time due to a last-minute change that Apple threw on as 10.9.3 headed out the door. Anybody notice the /Users issue that needed a fix after 10.9.3?

    It will take them some time to figure out the changes that Apple made to the video drivers in this "minor update" release. We aren't Apple's target market, so Apple really doesn't care if VMs work or not. I migrated to VMs from a partitioned boot drive because Apple doesn't support that configuration anymore either. If you can't afford or don't want to deal with a dedicated machine for each OS, then a VM is your only option. That means you have to wait for the VM vendor to support it.
  8. Breakout


    Perhaps that's reasonable if Parallels mentioned this somewhere. For example, I saw nothing about this update being pushed as a beta. Did you? Perhaps that's reasonable if Parallels had a popup during portions of the install, including this video driver, where it version checked the OS and allowed the user to decide if the driver should be installed in an as-of-yet untested version. Don't you? And perhaps it's reasonable if Parallel's actually tested this screen driver issue when the OS revision was publicly released and put some code together that automated the process of undoing the driver so I didn't have to spend an hour figuring out how to accomplish it this morning. Don't you? And perhaps a new release of Parallels where that driver ISN'T able to be installed for the very reason that it just doesn't work rather than leaving us to fend for ourselves might have been helpful. Don't you feel that way, too?

    I've been developing software for 33 years, including display drivers, and it just has never been this bad with product releases. It's not just from the Parallels camp. It's OS X. It's iOS. It's FB on both the web and the app. Who has to release three versions in two days like FB two iterations ago in their app? And no sense of embarrassment at all?!?!?! So much for the SCRUM!
  9. MHamson


    Just a reminder... and I know that this is not optimal... but you can use screen sharing (if its enabled) as well as ssh. This will at least get you past the black screen, which is what I am doing.
  10. waffffffle


    Thank you, that worked for me. I can now get the VM to boot.

    I wish Parallels would fix this. It's been driving me nuts for days. I reinstalled Mavericks only to figure out that the same problem happens upon upgrade to 10.9.3.
  11. AshkanS


    They're not going to give it any serious attention unless people actually file bug reports and complain.
    As far as I can tell, all tech support and development is outsourced and the company doesn't prioritize customer support *at all*. I've filed numerous bugs about advertised features not working (i.e USB 3 support on Mac guest, Shared Folder instability, and now this issue with Mavericks).

    Parallels is far and away the least reliable VM tools maker on the market. I made the mistake of recommending their tools to a number of clients but am in the process of recommending that they switch back to VMware and/or Virtualbox.
  12. thesmxp

    thesmxp Bit Poster

    Until I saw this thread I thought I was seriously hosed. It would be nice to hear something from Parallels. This is a major issue.
  13. Ram@Parallels

    Ram@Parallels Parallels Support

    Dear All,

    Parallels Development Team is aware of the issue and is working on a fix. Fix should be included to one of the upcoming builds of Parallels Desktop.
    Once the new build is out, you can see the updates summary at for more details.
  14. AHunter3

    AHunter3 Bit Poster

    How about those of us still using Parallels 8 for Mac? Any chance of the fix being rolled out to us as well?
  15. DarkonJohn


    Exactly the same situation for me. Thanks OP for posting the workaround...worked great for me and saved me from losing a VM I had put a great deal of time into creating.
  16. KoreyS



    When can we expect an update? OSX is currently hardly usable; even with the work around.
  17. Robert King

    Robert King

    Has this been fixed yet ?
  18. quokka


    No. It's a major enough issue that I expect it to be part of the next update, but there is no indication when that may happen.

    Incidentally, the majority here report a "Black Screen" but my systems were hanging on the grey screen with the logo and spinner. Removing the video driver is still the correct fix, so I'm not sure why some would get black, and others get the grey screen.
  19. rimorton


    Funny, I just caved and upgraded to 9 hoping to correct this issue. I guess I should have saved my $40 and read the forum. Glad there is a work around, but this really should not take this long to fix.

  20. rcstevensonaz

    rcstevensonaz Bit Poster

    It has been over month since this issue hit. Have we heard anything from Parallels other than the single (and belated) statement saying "we know there is an issue... it will be fixed someday"?

    I have not seen anything in this thread or the KB article that was referenced. So maybe this is covered else where or is Parallels simply not providing any update information on this?

Share This Page